newt-tcl_0.52.20-8_i386.deb


Advertisement

Description

newt-tcl - NEWT module for Tcl

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename newt-tcl_0.52.20-8_i386.deb
Package name newt-tcl
Package version 0.52.20
Package release 8
Package architecture i386
Package type deb
Category devel::lang:tcl devel::library interface::text-mode interpreters role::devel-lib role::program
Homepage https://pagure.io/newt
License -
Maintainer Alastair McKinstry <mckinstry@debian.org>
Download size 32.80 KB
Installed size 62.00 KB
This module allows you to build a text UI for your Tcl scripts
using newt.

Alternatives

Package Version Architecture Repository
newt-tcl_0.52.20-8_amd64.deb 0.52.20 amd64 Debian Main
newt-tcl - - -

Requires

Name Value
libc6 >= 2.4
libnewt0.52 = 0.52.20-8
libpopt0 >= 1.14
libslang2 >= 2.2.4
tcl8.6 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package newt-tcl_0.52.20-8_i386.deb
Source Package newt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install newt-tcl deb package:
    # sudo apt-get install newt-tcl

Files

Path
/usr/lib/whiptcl/whiptcl.so
/usr/share/doc/newt-tcl/changelog.Debian.gz
/usr/share/doc/newt-tcl/changelog.gz
/usr/share/doc/newt-tcl/copyright

Changelog

2018-09-27 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-8) unstable; urgency=medium
* Don't ship /etc/newt/palette.original. Closes: #909030
2018-09-17 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-7) unstable; urgency=medium
* Standards-Version: 4.2.1; no changes required
* Don't hard-code Automake version. Closes: #908739
* Grammar fix in description. Closes: #908740
* Close vcs reference bug. Closes: #572753
* Delete old palette.original files, too. Closes: #784390
2018-08-18 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-6) unstable; urgency=medium
* Bump automake version to 1.16. Closes: #906494
* Standards=Version: 4.2.0; no changes required
2018-06-28 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-5) unstable; urgency=medium
* Drop ancient X-Python*-Version statements from d/control
* Standards-Version: 4.1.4; no changes required
* Rebuild against python3.7
2018-03-19 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-4) unstable; urgency=medium
* Drop Priority: important for whiptail, to minimize system size.
Closes: #893563
* Replace dependency of newt-tcl from tcl8.3 | tcl8.4 | tcl8.5 to tcl8.6
since the package is built using Tcl 8.6. Closes: #893136
* Minor corrections to whiptail.1 by Bjarni Ingi Gislason. 
Closes: #890044
* Drop references to obsolete dbg packages, dependencies
2018-03-07 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-3) unstable; urgency=medium
* Create udeb. Closes: #871033
* Update watch file to look at releases.pagure.io
* Delete obsolete patches
* Set VCS to salsa.debian.org/mckinstry/newt
2018-01-30 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-2) unstable; urgency=medium
* Standards-Version: 4.1.3
* Drop Priority: extra in favour of optional
* Drop Priority: important on lib package
* Drop dh-autoconf, autoconf B-D as automatic on DH 10
* Change homepage to https://pagure.io/newt
* Drop broken VCS-Git
* Drop obsolete pre-depends
* Drop obsolete alternatives. Closes: #868056
* Delete old /etc/newt/palette if left over on previous install
* Fix fail-to-crossbuild due to Python dependencies.
Thanks to Helmut Grohe. Closes: #888300
2017-05-03 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.20-1) unstable; urgency=medium
* New upstream release. Closes: #847729
2016-10-15 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.19-1) unstable; urgency=medium
* New upstream release
- refresh patches. Lanugage patches merged upstream
* DH_COMPAT=10, with debhelper depends updated
* Standards-Version now 3.9.8
* Remove -dbg packages in favour of autogenerated -dbgsym packages
2015-12-29 - Alastair McKinstry <mckinstry@debian.org>
newt (0.52.18-2) unstable; urgency=medium
* bidi.patch: Look for libfribidi in multi-arch directory.
Closes: #794691
* Add comments to all patches.
* debhelper >= 9.20141010 required for multstage build
* Remove obsolete conffile. Closes: #793690
* Ack. bugs fixed in older versions: Closes: #351367, #714786, #5799412.
* Make python-* extensions Multi-Arch: same
* Add dh-python to Build-Depends.

See Also

Package Description
nextcloud-desktop-cmd_2.5.1-3+deb10u1_i386.deb folder synchronization with an Nextcloud server - cmd client
nextcloud-desktop-common_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - common data
nextcloud-desktop-doc_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - documentation
nextcloud-desktop-l10n_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - localization
nextcloud-desktop_2.5.1-3+deb10u1_i386.deb Nextcloud folder synchronization tool
nextepc-core_0.3.10+nods-3_i386.deb Evolved Packet Core for LTE (Shared Files)
nextepc-mme_0.3.10+nods-3_i386.deb Evolved Packet Core - Mobility Management Entity (MME)
nextepc-pgw_0.3.10+nods-3_i386.deb Evolved Packet Core - Packet Data Network Gateway (PDN-GW)
nextepc-sgw_0.3.10+nods-3_i386.deb Evolved Packet Core - Serving Gateway (SGW)
nextepc_0.3.10+nods-3_all.deb Evolved Packet Core implementation for LTE (metapackage)
nexuiz-data_2.5.2-9_all.deb Nexuiz game data files
nexuiz-music_2.5.2-9_all.deb Nexuiz music files
nexuiz-server_2.5.2+dp-7_all.deb Standalone server for Nexuiz Classic
nexuiz-textures_2.5.2-9_all.deb Textures for Nexuiz
nexuiz_2.5.2+dp-7_all.deb Fast-paced 3D first-person shooter
Advertisement
Advertisement