newlisp_10.7.1-1_i386.deb


Advertisement

Description

newlisp - LISP like, general purpose scripting language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename newlisp_10.7.1-1_i386.deb
Package name newlisp
Package version 10.7.1
Package release 1
Package architecture i386
Package type deb
Category lisp uitoolkit::ncurses
Homepage http://www.newlisp.org
License -
Maintainer Sergio Durigan Junior <sergiodj@sergiodj.net>
Download size 595.17 KB
Installed size 2.12 MB
newLISP is a scripting language for developing web applications and
programs in general and in the domains of artificial intelligence
(AI) and statistics.

Alternatives

Package Version Architecture Repository
newlisp_10.7.1-1_amd64.deb 10.7.1 amd64 Debian Main
newlisp - - -

Requires

Name Value
libc6 >= 2.15
libffi6 >= 3.0.4
libreadline7 >= 6.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package newlisp_10.7.1-1_i386.deb
Source Package newlisp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install newlisp deb package:
    # sudo apt-get install newlisp

Files

Path
/usr/bin/newlisp
/usr/bin/newlispdoc
/usr/share/doc-base/newlisp
/usr/share/doc/newlisp/CREDITS.gz
/usr/share/doc/newlisp/CodePatterns.html
/usr/share/doc/newlisp/changelog.Debian.gz
/usr/share/doc/newlisp/changelog.gz
/usr/share/doc/newlisp/copyright
/usr/share/doc/newlisp/manual_frame.html
/usr/share/doc/newlisp/newLISP-10.7.1-Release.html
/usr/share/doc/newlisp/newLISPdoc.html
/usr/share/doc/newlisp/newlisp_index.html
/usr/share/doc/newlisp/newlisp_manual.html
/usr/share/doc/newlisp/guiserver/guiserver.lsp.html
/usr/share/doc/newlisp/guiserver/index-gs.html
/usr/share/man/man1/newlisp.1.gz
/usr/share/man/man1/newlispdoc.1.gz
/usr/share/newlisp/modules/canvas.lsp
/usr/share/newlisp/modules/cgi.lsp
/usr/share/newlisp/modules/crypto.lsp
/usr/share/newlisp/modules/ftp.lsp
/usr/share/newlisp/modules/getopts.lsp
/usr/share/newlisp/modules/gsl.lsp
/usr/share/newlisp/modules/infix.lsp
/usr/share/newlisp/modules/mysql.lsp
/usr/share/newlisp/modules/odbc.lsp
/usr/share/newlisp/modules/plot.lsp
/usr/share/newlisp/modules/pop3.lsp
/usr/share/newlisp/modules/postgres.lsp
/usr/share/newlisp/modules/postscript.lsp
/usr/share/newlisp/modules/smtp.lsp
/usr/share/newlisp/modules/smtpx.lsp
/usr/share/newlisp/modules/sqlite3.lsp
/usr/share/newlisp/modules/stat.lsp
/usr/share/newlisp/modules/unix.lsp
/usr/share/newlisp/modules/xmlrpc-client.lsp
/usr/share/newlisp/modules/zlib.lsp
/usr/share/newlisp/util/newlisp.vim
/usr/share/newlisp/util/syntax.cgi

Changelog

2017-02-09 - Sergio Durigan Junior <sergiodj@sergiodj.net>
newlisp (10.7.1-1) unstable; urgency=medium
* New upstream version 10.7.1
* Updating patches to reflect new upstream release.
2017-01-30 - Sergio Durigan Junior <sergiodj@sergiodj.net>
newlisp (10.7.0-4) unstable; urgency=medium
* Fix shared library loading for modules.
Upstream uses a system for dlopen'ing shared libraries that is not
very robust.  They depend on libraries being installed on full paths,
which can break things when you move from one system to another.
Because of this, a fix had to be implemented downstream in order to
use dlopen's functionality of automatically searching the system
libraries when you pass just the file name to it.  This also has the
benefit of not trying to load libraries from /usr/local, which can be
dangerous. (Closes: #852259)
2016-07-14 - Sergio Durigan Junior <sergiodj@sergiodj.net>
newlisp (10.7.0-3) unstable; urgency=medium
* Silence a warning when compiling on GNU/kFreeBSD.
When enabling builds on GNU/kFreeBSD, I forgot to forward-declare the
prototype for strptime, which generated a warning when compiling the
code.
* Fix FTBFS on PowerPC 32-bit.
The fourth argument to semctl must be a 'union semun', but the
original code passes 0 instead.  This makes the build fail on PowerPC
32-bit, because of the calling convention for this architecture.
(Closes: #828807)
2016-07-02 - Sergio Durigan Junior <sergiodj@sergiodj.net>
newlisp (10.7.0-2) unstable; urgency=medium
* Do not use -m32/-m64 when building.
The use of -m32/-m64 flags is not needed and actually causes a bunch
of errors on some architectures (like x32). (Closes: #828806)
* Update Vcs-* links.
* Support GNU/kFreeBSD builds.
A few adjustments needed to be made in the makefiles and in the
source-code in order to support GNU/kFreeBSD properly.  First, -ldl
has to be used in the linking phase in order to use the dlopen family
of functions.  The use of FD_COPY also needed to be adjusted and the
code is using memset instead (just like it is done in GNU/Linux).
Finally, a new dependency on libncurses5-dev had to be added to
Build-Depends for kfreebsd-any because newLISP uses -lncurses on the
linking phase. (Closes: #828805)
2016-06-19 - Sergio Durigan Junior <sergiodj@sergiodj.net>
newlisp (10.7.0-1) unstable; urgency=medium
* Initial release of newLISP. (Closes: #425456)

See Also

Package Description
newmail_0.5-2+b2_i386.deb Notificator for incoming mail
newpid_10_i386.deb run a command in a new PID namespace
newrole_2.8-1_i386.deb SELinux core policy utilities (newrole application for RBAC/MLS)
newsbeuter_2.9-8+b1_i386.deb text mode rss feed reader with podcast support
newsboat_2.13-1+deb10u1_i386.deb text mode rss feed reader with podcast support
newt-tcl_0.52.20-8_i386.deb NEWT module for Tcl
nextcloud-desktop-cmd_2.5.1-3+deb10u1_i386.deb folder synchronization with an Nextcloud server - cmd client
nextcloud-desktop-common_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - common data
nextcloud-desktop-doc_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - documentation
nextcloud-desktop-l10n_2.5.1-3+deb10u1_all.deb Nextcloud folder synchronization - localization
nextcloud-desktop_2.5.1-3+deb10u1_i386.deb Nextcloud folder synchronization tool
nextepc-core_0.3.10+nods-3_i386.deb Evolved Packet Core for LTE (Shared Files)
nextepc-mme_0.3.10+nods-3_i386.deb Evolved Packet Core - Mobility Management Entity (MME)
nextepc-pgw_0.3.10+nods-3_i386.deb Evolved Packet Core - Packet Data Network Gateway (PDN-GW)
nextepc-sgw_0.3.10+nods-3_i386.deb Evolved Packet Core - Serving Gateway (SGW)
Advertisement
Advertisement