mupdf-tools_1.14.0+ds1-4_i386.deb


Advertisement

Description

mupdf-tools - command line tools for the MuPDF viewer

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename mupdf-tools_1.14.0+ds1-4_i386.deb
Package name mupdf-tools
Package version 1.14.0+ds1
Package release 4
Package architecture i386
Package type deb
Category interface::commandline role::program text works-with-format::pdf
Homepage http://mupdf.com/
License -
Maintainer Kan-Ru Chen (陳侃如) <koster@debian.org>
Download size 19.25 MB
Installed size 33.85 MB
MuPDF is a lightweight PDF viewer and toolkit written in portable C.
It also reads XPS, OpenXPS and ePub documents.
This package contains command line tools using the MuPDF library:
- mutool - tool for clean, extract, inspect PDF documents and
render PDF/XPS/CBZ documents.

Alternatives

Package Version Architecture Repository
mupdf-tools_1.14.0+ds1-4_amd64.deb 1.14.0+ds1 amd64 Debian Main
mupdf-tools - - -

Requires

Name Value
libc6 >= 2.27
libfreetype6 >= 2.6
libharfbuzz0b >= 0.9.11
libjbig2dec0 >= 0.11
libjpeg62-turbo >= 1.3.1
libopenjp2-7 >= 2.0.0
zlib1g >= 1:1.2.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mupdf-tools_1.14.0+ds1-4_i386.deb
Source Package mupdf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mupdf-tools deb package:
    # sudo apt-get install mupdf-tools

Files

Path
/usr/bin/mutool
/usr/share/doc/mupdf-tools/NEWS.Debian.gz
/usr/share/doc/mupdf-tools/README
/usr/share/doc/mupdf-tools/changelog.Debian.gz
/usr/share/doc/mupdf-tools/changelog.gz
/usr/share/doc/mupdf-tools/copyright
/usr/share/man/man1/mutool.1.gz

Changelog

2019-03-16 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.14.0+ds1-4) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Avoid being smart about keeping only a single reference to the buffer
(CVE-2018-16647)   
(Closes: #924351)
* Fix text used as clip mask in pdfwrite device (CVE-2018-16648)
(Closes: #924351)
* Fix typo in pdf write device
[ Kan-Ru Chen ]
* Add more options to mupdf wrapper and display usage correctly
2019-01-19 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.14.0+ds1-3) unstable; urgency=high
* d/patches: import upstream fixes for various bugs.
Fixes CVE-2018-18662, CVE-2019-6131, CVE-2019-6130
(Closes: #912013, #918970, #918971)
* d/control: Bump Standards-Version to 4.3.0, no changes required
* Fix FTCBFS
+ Supply a cross LD for wrapping fonts.
+ Supply PKG_CONFIG to all make targets.
Thanks to Helmut Grohne for the patch (Closes: #913515)
* Regenerate cmaps from source.
Thanks to Helmut Grohne for the suggestion
* d/patches/0007-typographical-and-formatting-fixes-to-the-manual.patch:
typographical and formatting fixes to the manual.
Thanks to Bjarni Ingi Gislason for the patch
2018-11-04 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.14.0+ds1-2) unstable; urgency=medium
* Fix FTBFS on mips64el
Disabled objcopy to avoid linking error.
* Bump Standards-Version to 4.2.1
Supports noopt and terse in DEB_BUILD_OPTIONS.
2018-10-28 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.14.0+ds1-1) unstable; urgency=medium
* New upstream version 1.14.0+ds1
- Fixes CVE-2018-1000036 (Closes: #900129, upstream bug 699695)
* d/patches: fresh patches
* d/rules: adjust to work with updated upstream Makefile
* d/rules: Set CC_FOR_BUILD (Closes: #903319)
2018-09-03 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.13.0+ds1-3) unstable; urgency=medium
* debian/patches: import upstream patch for CVE-2018-10289 (Closes: 896545)
* More FTCBFS patches.
Thanks to Helmut Grohne for the patches. (Closes: 903319)
2018-07-08 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.13.0+ds1-2) unstable; urgency=medium
* Use dh_auto_build/dh_auto_install --parallel.
Thanks to Helmut Grohne for the patch (Closes: #902968)
2018-04-30 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.13.0+ds1-1) unstable; urgency=medium
* New upstream version 1.13.0+ds1
- Fixes CVE-2018-5686 (Closes: #887130)
- Fixes CVE-2018-6187 (Closes: #888464)
- Fixes CVE-2018-6192 (Closes: #888487)
* debian/control: Migrate vcs to salsa.debian.org
* debian/patches: Refresh patches
* debian/rules: Build with Debian CFLAGS and enable PIC libmupdf.a
(Closes: #841403)
* debian/rules: use Debian flavor build options (Closes: #877067)
* debian/mupdf.sh: Do not read from a file descriptor
(Closes: #893115, #893862)
* debian/mupdf.desktop: Fixes and add ePub and XPS to supported mimetype.
Thanks to Pino Toscano, Hartmut Buhrmester (Closes: #877082)
2018-03-14 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.12.0+ds1-1) unstable; urgency=high
* New upstream version 1.12.0+ds1
- Fixes CVE-2017-17866 (Closes: #885120)
- Closes: #877062
* Exclude thirdparty/{freeglut,lcms2} from upstream source
* Refresh patches
* Add freeglut3-dev build-dep
* d/mupdf.docs: Include droid fonts NOTICE file
* d/patches: Fix CVE-2018-6544 / CVE-2018-1000051 (Closes: #891245)
2017-10-26 - Kan-Ru Chen (陳侃如) <koster@debian.org>
mupdf (1.11+ds1-2) unstable; urgency=high
* Acknowledge NMU. Thanks, Salvatore.
* Renumber patches
* Fixes CVE-2017-15587 (Closes: 879055)
* Sort files in static library to make the build reproducible.
* Bump Standards-Version to 4.1.1. No changes needed.

See Also

Package Description
mupdf_1.14.0+ds1-4_i386.deb lightweight PDF viewer
mupen64plus-audio-all_2.5+4_all.deb plugin-based Nintendo 64 emulator, audio plugins
mupen64plus-audio-sdl_2.5-4_i386.deb sdl audio output plugin for mupen64plus
mupen64plus-data_2.5-5_all.deb plugin-based Nintendo 64 emulator, data files
mupen64plus-input-all_2.5+4_all.deb plugin-based Nintendo 64 emulator, input plugins
mupen64plus-input-sdl_2.5-4_i386.deb sdl input device plugin for mupen64plus
mupen64plus-qt_1.12-1_i386.deb customizable launcher for Mupen64Plus
mupen64plus-rsp-all_2.5+4_all.deb plugin-based Nintendo 64 emulator, rsp plugins
mupen64plus-rsp-hle_2.5-4_i386.deb high-level rsp emulation for mupen64plus
mupen64plus-rsp-z64_2.0.0+12+g5a0a580-4_i386.deb low-level rsp emulation for mupen64plus
mupen64plus-ui-console_2.5-4_i386.deb console frontend for mupen64plus
mupen64plus-video-all_2.5+4_all.deb plugin-based Nintendo 64 emulator, video plugins
mupen64plus-video-arachnoid_2.0.0+13+g911d3b8-4_i386.deb Arachnoid high-level graphics emulation for mupen64plus
mupen64plus-video-glide64_2.0.0+33+g764d9fe-5_i386.deb Glide64 high-level graphics emulation for mupen64plus
mupen64plus-video-glide64mk2_2.5-6+b1_i386.deb Glide64Mk2 high-level graphics emulation for mupen64plus
Advertisement
Advertisement