msva-perl_0.9.2-1_all.deb


Advertisement

Description

msva-perl - Cryptographic identity validation agent (Perl implementation)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename msva-perl_0.9.2-1_all.deb
Package name msva-perl
Package version 0.9.2
Package release 1
Package architecture all
Package type deb
Category net uitoolkit::gtk
Homepage http://web.monkeysphere.info/
License -
Maintainer Daniel Kahn Gillmor <dkg@fifthhorseman.net>
Download size 42.97 KB
Installed size 202.00 KB
The Monkeysphere Validation Agent offers a local service for tools to
validate certificates (both X.509 and OpenPGP) and other public keys.
This package contains a perl implementation of a Monkeysphere
Validation Agent.

Alternatives

Package Version Architecture Repository
msva-perl_0.9.2-1_all.deb 0.9.2 all Debian Main
msva-perl - - -

Requires

Name Value
libconfig-general-perl -
libconvert-asn1-perl -
libcrypt-x509-perl >= 0.50
libfile-homedir-perl -
libgnupg-interface-perl >= 0.43
libhttp-server-simple-perl -
libjson-perl -
libnet-server-perl >= 2.00
libparent-perl -
libregexp-common-perl -

Provides

Name Value
monkeysphere-validation-agent -

Conflicts

Name Value
monkeysphere << 0.32

Download

Type URL
Mirror ftp.br.debian.org
Binary Package msva-perl_0.9.2-1_all.deb
Source Package msva-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install msva-perl deb package:
    # sudo apt-get install msva-perl

Files

Path
/etc/X11/Xsession.d/70monkeysphere_use-validation-agent
/usr/bin/msva-perl
/usr/bin/msva-query-agent
/usr/lib/gnupg/gpgkeys_hkpms
/usr/lib/gnupg2/gpg2keys_hkpms
/usr/share/doc/msva-perl/changelog.Debian.gz
/usr/share/doc/msva-perl/changelog.gz
/usr/share/doc/msva-perl/copyright
/usr/share/man/man1/msva-perl.1.gz
/usr/share/man/man1/msva-query-agent.1.gz
/usr/share/perl5/Crypt/Monkeysphere/Keyserver.pm
/usr/share/perl5/Crypt/Monkeysphere/Keytrans.pm
/usr/share/perl5/Crypt/Monkeysphere/Logger.pm
/usr/share/perl5/Crypt/Monkeysphere/MSVA.pm
/usr/share/perl5/Crypt/Monkeysphere/OpenPGP.pm
/usr/share/perl5/Crypt/Monkeysphere/Util.pm
/usr/share/perl5/Crypt/Monkeysphere/Validator.pm
/usr/share/perl5/Crypt/Monkeysphere/MSVA/Client.pm
/usr/share/perl5/Crypt/Monkeysphere/MSVA/MarginalUI.pm
/usr/share/perl5/Crypt/Monkeysphere/MSVA/Monitor.pm
/usr/share/perl5/Net/Server/MSVA.pm
/usr/share/pixmaps/monkeysphere-icon.png

Changelog

2013-09-13 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.9.2-1) unstable; urgency=low
* New upstream version
- includes POD failure fix from gregor, thanks!
* updated to dh 9
* bumped Standards-Version to 3.9.4 (no changes needed)
2013-08-30 - gregor herrmann <gregoa@debian.org>
msva-perl (0.9.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS with perl 5.18: POD failure":
add patch to add encoding to POD.
(Closes: #720430)
2012-09-09 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.9.1-1) unstable; urgency=low
* New Upstream version
- fix an error when msva-perl is launched without arguments.
2012-07-25 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.9-1) unstable; urgency=low
* New Upstream version
- tighter dependencies
- daemon crash should no longer kill X11 session
(Closes: #682353, #682518)
- cleanup for newer versions of perl and modules 
(Closes: #677565, #642304)
- binds explicitly to IPv4 loopback
(Closes: #661939)
- scanning for changes and prompting to reload off by default
(Closes: #614313)
* bumped Standards-Version to 3.9.3 (no changes needed)
2011-02-13 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.8-2) unstable; urgency=low
* Release into unstable.
2010-12-20 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.8-1) experimental; urgency=low
* New Upstream bugfix Release.
- added Suggests: liblwp-protocol-socks-perl to enable the use of
--keyserver-options http-proxy=socks://localhost:9050 for
gpgkeys_hkpms over tor.
2010-12-16 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.7-1) experimental; urgency=low
* new Upstream release (to experimental)
* installs gpgkeys_hkpms for gpg and gpg2.
2010-11-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.6-1) experimental; urgency=low
* New Upstream Release (to experimental)
* added some Recommends: needed for some new (optional) features:
- msva-query-agent (command-line query tool)
- autodetection of updates to a running agent
2010-10-12 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.5-1) experimental; urgency=low
* New Upstream Release (to experimental)
- relaxed dependency on libgtk2-perl to Recommends: (no marginal UI
without it, though)
2010-10-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
msva-perl (0.4-1) experimental; urgency=low
* New Upstream Release (to experimental)
* Bumped Standards-Version to 3.9.1 (no changes needed)
* Adopted Xsession.d script from monkeysphere package (which
unfortunately means we conflict with any monkeysphere package << 0.32)

See Also

Package Description
mswatch_1.2.0-2.2_i386.deb watch mailstores for changes and initiate mailbox syncs - client tools
mt-st_1.3-2_i386.deb Linux SCSI tape driver aware magnetic tape control (aka mt)
mtail_3.0.0~rc19-2_i386.deb Extract monitoring data from logs for collection in a timeseries database
mtd-utils_2.0.1-1_i386.deb Memory Technology Device Utilities
mtdev-tools_1.1.5-1+b1_i386.deb Multitouch Protocol Translation Library - test tools
mtink-doc_1.0.16-10_all.deb Status monitor tool for Epson inkjet printers - documentation
mtink_1.0.16-10_i386.deb Status monitor tool for Epson inkjet printers
mtkbabel_0.8.3.1-1.1_all.deb Tool for managing i-Blue 747 and compatible GPS data loggers
mtools_4.0.23-1_i386.deb Tools for manipulating MSDOS files
mtp-tools_1.1.16-2_i386.deb Media Transfer Protocol (MTP) library tools
mtpaint_3.40-3_i386.deb painting program to create pixel art and manipulate digital photos
mtpolicyd_2.03-1_all.deb modular policy daemon for postfix
mtr-tiny_0.92-2_i386.deb Full screen ncurses traceroute tool
mtr_0.92-2_i386.deb Full screen ncurses and X11 traceroute tool
mtree-netbsd_20180822-4_i386.deb Validates directory tree against specification
Advertisement
Advertisement