mpv_0.29.1-1_i386.deb


Advertisement

Description

mpv - video player based on MPlayer/mplayer2

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename mpv_0.29.1-1_i386.deb
Package name mpv
Package version 0.29.1
Package release 1
Package architecture i386
Package type deb
Category implemented-in::c interface::graphical interface::x11 role::program sound::player uitoolkit::sdl uitoolkit::xlib use::playing video works-with-format::mp3 works-with-format::oggtheora works-with-format::oggvorbis works-with-format::wav works-with::audio works-with::video x11::application
Homepage https://mpv.io/
License -
Maintainer Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Download size 1016.05 KB
Installed size 2.43 MB
mpv is a movie player based on MPlayer and mplayer2. It supports a wide
variety of video file formats, audio and video codecs, and subtitle types.
Changes from mplayer2 to mpv include:
* Removal of lots of unneeded code to encourage developer activity
* Better OSD rendering
* Cleaned up terminal output
* Improved OpenGL output
* Encoding functionality (replacement for mencoder)
* Wayland support
* Support for playing URLs of popular streaming sites
* Screenshot improvements
* ...
See mpv(1) for more info regarding changes between MPlayer, mplayer2 and mpv.

Alternatives

Package Version Architecture Repository
mpv_0.29.1-1_amd64.deb 0.29.1 amd64 Debian Main
mpv_0.29.1-dmo2_amd64.deb 0.29.1 amd64 Multimedia Main
mpv_0.29.1-dmo2_i386.deb 0.29.1 i386 Multimedia Main
mpv - - -

Requires

Name Value
libarchive13 >= 3.1.2
libasound2 >= 1.0.27
libass9 >= 1:0.13.6
libavcodec58 >= 7:4.0
libavdevice58 >= 7:4.0
libavfilter7 >= 7:4.0
libavformat58 >= 7:4.0
libavutil56 >= 7:4.0
libbluray2 >= 1:0.2.2
libc6 >= 2.27
libcaca0 >= 0.99.beta17-1
libcdio-cdda2 >= 10.2+0.94+2
libcdio-paranoia2 >= 10.2+0.94+2
libcdio18 >= 2.0.0
libdrm2 >= 2.4.62
libdvdnav4 >= 4.1.3
libdvdread4 >= 4.1.3
libegl1 -
libgbm1 >= 8.1~0
libgl1 -
libjack-0.125 -
libjack-jackd2-0 >= 1.9.10+20150825
libjpeg62-turbo >= 1.3.1
liblcms2-2 >= 2.6
liblua5.2-0 -
libpulse0 >= 0.99.4
librubberband2 -
libsdl2-2.0-0 >= 2.0.8
libsmbclient >= 2:4.0.3+dfsg1
libsndio7.0 >= 1.1.0
libswresample3 >= 7:4.0
libswscale5 >= 7:4.0
libuchardet0 >= 0.0.1
libva-drm2 >= 1.1.0
libva-wayland2 >= 1.3.0
libva-x11-2 >= 1.0.3
libva2 >= 2.1.0
libvdpau1 >= 0.2
libvulkan1 -
libwayland-client0 >= 1.9.91
libwayland-cursor0 >= 1.0.2
libwayland-egl1 >= 1.15.0
libx11-6 -
libxext6 -
libxinerama1 -
libxkbcommon0 >= 0.5.0
libxrandr2 >= 2:1.2.99.2
libxss1 -
libxv1 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mpv_0.29.1-1_i386.deb
Source Package mpv

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mpv deb package:
    # sudo apt-get install mpv

Files

Path
/etc/mpv/encoding-profiles.conf
/usr/bin/mpv
/usr/share/applications/mpv.desktop
/usr/share/doc/mpv/README.md.gz
/usr/share/doc/mpv/changelog.Debian.gz
/usr/share/doc/mpv/changelog.gz
/usr/share/doc/mpv/copyright
/usr/share/doc/mpv/edl-mpv.rst.gz
/usr/share/doc/mpv/encoding.rst.gz
/usr/share/doc/mpv/input.conf.gz
/usr/share/doc/mpv/mplayer-input.conf
/usr/share/doc/mpv/mpv.conf.gz
/usr/share/doc/mpv/restore-old-bindings.conf
/usr/share/doc/mpv/tech-overview.txt.gz
/usr/share/doc/mpv/waf-buildsystem.rst.gz
/usr/share/doc/mpv/examples/lua/README.md
/usr/share/doc/mpv/examples/lua/acompressor.lua.gz
/usr/share/doc/mpv/examples/lua/ao-null-reload.lua
/usr/share/doc/mpv/examples/lua/audio-hotplug-test.lua
/usr/share/doc/mpv/examples/lua/autocrop.lua
/usr/share/doc/mpv/examples/lua/autodeint.lua.gz
/usr/share/doc/mpv/examples/lua/autoload.lua.gz
/usr/share/doc/mpv/examples/lua/cycle-deinterlace-pullup.lua
/usr/share/doc/mpv/examples/lua/observe-all.lua
/usr/share/doc/mpv/examples/lua/ontop-playback.lua
/usr/share/doc/mpv/examples/lua/pause-when-minimize.lua
/usr/share/doc/mpv/examples/lua/status-line.lua
/usr/share/icons/hicolor/16x16/apps/mpv.png
/usr/share/icons/hicolor/32x32/apps/mpv.png
/usr/share/icons/hicolor/64x64/apps/mpv.png
/usr/share/icons/hicolor/scalable/apps/mpv.svg
/usr/share/icons/hicolor/symbolic/apps/mpv-symbolic.svg
/usr/share/man/man1/mpv.1.gz
/usr/share/zsh/vendor-completions/_mpv

Changelog

2018-10-03 - James Cowgill <jcowgill@debian.org>
mpv (0.29.1-1) unstable; urgency=medium
* New upstream release.
* d/control: Bump standards version to 4.2.1.
2018-07-28 - James Cowgill <jcowgill@debian.org>
mpv (0.29.0-1) unstable; urgency=medium
* New upstream release. (Closes: #904629)
- player: add on_load_fail hook. (Closes: #898576)
- ytdl_hook: fix single-entry playlists. (Closes: #898279)
* debian/copyright: Update.
* debian/libmpv1.symbols: Add new symbols.
* debian/patches:
- Drop 04_waf-pie.patch - hopefully not needed in recent GCC.
- Drop 08_waf-python3.7.patch - applied in new waf.
- Rewrite patch description for 06_ffmpeg-abi.patch.
- Refresh patches.
* debian/rules:
- Remove --enable-encoding option.
2018-07-18 - James Cowgill <jcowgill@debian.org>
mpv (0.28.2-3) unstable; urgency=medium
* Upload to unstable.
2018-07-16 - James Cowgill <jcowgill@debian.org>
mpv (0.28.2-2) experimental; urgency=medium
* debian/control:
- Add missing build-dependency on wayland-protocols.
Thanks to Laurent Bigonville for reporting! (Closes: #903887)
- Bump standards version to 4.1.5.
* debian/patches:
- Add patch to fix FTBFS with Python 3.7 as the default python3.
(Closes: #903610)
2018-05-06 - James Cowgill <jcowgill@debian.org>
mpv (0.28.2-1) experimental; urgency=medium
* New upstream bugfix release.
- Also whitelist subtitle URLs in youtube-dl hook. (Closes: #890410)
* debian/rules:
- Build-Depend on ffmpeg 4.0. (Closes: #898080)
* debian/patches:
- Drop patch for CVE-2018-6360 - fixed upstream.
- Fix typo in 06_ffmpeg-abi.patch description.
2018-02-04 - James Cowgill <jcowgill@debian.org>
mpv (0.28.0-1) experimental; urgency=medium
* New upstream release.
* debian/compat:
- Use debhelper 11.
* debian/control:
- Set Maintainer to debian-multimedia@l.d.o.
- Switch Vcs URLs to salsa.debian.org.
- Drop unused dependency on libavresample-dev.
- Add dependencies on libarchive-dev and libvulkan-dev.
- Bump ffmpeg dependencies to 3.5.
- Set Rules-Requires-Root: no.
- Bump standards to 4.1.3.
* debian/copyright:
- Update for 0.28.
- Use secure copyright format URL.
* debian/patches:
- Drop vaapi patch applied upstream.
- Add patch for CVE-2018-6360. (Closes: #888654)
- Refresh other patches.
2017-10-21 - James Cowgill <jcowgill@debian.org>
mpv (0.27.0-2) unstable; urgency=medium
* debian/control:
- Bump standards version to 4.1.1 (no changes).
* debian/patches:
- Add upstream patch to fix FTBFS with libva 2.0. (Closes: #879057)
2017-09-15 - James Cowgill <jcowgill@debian.org>
mpv (0.27.0-1) unstable; urgency=medium
* New upstream release.
* debian/control:
- Bump standards version to 4.1.0 (no changes).
* debian/copyright:
- Update copyright.
* debian/patches:
- Refresh.
* debian/rules:
- Re-enable DVB. (Closes: #873294)
- Run waf using python3 instead of python2.
2017-07-26 - James Cowgill <jcowgill@debian.org>
mpv (0.26.0-3) unstable; urgency=medium
* Bump ffmpeg build dependency to >= 3.3.
- Should fix hardware decoding in 0.26.0. (Closes: #869093)
2017-07-21 - James Cowgill <jcowgill@debian.org>
mpv (0.26.0-2) unstable; urgency=medium
* debian/control, debian/rules:
- Remove --enable-tv option and drop libv4l-dev build dependency. This
functionality is now provided through ffmpeg.
* debian/patches/07_io-stdin-used.patch:
- Add _IO_stdin_used to mpv version script. Should fix FTBFS on alpha,
mips* and powerpc*.

See Also

Package Description
mrb_0.3_all.deb Manage incremental data snapshots with make/rsync
mrbayes-doc_3.2.6+dfsg-2_all.deb Bayesian Inference of Phylogeny - manual
mrbayes-mpi_3.2.6+dfsg-2+b1_i386.deb Bayesian Inference of Phylogeny - mpi version
mrbayes_3.2.6+dfsg-2+b1_i386.deb Bayesian Inference of Phylogeny
mrboom_4.7-1_i386.deb 8 player Bomberman
mrd6_0.9.6-13+b1_i386.deb IPv6 Multicast Routing Daemon
mrename_1.2-13_all.deb tool for easy and automatic renaming of many files
mriconvert_2.1.0-3_i386.deb medical image file conversion utility
mricron-data_0.20140804.1~dfsg.1-3_all.deb data files for MRIcron
mricron-doc_0.20140804.1~dfsg.1-3_all.deb data files for MRIcron
mricron_0.20140804.1~dfsg.1-3_i386.deb magnetic resonance image conversion, viewing and analysis
mrmpi-doc_1.0~20140404-2_all.deb Implements MapReduce operation on top of standard MPI message - doc
mrpt-apps_1.5.6-1+b1_i386.deb Mobile Robot Programming Toolkit - Console and GUI applications
mrpt-common_1.5.6-1_all.deb Mobile Robot Programming Toolkit - Example datasets and files
mrpt-doc_1.5.6-1_all.deb Mobile Robot Programming Toolkit - Documentation and examples
Advertisement
Advertisement