mongrel2-run_1.12.0-2_all.deb


Advertisement

Description

mongrel2-run - programming language agnostic web server

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename mongrel2-run_1.12.0-2_all.deb
Package name mongrel2-run
Package version 1.12.0
Package release 2
Package architecture all
Package type deb
Category httpd
Homepage http://mongrel2.org/
License -
Maintainer Jan Niehusmann <jan@debian.org>
Download size 19.29 KB
Installed size 74.00 KB
Mongrel2 is an application, programming language, and network
architecture agnostic web server that focuses on web applications using
modern browser technologies.
Mongrel2 supports 17 languages and platforms, HTTP, Flash sockets,
WebSockets, Long Polling, and many ways to deploy and hack on it.
This package includes the infrastructure needed to setup a standalone
web server. Starting mongrel2 at boot is done using runit.

Alternatives

Package Version Architecture Repository
mongrel2-run_1.12.0-2_all.deb 1.12.0 all Debian Main
mongrel2-run - - -

Requires

Name Value
adduser -
mongrel2-core >= 1.12.0-2
runit -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mongrel2-run_1.12.0-2_all.deb
Source Package mongrel2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mongrel2-run deb package:
    # sudo apt-get install mongrel2-run

Files

Path
/etc/mongrel2/mongrel2.conf
/etc/sv/mongrel2/run
/usr/share/doc/mongrel2-run/changelog.Debian.gz
/usr/share/doc/mongrel2-run/changelog.gz
/usr/share/doc/mongrel2-run/copyright
/var/lib/mongrel2/doc_root/index.html

Changelog

2019-02-19 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.12.0-2) unstable; urgency=medium
* Build with authbind support
* Set Standards-Version: 4.3.0
2018-07-06 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.12.0-1) unstable; urgency=medium
* Update to upstream release 1.12.0
2018-05-11 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-8) unstable; urgency=medium
* Point Vcs-* to salsa repository.
* Fix lintian warning debian-rules-uses-unnecessary-dh-argument.
* Fix lintian warning dep5-copyright-license-name-not-unique.
2017-03-02 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-7) unstable; urgency=medium
* Add -shared flag when building shared libraries. Overrides -fPIE,
fixing build errors with older versions of dpkg-dev (eg. on ubuntu).
Hint found at https://lists.debian.org/debian-devel/2016/05/msg00302.html
2017-02-22 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-6) unstable; urgency=medium
* Cherry-pick upstream patch.
One can send HUP signals to mongrel2 to make it reopen the log
files. Due to a bug, after receiving two such signals, mongrel2
stopped working. This bug is fixed by the patch.
2016-12-21 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-5) unstable; urgency=medium
* Sort output of $(wildcard ...) in subdirectory Makefiles
2016-12-21 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-4) unstable; urgency=medium
* Disable test_Unixy_chroot_fails on GNU/hurd
2016-12-20 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-3) unstable; urgency=medium
* Sort output of $(wildcard ...) in Makefile to
fix reproducible builds.
(https://reproducible-builds.org/docs/stable-inputs/)
* remove unused function Unixy_getcwd()
uses non-portable PATH_MAX which is not available on hurd
* provide alternative implementation of normalize_path not using
PATH_MAX (should fix build on hurd)
2016-12-19 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-2) unstable; urgency=medium
* Update Vcs-Browser URL
* Enable hardening=+all flag
* Set debhelper compat level to 10
* Override source-is-missing lintian warning
* Set Standards-Version: 3.9.8
2016-02-11 - Jan Niehusmann <jan@debian.org>
mongrel2 (1.11.0-1) unstable; urgency=medium
* Update to upstream release 1.11.0

See Also

Package Description
monitoring-plugins-basic_2.2-6_i386.deb Plugins for nagios compatible monitoring systems (basic)
monitoring-plugins-btrfs_11-2_all.deb btrfs plugin for nagios compatible monitoring systems
monitoring-plugins-common_2.2-6_i386.deb Common files for plugins for nagios compatible monitoring
monitoring-plugins-standard_2.2-6_i386.deb Plugins for nagios compatible monitoring systems (standard)
monitoring-plugins_2.2-6_all.deb Plugins for nagios compatible monitoring systems (metapackage)
monitorix_3.10.1-1_all.deb lightweight system monitoring tool
monkeysign-doc_2.2.4_all.deb OpenPGP key signing and exchange for humans (documentation)
monkeysign_2.2.4_all.deb OpenPGP key signing and exchange for humans
monkeysphere_0.43-3_all.deb leverage the OpenPGP web of trust for SSH and TLS authentication
mono-4.0-gac_5.18.0.240+dfsg-3_all.deb Mono GAC tool (for CLI 4.0)
mono-4.0-service_5.18.0.240+dfsg-3_all.deb Mono service manager for CLI 4.0
mono-addins-utils_1.0+git20130406.adcd75b-4_all.deb Command-line utility for Mono.Addins management
mono-apache-server4_4.2-2.1_all.deb ASP.NET 4.5 backend for mod_mono Apache module
mono-apache-server_4.2-2.1_all.deb ASP.NET backend for mod_mono Apache module - default version
mono-complete_5.18.0.240+dfsg-3_i386.deb complete Mono runtime, development tools and all libraries
Advertisement
Advertisement