mediathekview_13.2.1-3_all.deb


Advertisement

Description

mediathekview - view streams from German public television stations

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename mediathekview_13.2.1-3_all.deb
Package name mediathekview
Package version 13.2.1
Package release 3
Package architecture all
Package type deb
Category culture::german implemented-in::java interface::graphical interface::x11 role::program uitoolkit::xlib use::downloading use::entertaining use::playing video works-with::audio x11::application
Homepage https://mediathekview.de/
License -
Maintainer Markus Koschany <apo@debian.org>
Download size 1.56 MB
Installed size 1.77 MB
This application searches for various media center video content of the German
television program (ARD, ZDF, Arte, 3Sat, MDR, ORF, SRF and many more).
You can watch, download and even subscribe to an offered show.

Alternatives

Package Version Architecture Repository
mediathekview_13.2.1-3_all.deb 13.2.1 all Debian Main
mediathekview - - -

Requires

Name Value
default-jre >= 2:1.9
java-wrappers >= 0.3
java9-runtime -
libcommons-compress-java -
libcommons-configuration2-java -
libcommons-dbcp2-java -
libcommons-lang3-java -
libcommons-pool2-java -
libcontrolsfx-java -
libguava-java -
libh2-java -
libjackson2-core-java -
libjchart2d-java -
libjiconfont-font-awesome-java -
libjiconfont-java -
libjiconfont-swing-java -
libjide-oss-java >= 3.7.4
liblog4j2-java -
libmbassador-java -
libmiglayout-java -
libokhttp-java -
libopenjfx-java >= 11
libswingx-java -
libxz-java -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mediathekview_13.2.1-3_all.deb
Source Package mediathekview

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mediathekview deb package:
    # sudo apt-get install mediathekview

Files

Path
/usr/bin/mediathekview
/usr/share/applications/mediathekview.desktop
/usr/share/doc/mediathekview/changelog.Debian.gz
/usr/share/doc/mediathekview/copyright
/usr/share/icons/hicolor/256x256/apps/MediathekView.png
/usr/share/icons/hicolor/scalable/apps/MediathekView.svg
/usr/share/man/de/man1/mediathekview.1.gz
/usr/share/man/man1/mediathekview.1.gz
/usr/share/mediathekview/MediathekView.jar
/usr/share/mediathekview/bin/flv.sh

Changelog

2019-02-07 - Markus Koschany <apo@debian.org>
mediathekview (13.2.1-3) unstable; urgency=medium
* Tighten dependency on java-wrappers and libjide-oss-java. (Closes: #921613)
2018-11-19 - Markus Koschany <apo@debian.org>
mediathekview (13.2.1-2) unstable; urgency=medium
* Add libguava-java as a new dependency too.
Thanks to Reinhard Karcher for the report. (Closes: #914093)
2018-11-18 - Markus Koschany <apo@debian.org>
mediathekview (13.2.1-1) unstable; urgency=medium
* New upstream version 13.2.1. (Closes: #911137, LP: #1795988)
- Fixes "Mediathekview does not start because it cannot find
its main class" (LP: #1798683)
- Repack the tarball and remove prebuilt jar and exe files.
* New dependencies for latest release including libcontrolsfx-java,
libh2-java, libjiconfont-font-awesome-java, libjiconfont-swing-java,
liblog4j2-java, libmbassador-java, libcommons-pool2-java,
libcommons-dbcp2-java, libcommons-configuration2-java and
libactivation-java.
* Removed dependencies: libjgoodies-common-java, libjgoodies-forms-java,
libmac-widgets-java, libtimingframework-java.
* No longer install mediathekview.xpm icon.
* The documentation in pdf format is no longer shipped by upstream.
* Remove dh_clean override and use debian/clean instead.
* Update debian/copyright for new release.
* Remove debian/mediathekview.links again and add javafx jar files to the
CLASSPATH in mediathekview.manifest instead.
2018-10-30 - Markus Koschany <apo@debian.org>
mediathekview (13.0.6-3) unstable; urgency=medium
* Fix FTBFS with OpenJDK 11.
- B-D on libactivation-java.
- Add /usr/share/java/javax.activation.jar to CLASSPATH.
- Update build.patch and use javax.activation.
(Closes: #912350)
2018-10-16 - Markus Koschany <apo@debian.org>
mediathekview (13.0.6-2) unstable; urgency=medium
* Move the package to salsa.debian.org.
* Fix compatibility issues with OpenJFX 11. (Closes: #910395)
* Depend on Java 9 at least.
2018-01-10 - Markus Koschany <apo@debian.org>
mediathekview (13.0.6-1) unstable; urgency=medium
* New upstream version 13.0.6.
2018-01-04 - Markus Koschany <apo@debian.org>
mediathekview (13.0.5-1) unstable; urgency=medium
* New upstream version 13.0.5.
* Switch to compat level 11.
* Declare compliance with Debian Policy 4.1.3.
* Refresh build.patch.
2017-11-20 - Markus Koschany <apo@debian.org>
mediathekview (13.0.4-1) unstable; urgency=medium
* New upstream version 13.0.4.
* Refresh build.patch.
2017-10-19 - Markus Koschany <apo@debian.org>
mediathekview (13.0.3-1) unstable; urgency=medium
* New upstream version 13.0.3. (Closes: #878302)
* Refresh build.patch
* New dependency: libokhttp-java.
* Declare compliance with Debian Policy 4.1.1.
* Use https for Format field.
2017-06-19 - Markus Koschany <apo@debian.org>
mediathekview (13.0.2-2) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
mediawiki-classes_1.31.2-1_all.deb website engine for collaborative work - standalone classes
mediawiki2latex_7.33-1_i386.deb Loads pages from MediaWiki and converts to LaTeX and PDF
mediawiki2latexguipyqt_1.5-1_all.deb lightweight GUI for mediawiki2latex
mediawiki_1.31.2-1_all.deb website engine for collaborative work
medit_1.2.0-3_i386.deb Useful programming and around-programming text editor
mednafen_1.22.1+dfsg-2~deb10u1_i386.deb multi-platform emulator, including NES, GB/A, Lynx, PC Engine
mednaffe_0.8.8-1_i386.deb front-end for the Mednafen multi-system emulator
medusa_2.2-6_i386.deb fast, parallel, modular, login brute-forcer for network services
meep-lam4_1.7.0-3_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-mpi-default_1.7.0-3_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-mpich2_1.7.0-3_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-openmpi_1.7.0-3_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep_1.7.0-3_i386.deb software package for FDTD simulation
megadown_0~20180705+git83c53dd-1.1_all.deb Script for downloading files from mega.nz and megacrypter
megaglest-data_3.13.0-2_all.deb data files for MegaGlest
Advertisement
Advertisement