mcollective-client_2.12.1+dfsg-1_all.deb


Advertisement

Description

mcollective-client - Marionette Collective clustering framework - clients

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename mcollective-client_2.12.1+dfsg-1_all.deb
Package name mcollective-client
Package version 2.12.1+dfsg
Package release 1
Package architecture all
Package type deb
Category utils
Homepage http://projects.puppetlabs.com/projects/mcollective
License -
Maintainer Puppet Package Maintainers <pkg-puppet-devel@lists.alioth.debian.org>
Download size 27.44 KB
Installed size 43.00 KB
The Marionette Collective is a framework for building server
orchestration and parallel job execution systems.
This package provides the MCollective client utility:
* mco

Alternatives

Package Version Architecture Repository
mcollective-client_2.12.1+dfsg-1_all.deb 2.12.1+dfsg all Debian Main
mcollective-client - - -

Requires

Name Value
mcollective-common >= 2.12.1+dfsg-1
ruby -
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mcollective-client_2.12.1+dfsg-1_all.deb
Source Package mcollective

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mcollective-client deb package:
    # sudo apt-get install mcollective-client

Files

Path
/usr/bin/mco
/usr/share/doc/mcollective-client/changelog.Debian.gz
/usr/share/doc/mcollective-client/changelog.gz
/usr/share/doc/mcollective-client/copyright
/usr/share/man/man1/mco.1.gz
/usr/share/mcollective-client/client.cfg

Changelog

2018-04-29 - Sebastien Badia <sbadia@debian.org>
mcollective (2.12.1+dfsg-1) unstable; urgency=medium
* New upstream version 2.12.1+dfsg
2018-04-11 - Sebastien Badia <sbadia@debian.org>
mcollective (2.12.0+dfsg-2) unstable; urgency=medium
* d/tests: Allow stderr during ci tests (debci)
* d/control:
+ Make mcollective-doc Multi-Arch: foreign
+ Bump to Standards-Version 4.1.4 (no changes needed)
2018-04-06 - Sebastien Badia <sbadia@debian.org>
mcollective (2.12.0+dfsg-1) unstable; urgency=medium
* New upstream version 2.12.0+dfsg
+ Upstream fix for CVE-2017-2292 (Closes: #866711)
+ Upstream fix for CVE-2016-2788 (Closes: #850968)
+ Upstream fix for CVE-2014-3251 (Closes: #758701)
* d/compat: Bump compat version to 11
* d/control:
+ Bump to Standards-Version 4.1.3 (no changes needed)
+ Use salsa.debian.org in Vcs-* fields
+ Added myself as Uploader
+ Remove dh-systemd and gem2deb fixed version
* d/upstream: Added Upstream metadata
* d/copyright:
+ Fix license name and update upstream url
+ Use Files-Excluded target for dfsg repack
+ Remove section about ext/action_helpers (repack)
* d/examples: Remove un-used mcollective-common.examples
* d/rules: Remove deprecated dh-systemd rules
* d/changelog: Added upstream changelog
* d/watch:
+ Bump to version 4 switch to https and test pgpmode
+ Fixes watch file (opts=pgpmode=auto)
* d/init:
+ Remove default (init.d-script-should-always-start-service)
+ Update systemd unit (refs upstream changes) (Closes: #709417)
* d/man: Added manpages for mco and mcollectived
* d/patches: Fix lintian issue with documentation (privacy-breach-generic)
* d/tests: Added dep8 autopkgtest testsuite (Closes: LP1679336)
2014-12-20 - Michael Gilbert <mgilbert@debian.org>
mcollective (2.6.0+dfsg-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Use interest-noawait trigger (closes: #772864).
2014-12-04 - Jonas Genannt <jonas.genannt@capi2name.de>
mcollective (2.6.0+dfsg-2) unstable; urgency=low
[ Jean Baptiste Favre ]
* Remove server & client config files from package to avoid dpkg asking for
replacement (Closes: #767936)
* Try to change server.cfg and client.cfg default connector, while keeping
user values in postinst due to stomp plugin being deprecated
2014-10-14 - Jonas Genannt <jonas.genannt@capi2name.de>
mcollective (2.6.0+dfsg-1) unstable; urgency=low
* Imported Upstream version 2.6.0+dfsg
* d/watch: removed uversionmangle, fixed for new tarball names
* d/control: bumped up standards version to 3.9.6 (no changes needed)
* added d/mcollective-doc.doc-base
2014-08-26 - Jonas Genannt <jonas.genannt@capi2name.de>
mcollective (2.5.2+dfsg-1) unstable; urgency=low
* Imported Upstream version 2.5.2+dfsg (Closes: #738590)
* d/control:
- added version depend to ruby-stomp
- bumped standards version to 3.9.5 (no changes needed)
- updated description
- added facter,puppet package as Suggests
* d/watch: update for new tarball names
* d/repackage.sh: remove also js files
* d/p/pluginsdir.patch: refreshed for new upstream version
* removed debconf questions and queries for now
will be back later for new configuration file syntax. (accepting patches)
* switched to d/rules, disabled old upstream makefile
* removed note about debconf in README
2013-09-24 - Jonas Genannt <jonas.genannt@capi2name.de>
mcollective (2.0.0+dfsg-4) unstable; urgency=low
* d/control: removed rubygems dependency (Closes: #724317)

See Also

Package Description
mcollective-common_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - common files
mcollective-doc_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - documentation
mcollective_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - server
mcomix_1.2.1-1.1_all.deb GTK+ image viewer for comic books
mcp-plugins_0.4.0-6_i386.deb LADSPA plugins designed for Alsa Modular Synth
mcpp-doc_2.7.2-4_all.deb Alternative C/C++ preprocessor (manual)
mcpp_2.7.2-4+b2_i386.deb Alternative C/C++ preprocessor
mcrl2_201409.0-1+b2_i386.deb formal specification language toolset
mcron_1.0.8-1+b2_i386.deb Guile-based program for running jobs at regular times
mcrypt_2.6.8-4_i386.deb Replacement for old unix crypt(1)
mcstrans_2.8-1_i386.deb SELinux core policy utilities (mcstrans utilities)
mcu8051ide_1.4.9-1_all.deb Graphical Integrated Development Environment for 8051
md5deep_4.4-5_all.deb transitional dummy package for hashdeep
mda-lv2_1.2.2~dfsg0-2_i386.deb Paul Kellett's MDA plugins ported to LV2
mdadm_4.1-1_i386.deb tool to administer Linux MD arrays (software RAID)
Advertisement
Advertisement