lua-zlib-dev_0.2+git+1+9622739-2.1_i386.deb


Advertisement

Description

lua-zlib-dev - zlib development files for the Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-zlib-dev_0.2+git+1+9622739-2.1_i386.deb
Package name lua-zlib-dev
Package version 0.2+git+1+9622739
Package release 2.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://github.com/brimworks/lua-zlib
License -
Maintainer Enrico Tassi <gareuselesinge@debian.org>
Download size 11.29 KB
Installed size 52.00 KB
This package contains the development files of the Lua zlib library,
useful to create a statically linked binary (like a C application or a
standalone Lua interpreter).
Documentation is also shipped within this package.

Alternatives

Package Version Architecture Repository
lua-zlib-dev_0.2+git+1+9622739-2.1_amd64.deb 0.2+git+1+9622739 amd64 Debian Main
lua-zlib-dev - - -

Requires

Name Value
lua-zlib = 0.2+git+1+9622739-2.1

Provides

Name Value
lua5.1-zlib-dev -
lua5.2-zlib-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-zlib-dev_0.2+git+1+9622739-2.1_i386.deb
Source Package lua-zlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-zlib-dev deb package:
    # sudo apt-get install lua-zlib-dev

Files

Path
/usr/include/lua5.1/lua-zlib.h
/usr/include/lua5.2/lua-zlib.h
/usr/lib/i386-linux-gnu/liblua5.1-zlib.a
/usr/lib/i386-linux-gnu/liblua5.1-zlib.so
/usr/lib/i386-linux-gnu/liblua5.2-zlib.a
/usr/lib/i386-linux-gnu/liblua5.2-zlib.so
/usr/lib/i386-linux-gnu/pkgconfig/lua5.1-zlib.pc
/usr/lib/i386-linux-gnu/pkgconfig/lua5.2-zlib.pc
/usr/share/doc/lua-zlib-dev/README.gz
/usr/share/doc/lua-zlib-dev/changelog.Debian.gz
/usr/share/doc/lua-zlib-dev/copyright

Changelog

2018-01-20 - Aurelien Jarno <aurel32@debian.org>
lua-zlib (0.2+git+1+9622739-2.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control: Drop explicit Pre-Depends on multiarch-support
(Closes: #870557).
2014-08-30 - Enrico Tassi <gareuselesinge@debian.org>
lua-zlib (0.2+git+1+9622739-2) unstable; urgency=medium
* Rebuild against Lua 5.1.5-7 (Closes: #723493)
2013-08-23 - Enrico Tassi <gareuselesinge@debian.org>
lua-zlib (0.2+git+1+9622739-1) unstable; urgency=low
* add Privides: ${lua:Provides} to control 
* new upstream snapshot integrating debian patches:
- 0001-Fix-avail_in-value-for-lz.deflate.patch
- 0002-Lua5.2-require-does-not-set-a-global.patch
2012-04-08 - Enrico Tassi <gareuselesinge@debian.org>
lua-zlib (0.2+gitcfa1ecd-1) unstable; urgency=low
* New snapshot supporting lua5.2 
* Remove lua5.2 path, merged upstream
* Package moved to git
* Patch fixing upstream bug if no string is given to deflate
* Patch making the test file lua5.2 compatible 
* Fix copyright naming the license Expat and not MIT/X 
2012-04-08 - Enrico Tassi <gareuselesinge@debian.org>
lua-zlib (0.2-1) unstable; urgency=low
* Initial release. (Closes: #668057)

See Also

Package Description
lua-zlib_0.2+git+1+9622739-2.1_i386.deb zlib library for the Lua language
lua5.1-doc_5.1.5-8.1_all.deb Documentation for the Lua language version 5.1
lua5.1-policy-dev_33_all.deb Lua 5.1 Debian policy - template and scripts
lua5.1-policy_33_all.deb Lua 5.1 Debian policy
lua5.1_5.1.5-8.1+b2_i386.deb Simple, extensible, embeddable programming language
lua5.2-doc_5.2.4-1.1_all.deb Documentation for the Lua language version 5.2
lua5.2_5.2.4-1.1+b2_i386.deb Simple, extensible, embeddable programming language
lua5.3_5.3.3-1.1_i386.deb Simple, extensible, embeddable programming language
lua50-doc_5.0.3-8_all.deb Documentation for the Lua 5.0 programming language
lua50_5.0.3-8+b1_i386.deb Small embeddable language with simple procedural syntax
luadoc_3.0.1+gitdb9e868-1_all.deb Documentation generation library for the Lua language
luajit_2.1.0~beta3+dfsg-5.1_i386.deb Just in time compiler for Lua programming language version 5.1
luakit_2.1-1_i386.deb fast and small web browser extensible by Lua
luarocks_2.4.2+dfsg-1_all.deb deployment and management system for Lua modules
luasseq_2018.20190227-2_all.deb TeX Live: transitional dummy package
Advertisement
Advertisement