lua-sec_0.7-1_i386.deb


Advertisement

Description

lua-sec - SSL socket library for the Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-sec_0.7-1_i386.deb
Package name lua-sec
Package version 0.7
Package release 1
Package architecture i386
Package type deb
Category interpreters
Homepage https://github.com/brunoos/luasec
License -
Maintainer Enrico Tassi <gareuselesinge@debian.org>
Download size 34.14 KB
Installed size 232.00 KB
This package contains the luasec library, that adds on top of
the luasocket library SSL support.

Alternatives

Package Version Architecture Repository
lua-sec_0.7-1_amd64.deb 0.7 amd64 Debian Main
lua-sec - - -

Requires

Name Value
libc6 >= 2.4
libssl1.1 >= 1.1.0
lua-socket -

Provides

Name Value
lua5.1-sec -
lua5.2-sec -
lua5.3-sec -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-sec_0.7-1_i386.deb
Source Package lua-sec

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-sec deb package:
    # sudo apt-get install lua-sec

Files

Path
/usr/lib/i386-linux-gnu/liblua5.1-sec.so.1
/usr/lib/i386-linux-gnu/liblua5.1-sec.so.1.0.0
/usr/lib/i386-linux-gnu/liblua5.2-sec.so.1
/usr/lib/i386-linux-gnu/liblua5.2-sec.so.1.0.0
/usr/lib/i386-linux-gnu/liblua5.3-sec.so.1
/usr/lib/i386-linux-gnu/liblua5.3-sec.so.1.0.0
/usr/lib/i386-linux-gnu/lua/5.1/ssl.so
/usr/lib/i386-linux-gnu/lua/5.2/ssl.so
/usr/lib/i386-linux-gnu/lua/5.3/ssl.so
/usr/share/doc/lua-sec/changelog.Debian.gz
/usr/share/doc/lua-sec/changelog.gz
/usr/share/doc/lua-sec/copyright
/usr/share/lua/5.1/ssl.lua
/usr/share/lua/5.1/ssl/https.lua
/usr/share/lua/5.1/ssl/options.lua
/usr/share/lua/5.2/ssl.lua
/usr/share/lua/5.2/ssl/https.lua
/usr/share/lua/5.2/ssl/options.lua
/usr/share/lua/5.3/ssl.lua
/usr/share/lua/5.3/ssl/https.lua
/usr/share/lua/5.3/ssl/options.lua

Changelog

2018-10-22 - Victor Seva <vseva@debian.org>
lua-sec (0.7-1) unstable; urgency=medium
* New upstream version 0.7 (Closes: #907656)
* remove patches already applied
* add myself to uploaders, wrap-and-sort -sat
* debhelper compat 10
* update debian patches
* update standard-version. No changes
2018-08-30 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
lua-sec (0.6-4.2) unstable; urgency=medium
* Non-maintainer upload.
* move to stronger cryptographic digests too
2018-08-30 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
lua-sec (0.6-4.1) unstable; urgency=medium
* Non-maintainer upload.
* use 2048-bit keys in test suite (Closes: #906997)
* point Vcs-* to salsa
* gbp: use upstream git tags
* debian/copyright: use https form of Format URI
* debian/changelog: strip trailing whitespace
* debian/watch: use github tags
2018-02-23 - Raphaël Hertzog <hertzog@debian.org>
lua-sec (0.6-4) unstable; urgency=medium
* Team upload.
* Drop luasandbox support as the package is going away (see #891191).
2017-01-06 - Mathieu Parent <sathieu@debian.org>
lua-sec (0.6-3) unstable; urgency=medium
* Add me to uploaders
* Add luasandbox support
* test.sh: Run client.lua synchronously
* test.lua: Ensure errors are catched on lua5.1
2016-11-06 - Ondřej Surý <ondrej@debian.org>
lua-sec (0.6-2) unstable; urgency=medium
* Add Lua 5.3 support (Closes: #808136)
* Add myself to Uploaders
* Re-wrap with wrap-and-sort -a
* Merge full OpenSSL 1.1.0 support and some crash fixes from upstream
2016-10-27 - Ondřej Surý <ondrej@debian.org>
lua-sec (0.6-1) unstable; urgency=medium
* Imported Upstream version 0.6
* Add OpenSSL 1.1.0 patch from upstream (Closes: #828427)
2015-12-06 - Enrico Tassi <gareuselesinge@debian.org>
lua-sec (0.5.1-1) unstable; urgency=medium
* new upstream release
2015-11-15 - Enrico Tassi <gareuselesinge@debian.org>
lua-sec (0.5-3) unstable; urgency=medium
* Cherry pick upstream 67f0867 to fix FTBFS after SSLv3 support
was removed from opanssl (Closes: #804607)
2015-08-16 - Enrico Tassi <gareuselesinge@debian.org>
lua-sec (0.5-2) unstable; urgency=medium
* Do not Pre-Depend on multiarch-support
* Bump standards version, no change
* Update Homepage URL (Close: #775315)

See Also

Package Description
lua-soap_3.0+git91419a7-1_all.deb SOAP library for the Lua language
lua-socket-dev_3.0~rc1+git+ac3201d-4_i386.deb luasocket development files for the Lua language
lua-socket_3.0~rc1+git+ac3201d-4_i386.deb TCP/UDP socket library for the Lua language
lua-sql-doc_2.3.4-1_all.deb luasql documentation
lua-sql-mysql-dev_2.3.4-1+b1_i386.deb luasql development files for the Lua language
lua-sql-mysql_2.3.4-1+b1_i386.deb luasql library for the Lua language
lua-sql-odbc-dev_2.3.4-1+b1_i386.deb luasql development files for the Lua language
lua-sql-odbc_2.3.4-1+b1_i386.deb luasql library for the Lua language
lua-sql-postgres-dev_2.3.4-1+b1_i386.deb luasql development files for the Lua language
lua-sql-postgres_2.3.4-1+b1_i386.deb luasql library for the Lua language
lua-sql-sqlite3-dev_2.3.4-1+b1_i386.deb luasql development files for the Lua language
lua-sql-sqlite3_2.3.4-1+b1_i386.deb luasql library for the Lua language
lua-supple-doc_1.0.8-1_all.deb Documentation for lua-supple
lua-supple_1.0.8-1_i386.deb Lua strict sandbox
lua-svn-dev_0.4.0-9.1_i386.deb Development files for the Subversion library for the Lua language
Advertisement
Advertisement