lua-mpack_1.0.7-2_i386.deb


Advertisement

Description

lua-mpack - libmpack binding for the Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-mpack_1.0.7-2_i386.deb
Package name lua-mpack
Package version 1.0.7
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://github.com/libmpack/libmpack-lua/
License -
Maintainer James McCoy <jamessan@debian.org>
Download size 17.04 KB
Installed size 104.00 KB
libmpack is a small binary serialization/RPC library that implements both the
msgpack and msgpack-rpc specifications.
This package provides the Lua bindings based on libmpack.

Alternatives

Package Version Architecture Repository
lua-mpack_1.0.7-2_amd64.deb 1.0.7 amd64 Debian Main
lua-mpack - - -

Requires

Name Value
libc6 >= 2.4
libmpack0 >= 1.0.0

Provides

Name Value
lua5.1-mpack -
lua5.2-mpack -
lua5.3-mpack -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-mpack_1.0.7-2_i386.deb
Source Package libmpack-lua

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-mpack deb package:
    # sudo apt-get install lua-mpack

Files

Path
/usr/lib/i386-linux-gnu/liblua5.1-mpack.so.0
/usr/lib/i386-linux-gnu/liblua5.1-mpack.so.0.0.0
/usr/lib/i386-linux-gnu/liblua5.2-mpack.so.0
/usr/lib/i386-linux-gnu/liblua5.2-mpack.so.0.0.0
/usr/lib/i386-linux-gnu/liblua5.3-mpack.so.0
/usr/lib/i386-linux-gnu/liblua5.3-mpack.so.0.0.0
/usr/lib/i386-linux-gnu/lua/5.1/mpack.so
/usr/lib/i386-linux-gnu/lua/5.2/mpack.so
/usr/lib/i386-linux-gnu/lua/5.3/mpack.so
/usr/share/doc/lua-mpack/changelog.Debian.gz
/usr/share/doc/lua-mpack/copyright
/usr/share/lintian/overrides/lua-mpack

Changelog

2018-03-13 - James McCoy <jamessan@debian.org>
libmpack-lua (1.0.7-2) unstable; urgency=medium
* control: Change Vcs-* to salsa.debian.org
* Bump debhelper compat to 11
* copyright: Use https URL for copyright Format
* Declare compliance with Policy 4.1.3
2017-12-15 - James McCoy <jamessan@debian.org>
libmpack-lua (1.0.7-1) unstable; urgency=medium
* New upstream release
* Adjust defines specified in CLIB_CFLAGS according to upstream build
changes.
* Change Priority to optional
* Add Lintian override for package-name-doesnt-match-sonames
* Declare compliance with Policy 4.1.2
2017-07-24 - James McCoy <jamessan@debian.org>
libmpack-lua (1.0.6-1) unstable; urgency=medium
* Initial release after being split out from src:libmpack.
* Cherry-pick upstream patches to allow using system libs
+ Fix builds using gcc7 and/or system lua
+ Allow linking against system libmpack
* Remove -pie from DEB_BUILD_MAINT_OPTIONS, due to the new semantics.
* debian/rules: Make upstream buildsystem link against system libmpack

See Also

Package Description
lua-nginx-cookie_0.1.0-1_all.deb Pure Lua cookie parser for the nginx embedded Lua language
lua-nginx-dns_0.20-1_all.deb DNS resolver for the nginx embedded Lua language
lua-nginx-kafka_0.06-1_all.deb Pure Lua Kafka producer for the nginx embedded Lua language
lua-nginx-memcached_0.14-1_all.deb Pure Lua memcached client driver for the nginx embedded Lua language
lua-nginx-redis-connector_0.06-1_all.deb Connection utilities for lua-nginx-redis
lua-nginx-redis_0.27~rc1-1_all.deb Pure Lua redis client driver for the nginx embedded Lua language
lua-nginx-string_0.11-1_all.deb String utilities for the nginx embedded Lua language
lua-nginx-websocket_0.06-1_all.deb Lua websocket client driver for the nginx embedded Lua language
lua-nvim-dev_0.1.0-1-2_i386.deb Lua client for Neovim
lua-nvim_0.1.0-1-2_i386.deb Lua client for Neovim
lua-orbit_2.2.1+dfsg-1_all.deb MVC web framework for Lua
lua-penlight-dev_1.3.2-2_all.deb Collection of general purpose libraries for the Lua language
lua-penlight_1.3.2-2_all.deb Collection of general purpose libraries for the Lua language
lua-posix-dev_33.4.0-3_i386.deb posix development files for the Lua language
lua-posix_33.4.0-3_i386.deb posix library for the Lua language
Advertisement
Advertisement