lua-mediator_1.1.2-0-2_all.deb


Advertisement

Description

lua-mediator - Mediator pattern implementation in Lua

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-mediator_1.1.2-0-2_all.deb
Package name lua-mediator
Package version 1.1.2
Package release 0-2
Package architecture all
Package type deb
Category interpreters
Homepage https://github.com/Olivine-Labs/mediator_lua
License -
Maintainer Jason Pleau <jason@jpleau.ca>
Download size 5.61 KB
Installed size 22.00 KB
mediator_lua is a simple class that allows you to listen to events by
subscribing to and sending data to channels.
Its purpose is to help you decouple code where you might otherwise have
functions calling functions calling functions.

Alternatives

Package Version Architecture Repository
lua-mediator_1.1.2-0-2_all.deb 1.1.2 all Debian Main
lua-mediator - - -

Provides

Name Value
lua5.1-mediator -
lua5.2-mediator -
lua5.3-mediator -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-mediator_1.1.2-0-2_all.deb
Source Package lua-mediator

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-mediator deb package:
    # sudo apt-get install lua-mediator

Files

Path
/usr/share/doc/lua-mediator/README.md.gz
/usr/share/doc/lua-mediator/changelog.Debian.gz
/usr/share/doc/lua-mediator/copyright
/usr/share/lua/5.1/mediator.lua
/usr/share/lua/5.2/mediator.lua
/usr/share/lua/5.3/mediator.lua

Changelog

2016-02-21 - Jason Pleau <jason@jpleau.ca>
lua-mediator (1.1.2-0-2) unstable; urgency=medium
* Do not rename mediator.lua to mediator_lua.lua
* Cleanup packaging files, get rid of the -dev binary package
* Bump Standards-Version to 3.9.7, no changes required
* Add support for Lua5.3
2015-06-19 - Jason Pleau <jason@jpleau.ca>
lua-mediator (1.1.2-0-1) unstable; urgency=medium
* Initial release (Closes: #784103)

See Also

Package Description
lua-messagepack_0.5.1-1_all.deb pure Lua implementation of MessagePack
lua-mmdb_0.1-1_all.deb IP geolocation library for Lua
lua-mode_20151025-3_all.deb Emacs mode for editing Lua programs -- transitional package
lua-moses_2.1.0-1_all.deb Utility library for functional programming in Lua
lua-mpack_1.0.7-2_i386.deb libmpack binding for the Lua language
lua-nginx-cookie_0.1.0-1_all.deb Pure Lua cookie parser for the nginx embedded Lua language
lua-nginx-dns_0.20-1_all.deb DNS resolver for the nginx embedded Lua language
lua-nginx-kafka_0.06-1_all.deb Pure Lua Kafka producer for the nginx embedded Lua language
lua-nginx-memcached_0.14-1_all.deb Pure Lua memcached client driver for the nginx embedded Lua language
lua-nginx-redis-connector_0.06-1_all.deb Connection utilities for lua-nginx-redis
lua-nginx-redis_0.27~rc1-1_all.deb Pure Lua redis client driver for the nginx embedded Lua language
lua-nginx-string_0.11-1_all.deb String utilities for the nginx embedded Lua language
lua-nginx-websocket_0.06-1_all.deb Lua websocket client driver for the nginx embedded Lua language
lua-nvim-dev_0.1.0-1-2_i386.deb Lua client for Neovim
lua-nvim_0.1.0-1-2_i386.deb Lua client for Neovim
Advertisement
Advertisement