lua-luassert_1.7.10-1_all.deb


Advertisement

Description

lua-luassert - Lua assertions extension

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-luassert_1.7.10-1_all.deb
Package name lua-luassert
Package version 1.7.10
Package release 1
Package architecture all
Package type deb
Category interpreters
Homepage https://github.com/Olivine-Labs/luassert
License -
Maintainer Jason Pleau <jason@jpleau.ca>
Download size 20.40 KB
Installed size 166.00 KB
luassert extends Lua's built-in assertions to provide additional tests and
the ability to create your own.
It comes preloaded with argument formatters for common Lua types, but it is
easy to roll your own.

Alternatives

Package Version Architecture Repository
lua-luassert_1.7.10-1_all.deb 1.7.10 all Debian Main
lua-luassert - - -

Requires

Name Value
lua-say -

Provides

Name Value
lua5.1-luassert -
lua5.2-luassert -
lua5.3-luassert -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-luassert_1.7.10-1_all.deb
Source Package lua-luassert

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-luassert deb package:
    # sudo apt-get install lua-luassert

Files

Path
/usr/share/doc/lua-luassert/README.md.gz
/usr/share/doc/lua-luassert/changelog.Debian.gz
/usr/share/doc/lua-luassert/copyright
/usr/share/lua/5.1/luassert/assert.lua
/usr/share/lua/5.1/luassert/assertions.lua
/usr/share/lua/5.1/luassert/compatibility.lua
/usr/share/lua/5.1/luassert/init.lua
/usr/share/lua/5.1/luassert/match.lua
/usr/share/lua/5.1/luassert/mock.lua
/usr/share/lua/5.1/luassert/modifiers.lua
/usr/share/lua/5.1/luassert/namespaces.lua
/usr/share/lua/5.1/luassert/spy.lua
/usr/share/lua/5.1/luassert/state.lua
/usr/share/lua/5.1/luassert/stub.lua
/usr/share/lua/5.1/luassert/util.lua
/usr/share/lua/5.1/luassert/formatters/binarystring.lua
/usr/share/lua/5.1/luassert/formatters/init.lua
/usr/share/lua/5.1/luassert/languages/ar.lua
/usr/share/lua/5.1/luassert/languages/de.lua
/usr/share/lua/5.1/luassert/languages/en.lua
/usr/share/lua/5.1/luassert/languages/fr.lua
/usr/share/lua/5.1/luassert/languages/ja.lua
/usr/share/lua/5.1/luassert/languages/nl.lua
/usr/share/lua/5.1/luassert/languages/ru.lua
/usr/share/lua/5.1/luassert/languages/ua.lua
/usr/share/lua/5.1/luassert/languages/zh.lua
/usr/share/lua/5.1/luassert/matchers/composite.lua
/usr/share/lua/5.1/luassert/matchers/core.lua
/usr/share/lua/5.1/luassert/matchers/init.lua
/usr/share/lua/5.2/luassert/assert.lua
/usr/share/lua/5.2/luassert/assertions.lua
/usr/share/lua/5.2/luassert/compatibility.lua
/usr/share/lua/5.2/luassert/init.lua
/usr/share/lua/5.2/luassert/match.lua
/usr/share/lua/5.2/luassert/mock.lua
/usr/share/lua/5.2/luassert/modifiers.lua
/usr/share/lua/5.2/luassert/namespaces.lua
/usr/share/lua/5.2/luassert/spy.lua
/usr/share/lua/5.2/luassert/state.lua
/usr/share/lua/5.2/luassert/stub.lua
/usr/share/lua/5.2/luassert/util.lua
/usr/share/lua/5.2/luassert/formatters/binarystring.lua
/usr/share/lua/5.2/luassert/formatters/init.lua
/usr/share/lua/5.2/luassert/languages/ar.lua
/usr/share/lua/5.2/luassert/languages/de.lua
/usr/share/lua/5.2/luassert/languages/en.lua
/usr/share/lua/5.2/luassert/languages/fr.lua
/usr/share/lua/5.2/luassert/languages/ja.lua
/usr/share/lua/5.2/luassert/languages/nl.lua
/usr/share/lua/5.2/luassert/languages/ru.lua
/usr/share/lua/5.2/luassert/languages/ua.lua
/usr/share/lua/5.2/luassert/languages/zh.lua
/usr/share/lua/5.2/luassert/matchers/composite.lua
/usr/share/lua/5.2/luassert/matchers/core.lua
/usr/share/lua/5.2/luassert/matchers/init.lua
/usr/share/lua/5.3/luassert/assert.lua
/usr/share/lua/5.3/luassert/assertions.lua
/usr/share/lua/5.3/luassert/compatibility.lua
/usr/share/lua/5.3/luassert/init.lua
/usr/share/lua/5.3/luassert/match.lua
/usr/share/lua/5.3/luassert/mock.lua
/usr/share/lua/5.3/luassert/modifiers.lua
/usr/share/lua/5.3/luassert/namespaces.lua
/usr/share/lua/5.3/luassert/spy.lua
/usr/share/lua/5.3/luassert/state.lua
/usr/share/lua/5.3/luassert/stub.lua
/usr/share/lua/5.3/luassert/util.lua
/usr/share/lua/5.3/luassert/formatters/binarystring.lua
/usr/share/lua/5.3/luassert/formatters/init.lua
/usr/share/lua/5.3/luassert/languages/ar.lua
/usr/share/lua/5.3/luassert/languages/de.lua
/usr/share/lua/5.3/luassert/languages/en.lua
/usr/share/lua/5.3/luassert/languages/fr.lua
/usr/share/lua/5.3/luassert/languages/ja.lua
/usr/share/lua/5.3/luassert/languages/nl.lua
/usr/share/lua/5.3/luassert/languages/ru.lua
/usr/share/lua/5.3/luassert/languages/ua.lua
/usr/share/lua/5.3/luassert/languages/zh.lua
/usr/share/lua/5.3/luassert/matchers/composite.lua
/usr/share/lua/5.3/luassert/matchers/core.lua
/usr/share/lua/5.3/luassert/matchers/init.lua

Changelog

2016-05-03 - Jason Pleau <jason@jpleau.ca>
lua-luassert (1.7.10-1) unstable; urgency=medium
* New upstream release
* Update Standards-Version to 3.9.8, no changes needed
* Remove the lua-luassert-dev package: lua-only packages don't need a -dev
package.
* Add support for lua5.3
* update debian/copyright
2015-06-22 - Jason Pleau <jason@jpleau.ca>
lua-luassert (1.7.9-1) unstable; urgency=medium
* Initial release (Closes: #783218)

See Also

Package Description
lua-luv-dev_1.9.1-0-2_i386.deb libuv bindings for lua
lua-luv_1.9.1-0-2_i386.deb libuv bindings for lua
lua-luxio-doc_13-1_all.deb Documentation for lua-luxio
lua-luxio0_13-1_all.deb Posix bindings for Lua (transitional package)
lua-luxio_13-1_i386.deb Posix bindings for Lua
lua-lxc_3.0.2-1_i386.deb Linux Containers userspace tools (Lua bindings)
lua-markdown_0.32-5_all.deb Pure Lua 5.1 implementation of the Markdown text-to-html markup
lua-md5-dev_1.2+git+1+8d87fee-1.1_i386.deb MD5 library for the Lua language
lua-md5_1.2+git+1+8d87fee-1.1_i386.deb MD5 library for the Lua language
lua-mediator_1.1.2-0-2_all.deb Mediator pattern implementation in Lua
lua-messagepack_0.5.1-1_all.deb pure Lua implementation of MessagePack
lua-mmdb_0.1-1_all.deb IP geolocation library for Lua
lua-mode_20151025-3_all.deb Emacs mode for editing Lua programs -- transitional package
lua-moses_2.1.0-1_all.deb Utility library for functional programming in Lua
lua-mpack_1.0.7-2_i386.deb libmpack binding for the Lua language
Advertisement
Advertisement