lua-lpeg-patterns_0.4-1_all.deb


Advertisement

Description

lua-lpeg-patterns - collection of LPEG patterns

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-lpeg-patterns_0.4-1_all.deb
Package name lua-lpeg-patterns
Package version 0.4
Package release 1
Package architecture all
Package type deb
Category interpreters
Homepage https://github.com/daurnimator/lpeg_patterns
License -
Maintainer Ondřej Surý <ondrej@debian.org>
Download size 16.20 KB
Installed size 72.00 KB
Collection of LPEG patterns used for:
* Strict validation of user input
* Searching free-form input

Alternatives

Package Version Architecture Repository
lua-lpeg-patterns_0.4-1_all.deb 0.4 all Debian Main
lua-lpeg-patterns - - -

Requires

Name Value
lua-lpeg -

Provides

Name Value
lua5.1-lpeg-patterns -
lua5.2-lpeg-patterns -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-lpeg-patterns_0.4-1_all.deb
Source Package lua-lpeg-patterns

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-lpeg-patterns deb package:
    # sudo apt-get install lua-lpeg-patterns

Files

Path
/usr/share/doc/lua-lpeg-patterns/README.md.gz
/usr/share/doc/lua-lpeg-patterns/changelog.Debian.gz
/usr/share/doc/lua-lpeg-patterns/copyright
/usr/share/lua/5.1/lpeg_patterns/IPv4.lua
/usr/share/lua/5.1/lpeg_patterns/IPv6.lua
/usr/share/lua/5.1/lpeg_patterns/core.lua
/usr/share/lua/5.1/lpeg_patterns/email.lua
/usr/share/lua/5.1/lpeg_patterns/http.lua
/usr/share/lua/5.1/lpeg_patterns/language.lua
/usr/share/lua/5.1/lpeg_patterns/phone.lua
/usr/share/lua/5.1/lpeg_patterns/uri.lua
/usr/share/lua/5.1/lpeg_patterns/util.lua
/usr/share/lua/5.2/lpeg_patterns/IPv4.lua
/usr/share/lua/5.2/lpeg_patterns/IPv6.lua
/usr/share/lua/5.2/lpeg_patterns/core.lua
/usr/share/lua/5.2/lpeg_patterns/email.lua
/usr/share/lua/5.2/lpeg_patterns/http.lua
/usr/share/lua/5.2/lpeg_patterns/language.lua
/usr/share/lua/5.2/lpeg_patterns/phone.lua
/usr/share/lua/5.2/lpeg_patterns/uri.lua
/usr/share/lua/5.2/lpeg_patterns/util.lua

Changelog

2016-11-22 - Ondřej Surý <ondrej@debian.org>
lua-lpeg-patterns (0.4-1) unstable; urgency=medium
* Imported Upstream version 0.4
2016-08-25 - Ondřej Surý <ondrej@debian.org>
lua-lpeg-patterns (0.3-1) unstable; urgency=medium
* Imported Upstream version 0.3
2016-07-14 - Ondřej Surý <ondrej@debian.org>
lua-lpeg-patterns (0.2-3) unstable; urgency=medium
* Clarify where does LICENSE comes from
* Add debian/watch for upstream github repository
2016-07-13 - Ondřej Surý <ondrej@debian.org>
lua-lpeg-patterns (0.2-2) unstable; urgency=medium
* Change Architecture: to all as it's Lua only package
2016-07-13 - Ondřej Surý <ondrej@debian.org>
lua-lpeg-patterns (0.2-1) unstable; urgency=low
* Initial release.

See Also

Package Description
lua-lpeg_1.0.0-2_i386.deb LPeg library for the Lua language
lua-lpty-dev_1.0.1-1.1_i386.deb PTY library for the Lua language - development files
lua-lpty_1.0.1-1.1_i386.deb PTY library for the Lua language
lua-luaossl-dev_20161214-1_i386.deb OpenSSL bindings for Lua (development package)
lua-luaossl_20161214-1_i386.deb OpenSSL bindings for Lua
lua-luassert_1.7.10-1_all.deb Lua assertions extension
lua-luv-dev_1.9.1-0-2_i386.deb libuv bindings for lua
lua-luv_1.9.1-0-2_i386.deb libuv bindings for lua
lua-luxio-doc_13-1_all.deb Documentation for lua-luxio
lua-luxio0_13-1_all.deb Posix bindings for Lua (transitional package)
lua-luxio_13-1_i386.deb Posix bindings for Lua
lua-lxc_3.0.2-1_i386.deb Linux Containers userspace tools (Lua bindings)
lua-markdown_0.32-5_all.deb Pure Lua 5.1 implementation of the Markdown text-to-html markup
lua-md5-dev_1.2+git+1+8d87fee-1.1_i386.deb MD5 library for the Lua language
lua-md5_1.2+git+1+8d87fee-1.1_i386.deb MD5 library for the Lua language
Advertisement
Advertisement