lua-cqueues-dev_20171014-1_i386.deb


Advertisement

Description

lua-cqueues-dev - event loop for Lua (development package)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-cqueues-dev_20171014-1_i386.deb
Package name lua-cqueues-dev
Package version 20171014
Package release 1
Package architecture i386
Package type deb
Category interpreters
Homepage http://www.25thandclement.com/~william/projects/cqueues.html
License -
Maintainer Ondřej Surý <ondrej@debian.org>
Download size 510.26 KB
Installed size 1.65 MB
cqueues is a type of event loop for Lua, except it's not a classic
event loop. It doesn't use callbacks—neither as part of the API nor
internally—but instead you communicate with an event controller by
the yielding and resumption of Lua coroutines using objects that
adhere to a simple interface.

Alternatives

Package Version Architecture Repository
lua-cqueues-dev_20171014-1_amd64.deb 20171014 amd64 Debian Main
lua-cqueues-dev - - -

Requires

Name Value
lua-cqueues = 20171014-1

Provides

Name Value
lua5.1-cqueues-dev -
lua5.2-cqueues-dev -
lua5.3-cqueues-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-cqueues-dev_20171014-1_i386.deb
Source Package lua-cqueues

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-cqueues-dev deb package:
    # sudo apt-get install lua-cqueues-dev

Files

Path
/usr/include/lua5.1/cqueues.h
/usr/include/lua5.2/cqueues.h
/usr/include/lua5.3/cqueues.h
/usr/lib/i386-linux-gnu/liblua5.1-cqueues.a
/usr/lib/i386-linux-gnu/liblua5.1-cqueues.so
/usr/lib/i386-linux-gnu/liblua5.2-cqueues.a
/usr/lib/i386-linux-gnu/liblua5.2-cqueues.so
/usr/lib/i386-linux-gnu/liblua5.3-cqueues.a
/usr/lib/i386-linux-gnu/liblua5.3-cqueues.so
/usr/lib/i386-linux-gnu/pkgconfig/lua5.1-cqueues.pc
/usr/lib/i386-linux-gnu/pkgconfig/lua5.2-cqueues.pc
/usr/lib/i386-linux-gnu/pkgconfig/lua5.3-cqueues.pc
/usr/share/doc/lua-cqueues-dev/changelog.Debian.gz
/usr/share/doc/lua-cqueues-dev/copyright
/usr/share/doc/lua-cqueues-dev/cqueues.pdf.gz
/usr/share/doc/lua-cqueues-dev/examples/chat.srv.gz
/usr/share/doc/lua-cqueues-dev/examples/condition.lua
/usr/share/doc/lua-cqueues-dev/examples/dig.lua
/usr/share/doc/lua-cqueues-dev/examples/echo.srv
/usr/share/doc/lua-cqueues-dev/examples/getopt.lua
/usr/share/doc/lua-cqueues-dev/examples/httpd.srv
/usr/share/doc/lua-cqueues-dev/examples/notify.lua
/usr/share/doc/lua-cqueues-dev/examples/peereid.lua
/usr/share/doc/lua-cqueues-dev/examples/promise.lua
/usr/share/doc/lua-cqueues-dev/examples/signal.pause
/usr/share/doc/lua-cqueues-dev/examples/signal.wait
/usr/share/doc/lua-cqueues-dev/examples/simple.get
/usr/share/doc/lua-cqueues-dev/examples/socket.pair
/usr/share/doc/lua-cqueues-dev/examples/socket.xchg
/usr/share/doc/lua-cqueues-dev/examples/thread.count

Changelog

2018-12-18 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20171014-1) unstable; urgency=medium
* Exclude upstream debian/ directory
* Add d/watch for the project
* Repack upstream tarball
* New upstream version 20171014
2016-12-15 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20161214-2) unstable; urgency=medium
* Enable Lua 5.3 support
* Add correct defines to compile with Lua 5.3
2016-12-15 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20161214-1) unstable; urgency=medium
* Imported Upstream version 20161214
2016-10-27 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20161018-1) unstable; urgency=medium
* Imported Upstream version 20161018
+ Includes openssl 1.1.0 support (Closes: #835785)
* Remove __typeof__ patch merged upstream
2016-08-24 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160812-1) unstable; urgency=medium
* Imported Upstream version 20160812
* Remove __linux__ macro patch as it was fixed upstream
* d/rules: Pre-build config.h
2016-07-14 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160316-5) unstable; urgency=medium
* Install cqueues .lua files into correct directories
2016-07-14 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160316-4) unstable; urgency=medium
* Update to use __linux__ macro instead of __linux, extend __FreeBSD__
to also include __FreeBSD_kernel__ (Closes: #831013)
* Add Dependency between lua-cqueues-dev and lua-cqueues
2016-07-13 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160316-3) unstable; urgency=medium
* lua files has to be placed in cqueues/ subdirectory
2016-07-13 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160316-2) unstable; urgency=medium
* Add m4 to Build-Depends and Update Vcs-Browser to correct URL
2016-07-12 - Ondřej Surý <ondrej@debian.org>
lua-cqueues (20160316-1) unstable; urgency=low
* Initial release.

See Also

Package Description
lua-cqueues_20171014-1_i386.deb event loop for Lua
lua-curl-dev_0.3.0-9.2_i386.deb libcURL development files for the Lua language
lua-curl_0.3.0-9.2_i386.deb libcURL bindings for the Lua language
lua-curses-dev_9.0.0-2+b1_i386.deb Development files for the lua-curses library
lua-curses_9.0.0-2+b1_i386.deb curses library bindings for the Lua language
lua-cyrussasl-dev_1.0.0-6.1_i386.deb Cyrus SASL development files for the Lua language
lua-cyrussasl_1.0.0-6.1_i386.deb Cyrus SASL library for the Lua language
lua-dbi-common_0.7.1-2_all.deb DBI library for the Lua language, common files
lua-dbi-mysql-dev_0.7.1-2_i386.deb DBI library for the Lua language, MySQL development files
lua-dbi-mysql_0.7.1-2_i386.deb DBI library for the Lua language, MySQL backend
lua-dbi-postgresql-dev_0.7.1-2_i386.deb DBI library for the Lua language, PostgreSQL development files
lua-dbi-postgresql_0.7.1-2_i386.deb DBI library for the Lua language, PostgreSQL backend
lua-dbi-sqlite3-dev_0.7.1-2_i386.deb DBI library for the Lua language, sqlite3 development files
lua-dbi-sqlite3_0.7.1-2_i386.deb DBI library for the Lua language, sqlite3 backend
lua-discount-dev_2.1.8-3_i386.deb discount development files for the Lua language
Advertisement
Advertisement