lua-cjson_2.1.0+dfsg-2.1_i386.deb


Advertisement

Description

lua-cjson - JSON parser/encoder for Lua

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-cjson_2.1.0+dfsg-2.1_i386.deb
Package name lua-cjson
Package version 2.1.0+dfsg
Package release 2.1
Package architecture i386
Package type deb
Category interpreters
Homepage http://www.kyne.com.au/~mark/software/lua-cjson.php
License -
Maintainer The Debian Lua Team <pkg-lua-devel@lists.alioth.debian.org>
Download size 17.50 KB
Installed size 87.00 KB
This library allows you to easily convert Lua values to JSON strings and back.
Features:
* Fast, standards compliant encoding/parsing routines
* Full support for JSON with UTF-8, including decoding surrogate pairs
* Optional run-time support for common exceptions to the JSON
specification (infinity, NaN,..)
* No dependencies on other libraries

Alternatives

Package Version Architecture Repository
lua-cjson_2.1.0+dfsg-2.1_amd64.deb 2.1.0+dfsg amd64 Debian Main
lua-cjson - - -

Requires

Name Value
libc6 >= 2.4

Provides

Name Value
lua5.1-cjson -
lua5.2-cjson -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-cjson_2.1.0+dfsg-2.1_i386.deb
Source Package lua-cjson

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-cjson deb package:
    # sudo apt-get install lua-cjson

Files

Path
/usr/lib/i386-linux-gnu/liblua5.1-cjson.so.0
/usr/lib/i386-linux-gnu/liblua5.1-cjson.so.0.0.0
/usr/lib/i386-linux-gnu/liblua5.2-cjson.so.0
/usr/lib/i386-linux-gnu/liblua5.2-cjson.so.0.0.0
/usr/lib/i386-linux-gnu/lua/5.1/cjson.so
/usr/lib/i386-linux-gnu/lua/5.2/cjson.so
/usr/share/doc/lua-cjson/changelog.Debian.gz
/usr/share/doc/lua-cjson/copyright
/usr/share/lua/5.1/cjson/util.lua
/usr/share/lua/5.2/cjson/util.lua

Changelog

2018-01-20 - Aurelien Jarno <aurel32@debian.org>
lua-cjson (2.1.0+dfsg-2.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control: Drop explicit Pre-Depends on multiarch-support
(Closes: #870548).
2012-09-24 - Dmitry E. Oboukhov <unera@debian.org>
lua-cjson (2.1.0+dfsg-2) unstable; urgency=low
* Add debian/watch file.
2012-08-24 - Dmitry E. Oboukhov <unera@debian.org>
lua-cjson (2.1.0+dfsg-1) unstable; urgency=low
* Initial release. (Closes: #685591)

See Also

Package Description
lua-cliargs_3.0-2-1_all.deb command-line argument parsing module for Lua
lua-clod-doc_1.0.2-3_all.deb Documentation for lua-clod
lua-clod_1.0.2-3_all.deb Configuration Language Organised (by) Dots
lua-compat53_0.3-3_i386.deb Lua-5.3-style APIs for Lua 5.2 and 5.1
lua-copas_1.2.0-1_all.deb Copas is a dispatcher of concurrent TCP/IP requests
lua-cosmo_13.01.30-2_all.deb Template library for the Lua language
lua-coxpcall_1.14.0-2_all.deb Protected function calls across coroutines for Lua
lua-cqueues-dev_20171014-1_i386.deb event loop for Lua (development package)
lua-cqueues_20171014-1_i386.deb event loop for Lua
lua-curl-dev_0.3.0-9.2_i386.deb libcURL development files for the Lua language
lua-curl_0.3.0-9.2_i386.deb libcURL bindings for the Lua language
lua-curses-dev_9.0.0-2+b1_i386.deb Development files for the lua-curses library
lua-curses_9.0.0-2+b1_i386.deb curses library bindings for the Lua language
lua-cyrussasl-dev_1.0.0-6.1_i386.deb Cyrus SASL development files for the Lua language
lua-cyrussasl_1.0.0-6.1_i386.deb Cyrus SASL library for the Lua language
Advertisement
Advertisement