lua-argparse_0.6.0-1_all.deb


Advertisement

Description

lua-argparse - feature-rich command line parser for Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lua-argparse_0.6.0-1_all.deb
Package name lua-argparse
Package version 0.6.0
Package release 1
Package architecture all
Package type deb
Category interpreters
Homepage https://github.com/mpeterv/argparse
License -
Maintainer Victor Seva <vseva@debian.org>
Download size 30.61 KB
Installed size 94.00 KB
Argparse supports positional arguments, options, flags, optional arguments,
subcommands and more. Argparse automatically generates usage, help and error
messages.

Alternatives

Package Version Architecture Repository
lua-argparse_0.6.0-1_all.deb 0.6.0 all Debian Main
lua-argparse - - -

Provides

Name Value
lua5.1-argparse -
lua5.2-argparse -
lua5.3-argparse -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-argparse_0.6.0-1_all.deb
Source Package lua-argparse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-argparse deb package:
    # sudo apt-get install lua-argparse

Files

Path
/usr/share/doc/lua-argparse/arguments.txt
/usr/share/doc/lua-argparse/callbacks.txt.gz
/usr/share/doc/lua-argparse/changelog.Debian.gz
/usr/share/doc/lua-argparse/changelog.gz
/usr/share/doc/lua-argparse/commands.txt
/usr/share/doc/lua-argparse/copyright
/usr/share/doc/lua-argparse/defaults.txt
/usr/share/doc/lua-argparse/index.txt
/usr/share/doc/lua-argparse/messages.txt.gz
/usr/share/doc/lua-argparse/misc.txt.gz
/usr/share/doc/lua-argparse/mutexes.txt
/usr/share/doc/lua-argparse/options.txt
/usr/share/doc/lua-argparse/parsers.txt
/usr/share/lua/5.1/argparse.lua
/usr/share/lua/5.2/argparse.lua
/usr/share/lua/5.3/argparse.lua
/usr/share/man/man1/argparse.1.gz

Changelog

2018-06-21 - Victor Seva <vseva@debian.org>
lua-argparse (0.6.0-1) unstable; urgency=medium
* New upstream version 0.6.0
* update Vcs-* urls to salsa
* fix lintian build-depends-on-python-sphinx-only
* upgrade Standars-Version, no changes needed
2017-05-22 - Victor Seva <vseva@debian.org>
lua-argparse (0.5.0-1) unstable; urgency=medium
* Initial release (Closes: #863122)

See Also

Package Description
lua-augeas_0.1.1-3_i386.deb Lua binding to the Augeas C API
lua-basexx_0.3-2_all.deb baseXX encoding/decoding library for Lua
lua-bit32-dev_5.3.0-3_i386.deb Development files for the bit32 library for Lua 5.1
lua-bit32_5.3.0-3_i386.deb Backport of the Lua 5.2 bit32 library to Lua 5.1
lua-bitop-dev_1.0.2-5_i386.deb fast bit manipulation library devel files for the Lua language
lua-bitop_1.0.2-5_i386.deb fast bit manipulation library for the Lua language
lua-busted_2.0~rc12-1-2_all.deb Lua unit testing framework focused on ease of use
lua-cgi_5.2~alpha2-1_all.deb CGI library for the Lua language
lua-check_0.23.0-1_all.deb static analyzer and a linter for the Lua language
lua-cjson-dev_2.1.0+dfsg-2.1_i386.deb JSON parser/encoder for Lua, development files
lua-cjson_2.1.0+dfsg-2.1_i386.deb JSON parser/encoder for Lua
lua-cliargs_3.0-2-1_all.deb command-line argument parsing module for Lua
lua-clod-doc_1.0.2-3_all.deb Documentation for lua-clod
lua-clod_1.0.2-3_all.deb Configuration Language Organised (by) Dots
lua-compat53_0.3-3_i386.deb Lua-5.3-style APIs for Lua 5.2 and 5.1
Advertisement
Advertisement