love_11.1-2_i386.deb


Advertisement

Description

love - 2D game development framework based on Lua and OpenGL

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package name love
Package version 11.1
Package release 2
Package architecture i386
Package type deb
Installed size 4.18 KB
Download size 1.37 MB
Official Mirror ftp.br.debian.org
LÖVE was created to be a user-friendly engine in which simple (or
complicated) games could be made without having extensive knowledge
of system or graphics functions and without having to dedicate time
towards developing the same engine features time and time again.
Developed with cross-platform implementation in mind, it utilizes the
latest open source libraries to deliver a similar game experience,
independent of operating system. By relying on the Lua scripting language
for game-specific programming, it allows even the novice game creator to
quickly and efficiently develop an idea into a fully working game.

Alternatives

Package Version Architecture Repository
love_11.1-2_amd64.deb 11.1 amd64 Debian Main
love - - -

Requires

Name Value
libc6 >= 2.27
libfreetype6 >= 2.2.1
libgcc1 >= 1:4.2
libluajit-5.1-2 >= 2.0.4+dfsg
libmodplug1 >= 1:0.8.8.5
libmpg123-0 >= 1.13.7
libogg0 >= 1.1.4~dfsg
libopenal1 >= 1.14
libsdl2-2.0-0 >= 2.0.8
libstdc++6 >= 5.2
libtheora0 >= 1.0
libvorbisfile3 >= 1.1.2
zlib1g >= 1:1.2.0

Download

Type URL
Binary Package love_11.1-2_i386.deb
Source Package love

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install love deb package:
    # sudo apt-get install love

Files

Path
/usr/bin/love-11.1
/usr/lib/mime/packages/love
/usr/share/application-registry/love.applications
/usr/share/applications/love.desktop
/usr/share/binfmts/love
/usr/share/doc/love/changelog.Debian.gz
/usr/share/doc/love/changelog.gz
/usr/share/doc/love/copyright
/usr/share/doc/love/readme.md
/usr/share/lintian/overrides/love
/usr/share/man/man6/love-11.1.6.gz
/usr/share/mime-info/love.keys
/usr/share/mime-info/love.mime
/usr/share/mime/packages/love.xml
/usr/share/pixmaps/love-app.png
/usr/share/pixmaps/love-app.svg
/usr/share/pixmaps/love-app.xpm
/usr/share/pixmaps/love-game.png
/usr/share/pixmaps/love-game.svg
/usr/share/pixmaps/love-game.xpm

Changelog

2018-08-04 - Reiner Herrmann <reiner@reiner-h.de>
love (11.1-2) unstable; urgency=medium
* Team upload.
* Remove luajit dependency restriction on hurd-i386 and kfreebsd-amd64.
* Restore check for lua implementation for architectures without luajit.
* Drop big-endian architectures as the hash module requires little-endian.
* Enable also non-release little-endian architectures.
* Drop unused build dependencies.
2018-08-03 - Markus Koschany <apo@debian.org>
love (11.1-1) unstable; urgency=medium
[ Reiner Herrmann, Alexandre Detiste ]
* Team upload.
* New upstream version 11.1. (Closes: #830876, #815170))
- The package builds from source again. (Closes: #873329)
* Fix FTCBFS by switching to dh sequencer. (Closes: #894041)
* Bump Standards-Version to 4.2.0
* Drop scripts_source.patch; included in upstream tarball
* Remove LDADD section from src/Makefile.am patch.
It was no longer building as it couldn't find a target '.libs/liblove.a'.
* Convert to dh-based build
* Disable -doc package for now.
It's currently unclear to me where the -doc and -demos tarball
is coming from.
* Since the -doc package is disabled and the patch for upstream's manpage was
accepted, this (Closes: #892917)
* The mimelnk files are no longer installed. (Closes: #875525)
* Remove unused lintian-override
* Install files only via dh_install; otherwise it installs static library too
* Add build dependency libtheora-dev
[ Markus Koschany ]
* Remove autoconf and automake from B-D because compat 11 provides them
automatically.
2016-08-03 - Markus Koschany <apo@debian.org>
love (0.9.1-4) unstable; urgency=medium
* Team upload.
* Drop README.source because source format 3.0 uses quilt by default.
* wrap-and-sort -sab.
* Use compat level 9 and require debhelper >= 9.
* Declare compliance with Debian Policy 3.9.8.
* Use secure Vcs-Browser URL.
* Drop love-dbg binary package and use the automatic -dbgsym package instead.
* Remove spurious libmng-dev build-dependency.
Thanks to Moritz Muehlenhoff for the report. (Closes: #757171)
* Build demos in arch-indep target. (Closes: #806657)
* Use default xz compression for the debian tarball.
* Fix Lintian warnings in debian/copyright.
* debian/rules: Fix Lintian error privacy-breach-google-plus.
2014-11-13 - Vincent Cheng <vcheng@debian.org>
love (0.9.1-3) unstable; urgency=medium
* Team upload.
* Add Breaks+Replaces relation against older versions of love to fix
wheezy -> jessie upgrades. (Closes: #768206)
2014-04-28 - Miriam Ruiz <miriam@debian.org>
love (0.9.1-2) unstable; urgency=medium
* Don't use luajit for architectures where it is not supported:
hurd-i386 !kfreebsd-amd64 !s390x
* Moved demos to love-doc package to make love package lighter
2014-04-11 - Miriam Ruiz <miriam@debian.org>
love (0.9.1-1) unstable; urgency=medium
[ Miriam Ruiz ]
* New upstream release
+ 0.9.1's API is fully backward compatible with existing 0.9.0 games.
+ Most of the changes are bug fixes, internal code improvements, and
+ some API additions and updates to flesh out LÖVE's features,
+ especially in the love.graphics module.
+ See http://love2d.org/forums/viewtopic.php?f=3&t=77609
+ See https://www.love2d.org/wiki/0.9.1
* Refreshed patches
* Temporarily removed the patches to use Glee from system, as Glee 5.5 is
needed for the program to compile.

See Also

Package Description
lp-solve-doc_5.5.0.15-4_all.deb Solve (mixed integer) linear programming problems - documentation
lp-solve_5.5.0.15-4+b1_i386.deb Solve (mixed integer) linear programming problems
lpc21isp_1.97-4_i386.deb In-circuit programming (ISP) of ARM and Cortex microcontrollers
lpctools_1.07-1_i386.deb interface to NXP LPC Microcontrollers ISP serial interface
lpe_1.2.8-2+b2_i386.deb Lightweight Programmer's Editor
lphdisk_0.9.1.ds1-3_i386.deb prepares hibernation partition for Phoenix NoteBIOS
lpr_2008.05.17.3_i386.deb BSD lpr/lpd line printer spooling system
lprng-doc_3.8.A~rc2-3.1_all.deb lpr/lpd printer spooling system (documentation)
lprng_3.8.B-2.1_i386.deb lpr/lpd printer spooling system
lptools_0.2.0-3_all.deb Tools for working with Launchpad
lqa_20180702.0-1_all.deb lava qa tool
lr_1.4.1-1_i386.deb list files, recursively
lrcalc_1.2-2+b1_i386.deb programs for calculating Littlewood-Richardson coefficients
lrslib_0.70-3_i386.deb package to enumerate vertices and extreme rays of a convex polyhedron
lrzip_0.631+git180528-1_i386.deb compression program with a very high compression ratio
Advertisement
Advertisement