lordsawar_0.3.1-4_i386.deb


Advertisement

Description

lordsawar - Clone of the popular SSG game Warlords II

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lordsawar_0.3.1-4_i386.deb
Package name lordsawar
Package version 0.3.1
Package release 4
Package architecture i386
Package type deb
Category game::strategy games implemented-in::c++ interface::graphical interface::x11 role::program uitoolkit::gtk uitoolkit::sdl use::gameplaying x11::application
Homepage http://www.nongnu.org/lordsawar/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 2.65 MB
Installed size 17.09 MB
A 2d turn-based strategy game where up to 8 players strive for control
of as many cities as possible. Produce new armies in cities to conquer
nearby cities. Using the income from those cities, make more armies to
take more cities. Send a hero to a temple to get a quest, or maybe search
a nearby ruin instead. Game should run well on modest hardware.
Play with others or against the computer.

Alternatives

Package Version Architecture Repository
lordsawar_0.3.1-4_amd64.deb 0.3.1 amd64 Debian Main
lordsawar - - -

Requires

Name Value
libarchive13 >= 3.0.4
libatkmm-1.6-1v5 >= 2.24.0
libc6 >= 2.4
libcairomm-1.0-1v5 >= 1.12.0
libgcc1 >= 1:3.0
libglib2.0-0 >= 2.22.0
libglibmm-2.4-1v5 >= 2.54.0
libgtk-3-0 >= 3.0.0
libgtkmm-3.0-1v5 >= 3.22.0
libpango-1.0-0 >= 1.22.0
libpangocairo-1.0-0 >= 1.14.0
libpangomm-1.4-1v5 >= 2.40.0
libsigc++-2.0-0v5 >= 2.8.0
libstdc++6 >= 5.2
libxml++2.6-2v5 >= 2.40.0
libxml2 >= 2.7.4
libxslt1.1 >= 1.1.25
lordsawar-data = 0.3.1-4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lordsawar_0.3.1-4_i386.deb
Source Package lordsawar

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lordsawar deb package:
    # sudo apt-get install lordsawar

Files

Path
/usr/games/lordsawar
/usr/games/lordsawar-editor
/usr/games/lordsawar-game-host-client
/usr/games/lordsawar-game-host-server
/usr/games/lordsawar-game-list-client
/usr/games/lordsawar-game-list-server
/usr/games/lordsawar-import
/usr/share/applications/lordsawar-editor.desktop
/usr/share/applications/lordsawar.desktop
/usr/share/doc/lordsawar/changelog.Debian.gz
/usr/share/doc/lordsawar/changelog.gz
/usr/share/doc/lordsawar/copyright

Changelog

2017-12-31 - Markus Koschany <apo@debian.org>
lordsawar (0.3.1-4) unstable; urgency=medium
* Drop libglademm-2.4-dev from Build-Depends. (Closes: #885888)
* Declare compliance with Debian Policy 4.1.3.
* Use dh_missing override.
* Switch to compat level 11.
2017-08-16 - Markus Koschany <apo@debian.org>
lordsawar (0.3.1-3) unstable; urgency=medium
* Fix FTBFS with GCC 7. (Closes: #853529)
* Declare compliance with Debian Policy 4.0.1.
2017-07-08 - Markus Koschany <apo@debian.org>
lordsawar (0.3.1-2) unstable; urgency=medium
* Declare compliance with Debian Policy 4.0.0.
* Drop deprecated menu file and xpm icon.
* Use https for Format field.
* Add bigmap-cairomm.patch and fix FTBFS with cairomm 1.12.2.
(Closes: #866988)
2016-10-03 - Markus Koschany <apo@debian.org>
lordsawar (0.3.1-1) unstable; urgency=medium
* New upstream version 0.3.1.
* Drop gcc6.patch. Fixed upstream.
* Drop reproducible-build.patch. Fixed upstream.
* Remove dh-autoreconf from Build-Depends.
2016-10-01 - Markus Koschany <apo@debian.org>
lordsawar (0.3.0-4) unstable; urgency=medium
* Add gcc6.patch and fix FTBFS with GCC-6. (Closes: #839323)
Thanks to Lucas Nussbaum for the report.
* Switch to compat level 10.
2016-06-30 - Markus Koschany <apo@debian.org>
lordsawar (0.3.0-3) unstable; urgency=medium
* Add reproducible-build.patch and make the build reproducible.
Thanks to Reiner Herrmann for the report and patch and Alexandre Detiste
for his initial work. (Closes: #828898)
* Declare compliance with Debian Policy 3.9.8.
* Vcs-Git: Use https.
* debian/watch: Use version=4.
2015-11-02 - Markus Koschany <apo@debian.org>
lordsawar (0.3.0-2) unstable; urgency=medium
* Rebuild lordsawar against the latest version of libxml++2.6-2v5 and fix
segmentation fault on startup.
* Update my e-mail address.
* Vcs-Browser: Use https.
2015-07-03 - Markus Koschany <apo@gambaru.de>
lordsawar (0.3.0-1) unstable; urgency=medium
[ Alexander Reichle-Schmehl ]
* Remove myself from uploaders.
[ Markus Koschany ]
* Imported Upstream version 0.3.0.
* Acknowledge last NMU from Matthias Klose. Thank you.
* debian/lordsawar.menu: Add missing icon entry. (Closes: #726812)
* Switch to source format 3.0 (quilt).
* Update debian/copyright for new release. Switch to copyright format 1.0.
* debian/rules:
- Add get-orig-source target.
- Export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed.
- Build with autoreconf and --parallel.
- Switch to dh sequencer and simplify debian/rules.
- Disable sound until gstreamermm-1.0 is available.
* Update debian/watch file for new download mirror.
* Drop ftbfs_as-needed.diff. No longer necessary.
* Drop README.source. Source format 3.0 uses quilt by default.
* wrap-and-sort -sa.
* debian/control:
- Change priority from extra to optional.
- Declare compliance with Debian Policy 3.9.6.
- Add myself to Uploaders.
- Update homepage field and point to nongnu.org/lordsawar.
- lordsawar-data: Change Recommends: lordsawar to Suggests: lordsawar.
- Update package description. Network play is not broken.
- Remove the following build-dependencies:
+ quilt, libboost-dev, uuid-dev, libsdl1.2-mixer, libtar-dev,
libgtkmm2.4-dev, intltool
- Add the following build-dependencies:
+ libxml++2.6-dev, libarchive-dev, libgtkmm-3.0-dev, libxslt1-dev,
gnome-common, libsigc++-2.0-dev.
* Use compat level 9 and require debhelper >= 9.
* Move the package to Git.
* Drop Debian specific desktop files and man pages. Install upstream files
instead.
* Drop lordsawar.docs. README, NEWS and TODO files are not useful enough.
* Remove lordsawar-upgrade-file because it is not really useful for normal
users.
* Add lordsawar-data.links and symlink /usr/share/games/lordsawar to
/usr/share/lordsawar. This ensures the translations can be found correctly
and is simpler to maintain than patching the build system.

See Also

Package Description
lorene-codes-src_0.0.0~cvs20161116+dfsg-1_all.deb source files of LORENE-based codes
lorene-doc_0.0.0~cvs20161116+dfsg-1_all.deb documentation for LORENE
lorene_0.0.0~cvs20161116+dfsg-1_all.deb framework for numerical relativity
lostirc_0.4.6-4.2_i386.deb simple gtk-based IRC client
lout-common_3.39-3_all.deb Common files for the Lout typesetting system
lout-doc_3.39-3_all.deb Documentation on the Lout typesetting system
lout_3.39-3+b1_i386.deb Typesetting system, an alternative to (La)TeX
love_11.1-2_i386.deb 2D game development framework based on Lua and OpenGL
lp-solve-doc_5.5.0.15-4_all.deb Solve (mixed integer) linear programming problems - documentation
lp-solve_5.5.0.15-4+b1_i386.deb Solve (mixed integer) linear programming problems
lpc21isp_1.97-4_i386.deb In-circuit programming (ISP) of ARM and Cortex microcontrollers
lpctools_1.07-1_i386.deb interface to NXP LPC Microcontrollers ISP serial interface
lpe_1.2.8-2+b2_i386.deb Lightweight Programmer's Editor
lphdisk_0.9.1.ds1-3_i386.deb prepares hibernation partition for Phoenix NoteBIOS
lpr_2008.05.17.3_i386.deb BSD lpr/lpd line printer spooling system
Advertisement
Advertisement