lldpad-dev_1.0.1+git20180808.4e642bd-1_i386.deb


Advertisement

Description

lldpad-dev - Link Layer Discovery Protocol Implementation (Development headers)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lldpad-dev_1.0.1+git20180808.4e642bd-1_i386.deb
Package name lldpad-dev
Package version 1.0.1+git20180808.4e642bd
Package release 1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://open-lldp.org/
License -
Maintainer Debian FCoE Maintainers <team+fcoe@tracker.debian.org>
Download size 39.04 KB
Installed size 141.00 KB
The lldpad package is an implementation of the Link Layer Discovery
Protocol (LLDP).  It originated from Intel's Data Center Bridging (DCB)
software - the dcbd package.  The lldpad package adds LLDP support
for all ports in addition to DCB Exchange protocol (DCBX) support on DCB
capable ports (as was provided by dcbd).  Also, support for additional
LLDP TLVs has been added.
DCB is a collection of emerging standards-based technologies designed to
allow Ethernet to support multiple types of traffic classes in the Data
Center.  The DCBX functionality of this package is designed to work with
the DCB kernel interface (dcbnl in rtnetlink) that is included in the Linux
kernel 2.6.29 or higher.  The Intel ixgbe driver supports the dcbnl interface.
This package contains lldpad development headers.

Alternatives

Package Version Architecture Repository
lldpad-dev_1.0.1+git20180808.4e642bd-1_amd64.deb 1.0.1+git20180808.4e642bd amd64 Debian Main
lldpad-dev - - -

Requires

Name Value
lldpad = 1.0.1+git20180808.4e642bd-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lldpad-dev_1.0.1+git20180808.4e642bd-1_i386.deb
Source Package lldpad

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lldpad-dev deb package:
    # sudo apt-get install lldpad-dev

Files

Path
/usr/include/lldpad/clif.h
/usr/include/lldpad/clif_msgs.h
/usr/include/lldpad/clif_sock.h
/usr/include/lldpad/dcb_types.h
/usr/include/lldpad/dcbnl.h
/usr/include/lldpad/lldp_8021qaz_cmds.h
/usr/include/lldpad/lldp_8023_cmds.h
/usr/include/lldpad/lldp_basman_cmds.h
/usr/include/lldpad/lldp_dcbx_cmds.h
/usr/include/lldpad/lldp_evb_cmds.h
/usr/include/lldpad/lldp_mand_cmds.h
/usr/include/lldpad/lldp_med_cmds.h
/usr/include/lldpad/lldp_util.h
/usr/include/lldpad/lldpad.h
/usr/include/lldpad/lldpad_status.h
/usr/include/lldpad/netlink.h
/usr/include/lldpad/qbg_vdp_cmds.h
/usr/include/lldpad/rtnetlink.h
/usr/lib/i386-linux-gnu/liblldp_clif.a
/usr/lib/i386-linux-gnu/liblldp_clif.la
/usr/lib/i386-linux-gnu/liblldp_clif.so
/usr/lib/i386-linux-gnu/pkgconfig/liblldp_clif.pc
/usr/lib/i386-linux-gnu/pkgconfig/lldpad.pc
/usr/share/doc/lldpad-dev/README.gz
/usr/share/doc/lldpad-dev/changelog.Debian.gz
/usr/share/doc/lldpad-dev/changelog.gz
/usr/share/doc/lldpad-dev/copyright
/usr/share/man/man3/liblldp_clif-vdp22.3.gz

Changelog

2018-08-17 - Valentin Vidic <Valentin.Vidic@CARNet.hr>
lldpad (1.0.1+git20180808.4e642bd-1) unstable; urgency=medium
* New upstream version 1.0.1+git20180808.4e642bd
- Fixes CVE-2018-10932: improper sanitization of shell-escape
codes (Closes: #905901)
* Refresh patches for new upstream version
* Add symbols for liblldp_clif.so.1
* Package test lldpad only
2018-06-23 - tony mancill <tmancill@debian.org>
lldpad (1.0.1+git20150824.036e314-4) unstable; urgency=medium
* Team upload.
* Update FCoE team address (Closes: #899600)
2018-05-13 - tony mancill <tmancill@debian.org>
lldpad (1.0.1+git20150824.036e314-3) unstable; urgency=medium
* Team upload
* Update Vcs fields for migration from Alioth -> Salsa
* Add patch for segfault in get_saddr6 (Closes: #897693)
* Bump Standards-Version to 4.1.4
2018-01-26 - Valentin Vidic <Valentin.Vidic@CARNet.hr>
lldpad (1.0.1+git20150824.036e314-2) unstable; urgency=medium
* lldpad-dev: add missing depends on lldpad (Closes: #887569)
* Update debhelper to v11
* Cleanup trailing whitespace from control files
* Convert debian/copyright to DEP-5
* Add debian/tests
* Bump Standards-Version to 4.1.3
* Update Vcs-Git and Vcs-Browser URLs
* Update uscan URL to use SSL
* Update patch descriptions
* Fix spelling errors reported by lintian
* Add lldpad.service Documentation value
2017-12-26 - Valentin Vidic <Valentin.Vidic@CARNet.hr>
lldpad (1.0.1+git20150824.036e314-1) unstable; urgency=medium
[ Ritesh Raj Sarraf ]
* Remove myself from uploaders
[ Valentin Vidic ]
* New upstream version 1.0.1+git20150824.036e314
* Add patch to fix FTBFS with GCC-7 (Closes: #853521)
* Update to debhelper level 10
* Add lsb-base to Depends
* Update Standards-Version to 4.1.2
* Install bash completion in /usr/share/bash-completion/completions
* Package all installed files
* Handle init script management automatically
* Refresh patches for new upstream version and drop unused patches
* Replace Priority extra with optional
* Add myself to Uploaders
* Package library manpage
* Fix installation of init and systemd services
* Add patches for lintian warnings
* Remove /var/lib/lldpad on purge
* Fix cleanup of parse_cli.c
2014-10-23 - Jacob Luna Lundberg <jacob@gnifty.net>
lldpad (0.9.46-3) unstable; urgency=low
* Added myself as a maintainer of this package.
* Applied upstream's patch to switch to libnl-3.
* Updated the standards version to 3.9.6; no changes required.
* Added a lintian override for liblldp-clif1 packaged in lldapd.
* Prevent lldpad from being started at install (it breaks).
2014-02-12 - Ritesh Raj Sarraf <rrs@debian.org>
lldpad (0.9.46-2) unstable; urgency=medium
* Add patch to fix build failure. Thanks Hideki Yamane
* debian/patches
- add specify_subdir-objects.patch (Closes: #725579)
2013-07-16 - Ritesh Raj Sarraf <rrs@debian.org>
lldpad (0.9.46-1) unstable; urgency=low
* [8e5431e] Imported Upstream version 0.9.46
* [4b269d3] Refresh patches
* [a1194ea] Add README.source
* [49b09fb] update Vcs links
* [baf5d63] Add Hardening build
2012-04-28 - Ritesh Raj Sarraf <rrs@debian.org>
lldpad (0.9.44-1) unstable; urgency=low
[ Liang Guo ]
* New upstream release
* Replase libconfig8-dev to libconfig-dev (Closes: #661408)
* debian/control:
- Bump Standards-Version to 3.9.3
- Add libreadline-dev to Build-Depends
* debian/copyright:
- Update download link
- Update copyright information
[ Ritesh Raj Sarraf ]
* [167d25a] Install empty folder for lldpad (Closes: #669540)

See Also

Package Description
lldpad_1.0.1+git20180808.4e642bd-1_i386.deb Link Layer Discovery Protocol Implementation (Runtime)
lldpd_1.0.3-1+b1_i386.deb implementation of IEEE 802.1ab (LLDP)
llgal_0.13.19-1_all.deb Command-line online gallery generator
llmnrd_0.5-1_i386.deb Link-Local Multicast Resolution (LLMNR) Daemon for Linux
lloconv_6.1.0-3_i386.deb command line document converter using LibreOfficeKit
lltag_0.14.6-1_all.deb Automatic command-line mp3/ogg/flac file tagger and renamer
llvm-6.0-dev_6.0.1-10_i386.deb Modular compiler and toolchain technologies, libraries and headers
llvm-6.0-doc_6.0.1-10_all.deb Modular compiler and toolchain technologies, documentation
llvm-6.0-examples_6.0.1-10_all.deb Modular compiler and toolchain technologies, examples
llvm-6.0-runtime_6.0.1-10_i386.deb Modular compiler and toolchain technologies, IR interpreter
llvm-6.0-tools_6.0.1-10_i386.deb Modular compiler and toolchain technologies, tools
llvm-6.0_6.0.1-10_i386.deb Modular compiler and toolchain technologies
llvm-7-dev_7.0.1-8_i386.deb Modular compiler and toolchain technologies, libraries and headers
llvm-7-doc_7.0.1-8_all.deb Modular compiler and toolchain technologies, documentation
llvm-7-examples_7.0.1-8_all.deb Modular compiler and toolchain technologies, examples
Advertisement
Advertisement