live-wrapper_0.8_all.deb


Advertisement

Description

live-wrapper - Wrapper for vmdebootstrap for creating live images

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename live-wrapper_0.8_all.deb
Package name live-wrapper
Package version 0.8
Package release -
Package architecture all
Package type deb
Category misc
Homepage https://debian-live.alioth.debian.org/live-wrapper/
License -
Maintainer Debian Live <debian-live@lists.debian.org>
Download size 20.55 KB
Installed size 87.00 KB
live-wrapper is a wrapper around vmdebootstrap to install a live Debian
system into an ISO image, which can be used by booting from optical media or a
USB device.
isolinux and grub2 bootloaders can be supported, depending on the distribution
and the architecture.

Alternatives

Package Version Architecture Repository
live-wrapper_0.8_all.deb 0.8 all Debian Main
live-wrapper - - -

Requires

Name Value
debian-archive-keyring -
isolinux -
python-apt -
python-cliapp -
python-distro-info -
python-pycurl -
python-requests -
python:any >= 2.7~
python:any << 2.8
squashfs-tools -
vmdebootstrap -
xorriso -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package live-wrapper_0.8_all.deb
Source Package live-wrapper

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install live-wrapper deb package:
    # sudo apt-get install live-wrapper

Files

Path
/usr/bin/lwr
/usr/lib/python2.7/dist-packages/live_wrapper-0.8.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/live_wrapper-0.8.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/live_wrapper-0.8.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/live_wrapper-0.8.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/live_wrapper-0.8.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/lwr/__init__.py
/usr/lib/python2.7/dist-packages/lwr/apt_udeb.py
/usr/lib/python2.7/dist-packages/lwr/bootloader.py
/usr/lib/python2.7/dist-packages/lwr/cdroot.py
/usr/lib/python2.7/dist-packages/lwr/disk.py
/usr/lib/python2.7/dist-packages/lwr/grub.py
/usr/lib/python2.7/dist-packages/lwr/isolinux.py
/usr/lib/python2.7/dist-packages/lwr/run.py
/usr/lib/python2.7/dist-packages/lwr/utils.py
/usr/lib/python2.7/dist-packages/lwr/vm.py
/usr/lib/python2.7/dist-packages/lwr/xorriso.py
/usr/share/doc/live-wrapper/changelog.gz
/usr/share/doc/live-wrapper/copyright
/usr/share/live-wrapper/customise.sh
/usr/share/live-wrapper/languagelist

Changelog

2019-02-13 - Jonathan Carter <jcc@debian.org>
live-wrapper (0.8) unstable; urgency=medium
[ Steve McIntyre ]
* Add "-padding 0" to the xorriso command line to remove padding in the
ISO image, as suggested by Thomas Schmitt.
* Add -compliance no_emul_toc to the xorriso command line, as suggested
by Thomas. Closes: #898995
[ Jonathan Carter ]
* Add "quiet splash" to cmdline
* Update standards version to 4.3.0
* Update to debhelper-compat (=12)
* Add self to uploaders
* Replace python-sphinx with python3-sphinx
2017-08-05 - Steve McIntyre <93sam@debian.org>
live-wrapper (0.7) unstable; urgency=medium
[ Steve McIntyre ]
* Add contrib and non-free components to apt config. Needed to allow for
building for images including firmware.
* Add command-line config for the apt-mirror (the mirror to be
configured inside the image), and change the default to use
deb.debian.org. Also switch the default build apt source to use
deb.debian.org
* Add command-line config for addition of firmware packages, and update
the docs about Customising Packages
* In the standard customise script, generate lists of the packages
installed in the image, and their sources. This needs a newer version
of vmdebootstrap, 1.7-1+nmu1 or higher, to add deb-src lines in
sources.list. Closes: #861070
* Change to how apt-ftparchive is called, so the installer will
work. This was part of the cause of #865015
* Tweak the size of the isolinux menu so long menus will display
better. This was the cause of #861421
* Add support for specifying the Volume ID of the output image.
Closes: #865384
* Set the mode of the ISO root dir to 0755 (rwxr-xr-x).
Closes: #865386
* Tweaks to the code for handling extra debs and udebs
+ Separate downloading and creating metadata files
+ Match the pool dir layout from the Debian archive more closely
+ Add support for "base" debs
+ Generate Packages and Release files separately for debs and udebs
* Add extra metadata to make d-i happy to install without network
This was part of the cause of #865015
* Fix up the root password in /etc/shadow so that the live installer
will set it properly. This is the cause of #866206
* Add myself to Uploaders
* Fix up usage of python-apt when there is more than one version of a
package available.
* When using base debs, add them to the sources list too.
* Add extra packages needed for braille and speech support.
Closes: #863177
* Ask pycurl to follow redirects when downloading. Closes: #862000
* Output the xorriso command line we're using into .disk/mkisofs, just
like on Debian installer images
[ Phil Wyett ]
* Various fixes for coding standards etc. Closes: #870845
* Update to standards version 4.0.0. Closes: #870846
* Add Suggests: live-wrapper-doc
2017-07-14 - Phil Wyett <philwyett@kathenas.org>
live-wrapper (0.6+nmu2) unstable; urgency=medium
* Non-maintainer upload.
* Remove incorrect instance of converting to UTF-8.
* Eliminate 'pyversions' warnings at build time.
* Add 'python-requests' build dependency. Fixes docs build.
* Add 'squashfs-tools' dependency. (Closes: #867282).
2017-05-16 - Florian Schlichting <fsfs@debian.org>
live-wrapper (0.6+nmu1) unstable; urgency=medium
* Non-maintainer upload.
* Add a dependency on python-pycurl, needed by lwr (closes: #861994)
* Add Build-Depends: python-apt, python-cliapp, vmdebootstrap needed to
completely build the lwr autodoc

See Also

Package Description
livemedia-utils_2018.11.26-1.1_i386.deb multimedia RTSP streaming tools
lives-data_2.10.0-1_all.deb Data files for LiVES
lives-plugins_2.10.0-1_i386.deb LiVES plugins pack
lives_2.10.0-1_i386.deb Video Editing system allowing users to edit and create video
livescript_1.6.0+dfsg-1_all.deb language which compiles to JavaScript
livestreamer_1.12.2+streamlink+1.0.0+dfsg-1_all.deb transitional package - streamlink
liwc_1.21-1+b1_i386.deb Tools for manipulating C source code
lix-data_0.9.24-1_i386.deb Puzzle game inspired by Lemmings
lix_0.9.24-1_i386.deb Puzzle game inspired by Lemmings
lizardfs-adm_3.12.0+dfsg-3+b10_i386.deb LizardFS - administration tools
lizardfs-cgi_3.12.0+dfsg-3_all.deb LizardFS - CGI monitor
lizardfs-cgiserv_3.12.0+dfsg-3+b10_i386.deb simple CGI-capable HTTP server to run LizardFS CGI monitor
lizardfs-chunkserver_3.12.0+dfsg-3+b10_i386.deb LizardFS - data server
lizardfs-client_3.12.0+dfsg-3+b10_i386.deb LizardFS - client tools and mount utility
lizardfs-common_3.12.0+dfsg-3_all.deb LizardFS - common files
Advertisement
Advertisement