littler_0.3.6-1_all.deb


Advertisement

Description

littler - GNU R scripting and command-line front-end -- transition package

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename littler_0.3.6-1_all.deb
Package name littler
Package version 0.3.6
Package release 1
Package architecture all
Package type deb
Category devel::lang:r field::statistics gnu-r implemented-in::c interface::commandline role::program suite::gnu
Homepage https://cran.r-project.org/package=littler
License -
Maintainer Dirk Eddelbuettel <edd@debian.org>
Download size 13.28 KB
Installed size 21.00 KB
The 'r' (aka 'littler') program provides a lightweight binary wrapper around
the GNU R language and environment for statistical computing and graphics.
While R can be used in batch mode, the r binary adds full support for
both 'shebang'-style scripting (i.e. using a  hashmark-exclamation-path
expression as the first line in scripts) as well as command-line use in
standard Unix pipelines. In other words, r provides the R language without
the environment.
This virtual package ensures that 'r-cran-littler' is installed. Once that
is done, this 'littler' package can be removed.

Alternatives

Package Version Architecture Repository
littler_0.3.6-1_all.deb 0.3.6 all Debian Main
littler - - -

Requires

Name Value
r-cran-littler -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package littler_0.3.6-1_all.deb
Source Package littler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install littler deb package:
    # sudo apt-get install littler

Files

Path
/usr/share/doc/littler/changelog.Debian.gz
/usr/share/doc/littler/changelog.gz
/usr/share/doc/littler/copyright
/usr/share/doc/littler/examples

Changelog

2019-01-26 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.6-1) unstable; urgency=medium
* New upstream release
* debian/control: Set Build-Depends: to current R version
* debian/control: Set Standards-Version: to current version 
2018-10-05 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.5-1) unstable; urgency=medium
* New upstream release
* debian/control: Set Standards-Version: to current version 
2018-08-24 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.4-1) unstable; urgency=medium
* New upstream release
* debian/control: Set Standards-Version: to current version 
* debian/control: Set Build-Depends: to current R version 
* debian/control: Revert back to ${R:Depends} and cdbs
2018-04-28 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.3-1.2) unstable; urgency=medium
* (Inofficial) Rebuild for R 3.5.0
* Manual override for ${R:Depends} while dh-r is looked at
* debian/control: Set Build-Depends: to current R version
* debian/control: Set Standards-Version: to current version 
* debian/control: Add Vcs-Browser: and Vcs-Git:
2017-12-17 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.3-1) unstable; urgency=medium
* New upstream release
* debian/control: Set Standards-Version: to current version 
* debian/control: Set Build-Depends: to current R version 
* debian/compat: Set level to 9
2017-02-15 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.2-1) unstable; urgency=medium
* New upstream release
* debian/control: Set Build-Depends: to current R version
2016-08-07 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.1-1) unstable; urgency=medium
* New upstream release based on second CRAN upload
* debian/control: Removed libicu-dev from Builds-Depends but increased
versioned Depends: to r-base-dev (>= 3.3.0-2) which now provides it
* debian/control: Set Build-Depends: to current R version
* debian/control: Set Standards-Version: to current version 
2016-05-16 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.0-3) unstable; urgency=low
* debian/control: Add libicu-dev to Build-Depends	(Closes: #824465)
* debian/rules: Strip /usr/bin/r when installing
2015-11-03 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.0-2) unstable; urgency=low
* debian/control: Add virtual package littler to ensure installation of
r-cran-littler
2015-10-28 - Dirk Eddelbuettel <edd@debian.org>
littler (0.3.0-1) unstable; urgency=low
* New upstream release based on intial CRAN upload
* debian/control: Binary package renamed to 'r-cran-littler' to match
other CRAN packages in Debian; added Conflicts:/Replaces:/Provides:
* debian/rules: Rewritten for use as a CRAN package

See Also

Package Description
littlewizard-data_1.2.2-4_all.deb littlewizard data files
littlewizard_1.2.2-4+b1_i386.deb development environment for children
live-boot-doc_20190614_all.deb Live System Boot Components (documentation)
live-boot-initramfs-tools_20190614_all.deb Live System Boot Components (initramfs-tools backend)
live-boot_20190614_all.deb Live System Boot Components
live-build_20190311_all.deb Live System Build Components
live-config-doc_5.20190519_all.deb Live System Configuration Components (documentation)
live-config-systemd_5.20190519_all.deb Live System Configuration Components (systemd backend)
live-config-sysvinit_5.20190519_all.deb Live System Configuration Components (sysvinit backend)
live-config_5.20190519_all.deb Live System Configuration Components
live-manual-epub_20151217.1_all.deb Live Systems Documentation (epub)
live-manual-html_20151217.1_all.deb Live Systems Documentation (html)
live-manual-odf_20151217.1_all.deb Live Systems Documentation (odf)
live-manual-pdf_20151217.1_all.deb Live Systems Documentation (pdf)
live-manual-txt_20151217.1_all.deb Live Systems Documentation (txt)
Advertisement
Advertisement