linpsk_1.3.5-1.1_i386.deb


Advertisement

Description

linpsk - program for operating PSK31/RTTY modes with X GUI

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename linpsk_1.3.5-1.1_i386.deb
Package name linpsk
Package version 1.3.5
Package release 1.1
Package architecture i386
Package type deb
Category hamradio hardware::hamradio interface::graphical interface::x11 role::program scope::utility uitoolkit::qt x11::application
Homepage http://linpsk.sourceforge.net/
License -
Maintainer Debian Hamradio Maintainers <debian-hams@lists.debian.org>
Download size 175.45 KB
Installed size 608.00 KB
linpsk is a program for operating on amateur radio digital modes.
linpsk currently supports BPSK, QPSK, and RTTY modes,
and it provides an X user interface.  linpsk's main features are:
- simultaneous decoding of up to four channels
- different digital modes may be mixed
- trigger text can be defined on each channel
- each channel can be logged to a file
- user-defined macros and two files for larger texts
- spectrum and waterfall displays, both scalable in the frequency domain.
At the Moment RTTY only supports 45 baud and 1.5 stopbits.

Alternatives

Package Version Architecture Repository
linpsk_1.3.5-1.1_amd64.deb 1.3.5 amd64 Debian Main
linpsk - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.4
libfftw3-double3 >= 3.3.5
libgcc1 >= 1:4.0
libgl1 -
libhamlib2 -
libqt5core5a >= 5.11.0~rc1
libqt5gui5 >= 5.2.0
libqt5network5 >= 5.0.2
libqt5widgets5 >= 5.2.0~alpha1
libstdc++6 >= 5.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package linpsk_1.3.5-1.1_i386.deb
Source Package linpsk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linpsk deb package:
    # sudo apt-get install linpsk

Files

Path
/usr/bin/linpsk
/usr/share/applications/linpsk.desktop
/usr/share/doc/linpsk/AUTHORS
/usr/share/doc/linpsk/README
/usr/share/doc/linpsk/README.Debian
/usr/share/doc/linpsk/asoundrc
/usr/share/doc/linpsk/changelog.Debian.gz
/usr/share/doc/linpsk/changelog.gz
/usr/share/doc/linpsk/copyright
/usr/share/man/man1/linpsk.1.gz
/usr/share/pixmaps/linpsk.png
/usr/share/pixmaps/linpsk.xpm

Changelog

2018-09-13 - Adrian Bunk <bunk@debian.org>
linpsk (1.3.5-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add patch from Reiner Herrmann for FTBFS with Qt 5.11.
(Closes: #906253)
2017-07-18 - Iain R. Learmonth <irl@debian.org>
linpsk (1.3.5-1) unstable; urgency=medium
* New upstream version 1.3.5
* debian/control
- Adds Build-Depends for libhamlib-dev and pkg-config
- Updated Standards Version to 4.0.0
* debian/patches:
- Refreshed typo.patch
- New we_have_hamlib.patch to forces build with hamlib support
2016-04-15 - Iain R. Learmonth <irl@debian.org>
linpsk (1.2.5~rc1-1) unstable; urgency=medium
* New upstream version.
- This version moves to Qt 5.
* debian/control:
- Removed inactive uploaders.
- Added build dependencies for Qt 5.
- Updated Vcs-* fields to secure URIs.
* debian/rules:
- Add QT_SELECT value for Qt 5.
* Refreshed patches.
* debian/dirs:
- Removed file, redundant.
* debian/linpsk.menu:
- Removed menu file.
2015-05-04 - Iain R. Learmonth <irl@fsfe.org>
linpsk (1.2-1) unstable; urgency=medium
* Team upload.
* Acknowledge NMU.
* New upstream version (Closes: #773755):
* debian/watch:
- Now checks for alternative archive extensions.
* debian/control:
- Reformatted with cme.
- Bump standards version to 3.9.6.
- Removed version from build dependency on libqt4-dev.
- Removed old incorrect Vcs-* fields and added new Vcs-* fields for the
pkg-hamradio git.
* debian/rules:
- Streamline using modern dh command.
* Refreshed patches:
- Removed demowave.patch - now included upstream.
- Removed qt4.patch - no longer relevant.
- Removed gcc-4.6.patch - no longer relevant.
- Refreshed typo.patch - typos have moved.
- Included ftbfs-clang.patch (Closes: #753272).
2011-10-01 - gregor herrmann <gregoa@debian.org>
linpsk (1.1-1.1) unstable; urgency=low
* NMU.
* Apply patch from Ubuntu / Matthias Klose:
- Fix FTBFS with g++-4.6. Closes: #624967, LP: #770983.
2010-08-21 - Jerry Stueve <k4int@arrl.net>
linpsk (1.1-1) unstable; urgency=low
* Move to alsa sound system (Closes: #575243)
* Move to qt4 packaging
* Add menu & desktop entries
* Update standards revision to 3.9.1
* Update to 3.0 (quilt) for patch management.
* Update to debhelper 7
* Correct spelling error in messages.
2009-11-15 - Joop Stakenborg <pa3aba@debian.org>
linpsk (0.8.1-4.1) unstable; urgency=low
* Retiring - remove myself from the uploaders list.
2007-12-26 - Joop Stakenborg <pa3aba@debian.org>
linpsk (0.8.1-4) unstable; urgency=low
* Make aptitude render the description nicely. Closes: #389051.
* Looking at #284488 I found that the source has changed to much
to be able to apply the supplied patch. Please re-submit against
recent source code or contact upstream. Closes: #284488.
* Menu transition.
* Update standards version.
* Lintian fixes.
* Change build dependencies to include libfftw3-dev, not fftw3-dev.
2006-03-19 - Hamish Moffatt <hamish@debian.org>
linpsk (0.8.1-3) unstable; urgency=low
* Apply patch to src/portaudio/pa_unix_oss.c to allow compilation
on GNU/kFreeBSD; thanks to Aurelien Jarno for the patch
(closes: #336914)
* Added debian/watch file to look for new upstream versions
2005-09-10 - Hamish Moffatt <hamish@debian.org>
linpsk (0.8.1-2) unstable; urgency=low
* Rebuild for g++ transition / link with libqt3, not libqt3c102
(closes: #327304)
* Update standards revision to 3.6.2

See Also

Package Description
linssid_3.6-3_i386.deb graphical wireless scanner
lintex_1.14-1+b1_i386.deb automatic cleanup of old TeX-related files
lintian-brush_0.13.1_all.deb automatically fix lintian problems
lintian_2.15.0_all.deb Debian package checker
linux-base_4.6_all.deb Linux image base package
linux-compiler-gcc-8-x86_4.19.67-2_i386.deb Compiler for Linux on x86 (meta-package)
linux-config-4.19_4.19.67-2_i386.deb Debian kernel configurations for Linux 4.19
linux-cpupower_4.19.67-2_i386.deb CPU power management tools for Linux
linux-doc-4.19_4.19.67-2_all.deb Linux kernel specific documentation for version 4.19
linux-doc_4.19+105+deb10u1_all.deb Linux kernel specific documentation (meta-package)
linux-headers-4.19.0-6-686-pae_4.19.67-2_i386.deb Header files for Linux 4.19.0-6-686-pae
linux-headers-4.19.0-6-686_4.19.67-2_i386.deb Header files for Linux 4.19.0-6-686
linux-headers-4.19.0-6-all-i386_4.19.67-2_i386.deb All header files for Linux 4.19 (meta-package)
linux-headers-4.19.0-6-all_4.19.67-2_i386.deb All header files for Linux 4.19 (meta-package)
linux-headers-4.19.0-6-common-rt_4.19.67-2_all.deb Common header files for Linux 4.19.0-6-rt
Advertisement
Advertisement