linphone-nogtk_3.12.0-3_i386.deb


Advertisement

Description

linphone-nogtk - SIP softphone - console-only client

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename linphone-nogtk_3.12.0-3_i386.deb
Package name linphone-nogtk
Package version 3.12.0
Package release 3
Package architecture i386
Package type deb
Category sound
Homepage http://www.linphone.org/
License -
Maintainer Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>
Download size 401.03 KB
Installed size 1.24 MB
Linphone is an audio and video internet phone using the SIP protocol. It
has a GTK+ and console interface, includes a large variety of audio and video
codecs, and provides IM features.
This package contains the console version of linphone.

Alternatives

Package Version Architecture Repository
linphone-nogtk_3.12.0-3_amd64.deb 3.12.0 amd64 Debian Main
linphone-nogtk - - -

Requires

Name Value
host -
libbctoolbox1 >= 0.6.0
libbctoolbox1 << 0.7.0
libbelcard1 -
libbellesip0 >= 1.6.3
libbzrtp0 >= 1.0.6
libc6 >= 2.7
libgcc1 >= 1:4.2
liblinphone9 = 3.12.0-3
libmediastreamer-base10 >= 1:2.16.1
libmediastreamer-voip10 >= 1:2.16.1
libortp13 >= 1:1.0.2
libsqlite3-0 >= 3.6.0
libstdc++6 >= 5.2
libxml2 >= 2.8.0
linphone-common = 3.12.0-3
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package linphone-nogtk_3.12.0-3_i386.deb
Source Package linphone

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linphone-nogtk deb package:
    # sudo apt-get install linphone-nogtk

Files

Path
/usr/bin/linphonec
/usr/bin/linphonecsh
/usr/share/doc/linphone-nogtk/BUGS
/usr/share/doc/linphone-nogtk/README.arm.gz
/usr/share/doc/linphone-nogtk/README.md
/usr/share/doc/linphone-nogtk/TODO
/usr/share/doc/linphone-nogtk/changelog.Debian.gz
/usr/share/doc/linphone-nogtk/changelog.gz
/usr/share/doc/linphone-nogtk/copyright
/usr/share/man/man1/linphonec.1.gz
/usr/share/man/man1/linphonecsh.1.gz

Changelog

2018-10-11 - Bernhard Schmidt <berni@debian.org>
linphone (3.12.0-3) unstable; urgency=medium
* Team upload.
* Release to unstable
* Remove obsolete build-dep libupnp-dev
* Drop liblinphone9.symbols in favour of shlibs
* Fix FTBFS with GCC-8
2018-02-17 - Bernhard Schmidt <berni@debian.org>
linphone (3.12.0-2) experimental; urgency=medium
* Drop unused libsrtp0-dev dependency (Closes: #787183)
* Drop C++ symbols from liblinphone9.symbols
* Adjust liblinphone-dev
- Add libbellesip-dev dependency
- Add liblinphone++9 dependency
- Install LinphoneCxx cmake files
2018-02-15 - Bernhard Schmidt <berni@debian.org>
linphone (3.12.0-1) experimental; urgency=medium
[ Felix Lechner ]
* Enabled LDAP; added Build-Depends: libldap2-dev, libsasl2-dev
* Enabled Lime
* Added upstream signing key
* Added pgpsigurlmangle option to watch
* Removed a URL from watch
* Replaced Build-Depends: libcunit1-dev with libcunit1-ncurses-dev
* Require higher version Build-Depend: libbellesip-dev (>= 1.4)
* Removed duplicates from Build-Depends:
* Updated Standards-Version: to 3.9.6
* Made Vcs-Svn: canonical
* Changed liblinphone7 package name to match SONAME
* Changed libmediastreamer-base4 package name to match SONAME
* Added lintian override for embedded srtp library (symbol conflict)
* Fixed spelling errors
* Removed /usr/share/gnome from installation dirs for linphone-common
[ Mark Purcell ]
* Update debian/watch
* Fix "linphone Broken Vcs-Svn: header in debian/control"
updated debian/control (Closes: #743652)
* Add Build-Depends: polarssl, gsm1
[ Tzafrir Cohen ]
* Fix name of signature file in watch file.
[ Johannes Schauer ]
* remove patch hunks for mediastreamer2 because mediastreamer2 is no longer
part of upstream tarball
* remove build dependency on libpolarssl-dev
* add build dependency on libbctoolbox-dev
* add build dependency on libortp-dev (>= 1:0.24.0)
* add build dependency on libmediastreamer-dev (>= 1:2.11.0)
* bump dependency on libbellesip-dev to >= 1.4.2
* remove libortp* and libmediastreamer* from source package as those
packages moved to their own source packages, respectively
* upstream renamed README to README.md -> adapt debian/*.docs
* add build dependency on libmbedtls-dev
* switch from autotools to cmake
* rename liblinphone7 to liblinphone9, following upstream soname bump
* debian/control: switch Vcs-* fields to https
* debian/control: add Felix Lechner to Uploaders
* debian/control: bump Standards-Version (no changes required)
* debian/rules: Use hardening=+all
* remove lintian-dbg package in favour of automatically generated dbgsym
package
* remove debian/linphone.menu as package already provides .desktop file
* add a patch adding the Keywords entry to the linphone.desktop file
* add a patch regenerating png images from their svg sources
* add a patch to update rootca.pem with a more recent version from mozilla
* run wrap-and-sort -abt
* change debian/copyright to use DEP5 (Machine-readable debian/copyright)
* add a patch to build linphone without attempting to download from mozilla
* add a debian/README.source
[ Dr. Tobias Quathamer ]
* New upstream version 3.12.0
- Fixes "New upstream version available" (Closes: #743474, #889161)
- Add new Build-Depends: libbelcard-dev, graphviz, libbelr-dev,
python-pystache, python-six
- Refresh patches
* Update d/watch to new github location
* Update d/copyright
* Wrap d/rules and add ENABLE_ROOTCA_DOWNLOAD=NO
* Add more files to d/liblinphone-dev.install
* Remove patch offline-mode, should not be needed anymore
* Disable spelling errors patch for now
* Use debhelper's dbgsym-migration
* Update Build-Depends: xxd moved from vim-common to xxd.
Thanks to Helmut Grohne <helmut@subdivi.de> (Closes: #887381)
* Switch Vcs-URLs to salsa.d.o (Closes: #855421)
[ Bernhard Schmidt ]
* Build legacy GTK UI
* Create empty coreapi/liblinphone_gitversion.h to fix FTBFS
* New binary package liblinphone++9

See Also

Package Description
linphone_3.12.0-3_i386.deb SIP softphone - graphical client
linpsk_1.3.5-1.1_i386.deb program for operating PSK31/RTTY modes with X GUI
linssid_3.6-3_i386.deb graphical wireless scanner
lintex_1.14-1+b1_i386.deb automatic cleanup of old TeX-related files
lintian-brush_0.13.1_all.deb automatically fix lintian problems
lintian_2.15.0_all.deb Debian package checker
linux-base_4.6_all.deb Linux image base package
linux-compiler-gcc-8-x86_4.19.37-5_i386.deb Compiler for Linux on x86 (meta-package)
linux-config-4.19_4.19.37-5_i386.deb Debian kernel configurations for Linux 4.19
linux-cpupower_4.19.37-5_i386.deb CPU power management tools for Linux
linux-doc-4.19_4.19.37-5_all.deb Linux kernel specific documentation for version 4.19
linux-doc_4.19+105_all.deb Linux kernel specific documentation (meta-package)
linux-headers-4.19.0-5-686-pae_4.19.37-5_i386.deb Header files for Linux 4.19.0-5-686-pae
linux-headers-4.19.0-5-686_4.19.37-5_i386.deb Header files for Linux 4.19.0-5-686
linux-headers-4.19.0-5-all-i386_4.19.37-5_i386.deb All header files for Linux 4.19 (meta-package)
Advertisement
Advertisement