lightspeed_1.2a.debian.1-2_i386.deb


Advertisement

Description

lightspeed - Shows how objects moving at relativistic speeds look like

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename lightspeed_1.2a.debian.1-2_i386.deb
Package name lightspeed
Package version 1.2a.debian.1
Package release 2
Package architecture i386
Package type deb
Category field::astronomy game::toys interface::3d interface::graphical interface::x11 misc role::program uitoolkit::gtk use::entertaining use::learning works-with::3dmodel x11::application
Homepage http://lightspeed.sourceforge.net/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 96.51 KB
Installed size 269.00 KB
Light Speed! is an OpenGL-based program which illustrates the effects of
special relativity on the appearance of moving objects. When an object
accelerates past a few million meters per second, these effects begin to
grow noticeable, becoming more and more pronounced as the speed of light
is approached. These relativistic effects are viewpoint-dependent, and
include shifts in length, object hue, brightness and shape.
The moving object is, by default, a geometric lattice. 3D Studio and
LightWave 3D objects may be imported as well. Best of all, the simulator
is completely interactive, rendering the exotic distortions in real-time!

Alternatives

Package Version Architecture Repository
lightspeed_1.2a.debian.1-2_amd64.deb 1.2a.debian.1 amd64 Debian Main
lightspeed - - -

Requires

Name Value
libc6 >= 2.11
libfontconfig1 >= 2.12.6
libftgl2 >= 2.4.0
libgcc1 >= 1:3.0
libgl1 -
libglib2.0-0 >= 2.16.0
libgtk2.0-0 >= 2.8.0
libgtkglext1 -
libpng16-16 >= 1.6.2-1
libstdc++6 >= 5
libtiff5 >= 4.0.3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lightspeed_1.2a.debian.1-2_i386.deb
Source Package lightspeed

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lightspeed deb package:
    # sudo apt-get install lightspeed

Files

Path
/usr/bin/lightspeed
/usr/share/applications/lightspeed.desktop
/usr/share/doc/lightspeed/MATH.gz
/usr/share/doc/lightspeed/README
/usr/share/doc/lightspeed/README.Debian
/usr/share/doc/lightspeed/TODO
/usr/share/doc/lightspeed/changelog.Debian.gz
/usr/share/doc/lightspeed/changelog.gz
/usr/share/doc/lightspeed/copyright
/usr/share/locale/es/LC_MESSAGES/lightspeed.mo
/usr/share/man/man1/lightspeed.1.gz

Changelog

2019-02-26 - Boyuan Yang <byang@debian.org>
lightspeed (1.2a.debian.1-2) unstable; urgency=medium
* QA upload.
[ Ondřej Nový ]
* d/watch: Use https protocol
[ Boyuan Yang ]
* Rebuild for Debian Buster.
* debian/control:
+ Bump debhelper compat to v12.
+ Bump Standards-Version to 4.3.0.
+ Use Rules-Requires-Root: no.
2018-08-26 - Boyuan Yang <073plan@gmail.com>
lightspeed (1.2a.debian.1-1) unstable; urgency=medium
* QA upload.
* Convert package format to "3.0 (quilt)" and make all previous
debian-specific patches into a "1.2a.debian.1" pseudo-upstream
release.
* debian: Apply "wrap-and-sort -abst".
* debian/control:
+ Bump Standards-Version to 4.2.1.
+ Bump debhelper compat to v11.
+ Remove build-dependency to autotool-dev, not necessary under
new debhelper.
+ Update suggestion to font packages to use real packages instead
of transitional dummy packages.
+ Use Salsa platform for Vcs fields.
* debian/menu: Removed in favour of new .desktop file.
* debian/rules: Enable full hardening.
* debian/watch: Update to v4.
2014-03-01 - Boris Pek <tehnick@debian.org>
lightspeed (1.2a-10) unstable; urgency=medium
* QA upload.
* Bump Standards-Version to 3.9.5 (was 3.9.3): no changes required.
* Fix FTBFS using Clang. (Closes: #739568) [Thanks to Arthur Marble]
* Fix lintian note vcs-field-not-canonical.
* Update get-orig-source section in debian/rules.
2012-11-20 - Boris Pek <tehnick-8@mail.ru>
lightspeed (1.2a-9) unstable; urgency=low
* QA upload.
* Bumped Standards-Version to 3.9.3 (was 3.7.2.0).
* Bumped debhelper version to 9 (was 4.0.0); updated debian/compat.
* Added file debian/source/format: format 1.0 is still used in this package.
* Added files debian/docs and debian/manpages to simplify debian/rules.
* Deleted files config/config.guess and config/config.sub.
Files from the package autotools-dev are used instead.
* Rewritten debian/rules:
- now dh is used instead of direct dh_* commands
- added --as-needed option to LDFLAGS
- added section get-orig-source (uscan is used)
- used symlinks for config/config.guess and config/config.sub
- fixed lintian warnings:
+ hardening-no-relro
+ hardening-no-fortify-functions
+ debian-rules-ignores-make-clean-error
+ debian-rules-missing-recommended-target build-arch
+ debian-rules-missing-recommended-target build-indep
+ dh-clean-k-is-deprecated
* Updated debian/control:
- added Homepage field
- added Vcs-* fields (Git repo in collab-maint is available now)
- changed build dependency from libpng12-dev to libpng-dev (Closes: #662418)
- changed build dependency from ftgl-dev to libftgl-dev (Closes: #485799)
- changed build dependency from libtiff4-dev to libtiff-dev
(preparation for switching to libtiff5 in Debian Jessie)
- added build dependency from autotools-dev
- added ${misc:Depends} to list of dependencies
- lightspeed now suggests recommended font ttf-dejavu instead of font
ttf-bitstream-vera which is going to be removed from the repository
(Closes: #461272)
* Updated debian/copyright: fixed lintian warning
debian-copyright-file-uses-obsolete-national-encoding.
* Updated debian/watch: fixed lintian warning
debian-watch-file-should-use-sf-redirector. (Closes: #449901)
* Patched file src/snapshot.c. [Thanks to Nobuhiro Iwamatsu] (Closes: #649787)
But build with libpng version 1.5.10 now impossible because
`pkg-config --cflags gtk+-2.0` returns error:
"Package 'libpng12', required by 'GdkPixbuf', not found"
2011-11-05 - Ola Lundqvist <opal@debian.org>
lightspeed (1.2a-8) unstable; urgency=low
* Package maintainer set to Debian QA Group <packages@qa.debian.org>.
2006-12-12 - Ola Lundqvist <opal@debian.org>
lightspeed (1.2a-7) unstable; urgency=high
* Workaround for FcFini problem in fontconfig package. Commenting out
that line and now the program can start. Closes: #402402. It should
be changed back when the cause is found.

See Also

Package Description
lightsquid_1.8-6_all.deb Lite and fast log analizer for squid proxy
lighttpd-doc_1.4.53-4_all.deb documentation for lighttpd
lighttpd-mod-authn-gssapi_1.4.53-4_i386.deb GSSAPI authentication for lighttpd
lighttpd-mod-authn-ldap_1.4.53-4_i386.deb Transitional dummy package for LDAP authentication for lighttpd
lighttpd-mod-authn-mysql_1.4.53-4_i386.deb Transitional dummy package for MySQL authentication for lighttpd
lighttpd-mod-authn-pam_1.4.53-4_i386.deb PAM authentication for lighttpd
lighttpd-mod-authn-sasl_1.4.53-4_i386.deb SASL authentication for lighttpd
lighttpd-mod-cml_1.4.53-4_i386.deb cache meta language module for lighttpd
lighttpd-mod-geoip_1.4.53-4_i386.deb GeoIP restrictions for lighttpd
lighttpd-mod-magnet_1.4.53-4_i386.deb control the request handling module for lighttpd
lighttpd-mod-mysql-vhost_1.4.53-4_i386.deb Transitional dummy package for lighttpd MySQL-based vhost config
lighttpd-mod-trigger-b4-dl_1.4.53-4_i386.deb anti-deep-linking module for lighttpd
lighttpd-mod-vhostdb-dbi_1.4.53-4_i386.deb DBI-based virtual host configuration for lighttpd
lighttpd-mod-vhostdb-pgsql_1.4.53-4_i386.deb PostgreSQL-based virtual host configuration for lighttpd
lighttpd-mod-webdav_1.4.53-4_i386.deb WebDAV module for lighttpd
Advertisement
Advertisement