libyaml-perl_1.27-1_all.deb


Advertisement

Description

libyaml-perl - YAML Ain't Markup Language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libyaml-perl_1.27-1_all.deb
Package name libyaml-perl
Package version 1.27
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/YAML
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 65.27 KB
Installed size 178.00 KB
YAML is a generic data serialization language that is optimized for human
readability. It can be used to express the data structures of most modern
programming languages (including Perl, of course). YAML supports Unicode
and there are implementations of the parser in many different languages,
making it a rather portable serialization format.
Please note that the YAML module is currently a deprecated implementation
in Pure Perl, which is probably slow on your system. The authors intend
to change it to just be a front-end interface module for various YAML
implementations. For now, YAML::Any is a module provided for this purpose,
which simply selects the best YAML implementation available.

Alternatives

Package Version Architecture Repository
libyaml-perl_1.27-1_all.deb 1.27 all Debian Main
libyaml-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libyaml-perl_1.27-1_all.deb
Source Package libyaml-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libyaml-perl deb package:
    # sudo apt-get install libyaml-perl

Files

Path
/usr/share/doc/libyaml-perl/CONTRIBUTING
/usr/share/doc/libyaml-perl/changelog.Debian.gz
/usr/share/doc/libyaml-perl/changelog.gz
/usr/share/doc/libyaml-perl/copyright
/usr/share/man/man3/YAML.3pm.gz
/usr/share/man/man3/YAML::Any.3pm.gz
/usr/share/man/man3/YAML::Dumper.3pm.gz
/usr/share/man/man3/YAML::Dumper::Base.3pm.gz
/usr/share/man/man3/YAML::Error.3pm.gz
/usr/share/man/man3/YAML::Loader.3pm.gz
/usr/share/man/man3/YAML::Loader::Base.3pm.gz
/usr/share/man/man3/YAML::Marshall.3pm.gz
/usr/share/man/man3/YAML::Node.3pm.gz
/usr/share/man/man3/YAML::Tag.3pm.gz
/usr/share/man/man3/YAML::Types.3pm.gz
/usr/share/perl5/YAML.pm
/usr/share/perl5/YAML.pod
/usr/share/perl5/YAML/Any.pm
/usr/share/perl5/YAML/Any.pod
/usr/share/perl5/YAML/Dumper.pm
/usr/share/perl5/YAML/Dumper.pod
/usr/share/perl5/YAML/Error.pm
/usr/share/perl5/YAML/Error.pod
/usr/share/perl5/YAML/Loader.pm
/usr/share/perl5/YAML/Loader.pod
/usr/share/perl5/YAML/Marshall.pm
/usr/share/perl5/YAML/Marshall.pod
/usr/share/perl5/YAML/Mo.pm
/usr/share/perl5/YAML/Node.pm
/usr/share/perl5/YAML/Node.pod
/usr/share/perl5/YAML/Tag.pm
/usr/share/perl5/YAML/Tag.pod
/usr/share/perl5/YAML/Types.pm
/usr/share/perl5/YAML/Types.pod
/usr/share/perl5/YAML/Dumper/Base.pm
/usr/share/perl5/YAML/Dumper/Base.pod
/usr/share/perl5/YAML/Loader/Base.pm
/usr/share/perl5/YAML/Loader/Base.pod

Changelog

2018-11-09 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.27-1) unstable; urgency=medium
* Import upstream version 1.27.
* Declare compliance with Debian Policy 4.2.1.
* Remove trailing whitespace from debian/*.
2018-05-21 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.26-1) unstable; urgency=medium
* Import upstream version 1.26.
* Remove 0001-Fix-loading-of-quoted-string-with-colon-as-sequence-.patch
which was taken from upstream Git.
2018-05-17 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.25-2) unstable; urgency=medium
* Add patch from upstream Git repo to fix "loading of quoted string with
colon as sequence element". (Closes: #898578)
2018-05-12 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.25-1) unstable; urgency=medium
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 1.25.
* Refresh ysh-location.patch (offset).
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 4.1.4.
* Bump debhelper compatibility level to 10.
* Add libtest-deep-perl to Build-Depends-Indep.
2017-11-01 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.24-1) unstable; urgency=medium
* Import upstream version 1.24.
* Refresh ysh-location.patch (offset).
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 4.1.1.
2016-12-25 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.21-1) unstable; urgency=medium
* Import upstream version 1.21.
2016-12-03 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.20-1) unstable; urgency=medium
* Import upstream version 1.20.
* Refresh ysh-location.patch (offset).
* Update years of packaging copyright.
2016-11-20 - Nick Morrott <knowledgejunkie@gmail.com>
libyaml-perl (1.19-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Remove Iulian Udrea from Uploaders. Thanks for your work!
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Rene Mayorga from Uploaders. Thanks for your work!
[ Nick Morrott ]
* Import upstream version 1.19
* Refresh d/u/metadata
* Refresh ysh-location.patch
2016-07-12 - Nuno Carvalho <smash@cpan.org>
libyaml-perl (1.18-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Nuno Carvalho ]
* debian/copyright: update upstream copyright years.
* debian/metadata: update upstream contact.
* debian/control: update Standards-Version to 3.9.8.
2015-11-01 - gregor herrmann <gregoa@debian.org>
libyaml-perl (1.15-1) unstable; urgency=medium
* Import upstream version 1.15.
* Refresh ysh-location.patch (offset).
* Update years of upstream and packaging copyright.
* Bump debhelper compatibility level to 9.

See Also

Package Description
libyaml-shell-perl_0.71-2_all.deb YAML test shell
libyaml-snake-java-doc_1.23-1_all.deb Documentation for SnakeYAML
libyaml-snake-java_1.23-1_all.deb YAML parser and emitter for the Java programming language
libyaml-syck-perl_1.31-1+b1_i386.deb Perl module providing a fast, lightweight YAML loader and dumper
libyaml-tiny-perl_1.73-1_all.deb Perl module for reading and writing YAML files
libyanfs-java_0.0+cvs20070825-4_all.deb Yet Another NFS - a Java NFS library
libyang-cpp-dev_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - C++ development files
libyang-cpp0.16_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - C++ runtime
libyang-dev_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - development files
libyang0.16_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - runtime
libyangrpc-dev_2.11-1_i386.deb NETCONF/YANG simple client applications development files
libyangrpc2_2.11-1_i386.deb NETCONF/YANG library for simple client applications
libyara-dev_3.9.0-1_i386.deb YARA development libraries and headers
libyara3_3.9.0-1_i386.deb YARA shared library
libyaz-dev_5.27.1-2_i386.deb YAZ Z39.50 toolkit (development files)
Advertisement
Advertisement