libyaml-0-2_0.2.1-1_i386.deb


Advertisement

Description

libyaml-0-2 - Fast YAML 1.1 parser and emitter library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libyaml-0-2_0.2.1-1_i386.deb
Package name libyaml-0-2
Package version 0.2.1
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://github.com/yaml/libyaml
License -
Maintainer Anders Kaseorg <andersk@mit.edu>
Download size 48.50 KB
Installed size 139.00 KB
LibYAML is a C library for parsing and emitting data in YAML 1.1, a
human-readable data serialization format.

Alternatives

Package Version Architecture Repository
libyaml-0-2_0.2.1-1_amd64.deb 0.2.1 amd64 Debian Main
libyaml-0-2 - - -

Requires

Name Value
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libyaml-0-2_0.2.1-1_i386.deb
Source Package libyaml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libyaml-0-2 deb package:
    # sudo apt-get install libyaml-0-2

Files

Path
/usr/lib/i386-linux-gnu/libyaml-0.so.2
/usr/lib/i386-linux-gnu/libyaml-0.so.2.0.5
/usr/share/doc/libyaml-0-2/changelog.Debian.gz
/usr/share/doc/libyaml-0-2/copyright

Changelog

2018-06-26 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.2.1-1) unstable; urgency=medium
* New upstream version 0.2.1.
+ Moved canonical repo to GitHub.  (Closes: #865709)
* Bump Standards-Version to 4.1.4 and debian/compat to 11.
+ Moved documentation in libyaml-doc from /usr/share/doc/libyaml-doc
to /usr/share/doc/libyaml-dev.
2016-09-30 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.7-2) unstable; urgency=medium
* Clean doxygen-generated documentation with dh_doxygen.
* Mark libyaml-doc Multi-Arch: foreign.
* Add libyaml-0-2.symbols file.
2016-09-03 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.7-1) unstable; urgency=medium
* New upstream version 0.1.7.
+ Fix segfault in yaml_string_write_handler.
+ Fix invalid simple key assertion.
* Drop upstreamed patches.
* Migrate packaging from CDBS to dh.
* Drop libyaml-0-2-dbg in favor of automatically generated
libyaml-0-2-dbgsym package.
2014-11-28 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.6-3) unstable; urgency=high
* debian/patches/CVE-2014-9130.patch: Fix CVE-2014-9130 assertion
failure caused by wrapped strings.  (Closes: #771366)
* Bump Standards-Version to 3.9.6 (no changes needed).
2014-08-19 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.6-2) unstable; urgency=medium
* Move doxygen from Build-Depends to Build-Depends-Indep.
2014-08-19 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.6-1) unstable; urgency=medium
* New upstream version 0.1.6.
+ Fix CVE-2013-6393: heap-based buffer overflow when parsing YAML
tags.
+ Fix CVE-2014-2525: heap-based buffer overflow in
yaml_parser_scan_uri_escapes.
* Drop upstreamed patches.
* Run tests at build time.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Use dh-autoreconf.  (Closes: #745078)
* Use dh-buildinfo.
* Add libyaml-doc package for Doxygen-generated API documentation and
examples.  (Closes: #696821)
* Acknowledge NMUs.
2014-03-27 - Salvatore Bonaccorso <carnil@debian.org>
libyaml (0.1.4-3.2) unstable; urgency=high
* Non-maintainer upload by the Security Team.
* Add CVE-2014-2525.patch patch.
CVE-2014-2525: Fixes heap overflow in yaml_parser_scan_uri_escapes.
The heap overflow is caused by not properly expanding a string before
writing to it in function yaml_parser_scan_uri_escapes in scanner.c.
(Closes: #742732)
2014-02-13 - Salvatore Bonaccorso <carnil@debian.org>
libyaml (0.1.4-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop libyaml-indent-column-overflow-v2.patch patch.
This patch causes additional regressions on simple YAML files.
* Add libyaml-guard-against-overflows-in-indent-and-flow_level.patch patch.
Add upstream's patch to guard against overflows in indent and
flow_level. (Closes: #738587)
2014-01-29 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.4-3) unstable; urgency=high
* Fix CVE-2013-6393: heap-based buffer overflow when parsing YAML tags.
(Closes: #737076)
2011-12-30 - Anders Kaseorg <andersk@mit.edu>
libyaml (0.1.4-2) unstable; urgency=low
* Remove extra libyaml-0.so symlink from libyaml-dev.
* Bump Debhelper compat level to 9.
* Support multiarch.  (Closes: #653748) (LP: #905630)
* Use 3.0 (quilt) source format.

See Also

Package Description
libyaml-appconfig-perl_0.19-1_all.deb module to manage configuration files with YAML
libyaml-cpp-dev_0.6.2-4_i386.deb YAML parser and emitter for C++ - development files
libyaml-cpp0.6_0.6.2-4_i386.deb YAML parser and emitter for C++
libyaml-dev_0.2.1-1_i386.deb Fast YAML 1.1 parser and emitter library (development)
libyaml-doc_0.2.1-1_all.deb Fast YAML 1.1 parser and emitter library (documentation)
libyaml-libyaml-perl_0.76+repack-1_i386.deb Perl interface to libyaml, a YAML implementation
libyaml-perl_1.27-1_all.deb YAML Ain't Markup Language
libyaml-shell-perl_0.71-2_all.deb YAML test shell
libyaml-snake-java-doc_1.23-1_all.deb Documentation for SnakeYAML
libyaml-snake-java_1.23-1_all.deb YAML parser and emitter for the Java programming language
libyaml-syck-perl_1.31-1+b1_i386.deb Perl module providing a fast, lightweight YAML loader and dumper
libyaml-tiny-perl_1.73-1_all.deb Perl module for reading and writing YAML files
libyanfs-java_0.0+cvs20070825-4_all.deb Yet Another NFS - a Java NFS library
libyang-cpp-dev_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - C++ development files
libyang-cpp0.16_0.16.105-1_i386.deb parser toolkit for IETF YANG data modeling - C++ runtime
Advertisement
Advertisement