libxerces-c3.2_3.2.2+debian-1+b1_i386.deb


Advertisement

Description

libxerces-c3.2 - validating XML parser library for C++

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libxerces-c3.2_3.2.2+debian-1+b1_i386.deb
Package name libxerces-c3.2
Package version 3.2.2+debian
Package release 1+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://xerces.apache.org/xerces-c/
License -
Maintainer William Blough <bblough@debian.org>
Download size 932.71 KB
Installed size 3.59 MB
Xerces-C++ is a validating XML parser written in a portable subset of
C++.  Xerces-C++ makes it easy to give your application the ability
to read and write XML data. A shared library is provided for parsing,
generating, manipulating, and validating XML documents. Xerces-C++ is
faithful to the XML 1.0 recommendation and associated standards (DOM
1.0, DOM 2.0, SAX 1.0, SAX 2.0, Namespaces, XML Schema Part 1 and
Part 2).  It also provides experimental implementations of XML 1.1
and DOM Level 3.0.  The parser provides high performance, modularity,
and scalability.

Alternatives

Package Version Architecture Repository
libxerces-c3.2_3.2.2+debian-1+b1_amd64.deb 3.2.2+debian amd64 Debian Main
libxerces-c3.2 - - -

Requires

Name Value
libc6 >= 2.27
libcurl3-gnutls >= 7.16.2
libgcc1 >= 1:3.0
libicu63 >= 63.1-1~
libstdc++6 >= 5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libxerces-c3.2_3.2.2+debian-1+b1_i386.deb
Source Package xerces-c

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxerces-c3.2 deb package:
    # sudo apt-get install libxerces-c3.2

Files

Path
/usr/lib/i386-linux-gnu/libxerces-c-3.2.so
/usr/share/doc/libxerces-c3.2/NEWS.Debian.gz
/usr/share/doc/libxerces-c3.2/NOTICE
/usr/share/doc/libxerces-c3.2/changelog.Debian.gz
/usr/share/doc/libxerces-c3.2/changelog.Debian.i386.gz
/usr/share/doc/libxerces-c3.2/copyright
/usr/share/lintian/overrides/libxerces-c3.2

Changelog

2018-09-19 - William Blough <bblough@debian.org>
xerces-c (3.2.2+debian-1) unstable; urgency=medium
* New upstream version 3.2.2+debian Closes: 909202
* Add gbp.conf
* Update VCS URLs
* Update maintainer email
* Remove duplicate VCS URL
* Update standards to 4.2.1 (no changes needed)
2018-04-26 - William Blough <devel@blough.us>
xerces-c (3.2.1+debian-2) unstable; urgency=medium
* Fixes regression related to SSE2 detection/support, which
causes a baseline violation on i386.  Closes: 895068
* Update to policy 4.1.4 (no changes)
* Update to debhelper compat 11
* Simplify installation of NOTICE files
2018-03-28 - William Blough <devel@blough.us>
xerces-c (3.2.1+debian-1) unstable; urgency=medium
* New upstream release.  Closes: 891841
Fixes CVE-2017-12627  Closes: 894050
* Update to policy 4.1.3 (no changes)
* Remove patch that was applied upstream
* Lintian fixes:
- remove trailing whitespace in changelog
- install NOTICE file
- change watch file to use https
2017-11-10 - William Blough <devel@blough.us>
xerces-c (3.2.0+debian-2) unstable; urgency=medium
* Upload to unstable
2017-10-12 - William Blough <devel@blough.us>
xerces-c (3.2.0+debian-1) experimental; urgency=medium
* New upstream version
* Update to policy 4.1.1
- Change d/copyright Format URL to use https
* Remove patches that have been applied upstream
* Set dh compat to 10
* Patch: Fix test failures for parallel builds (forwarded)
2016-12-11 - William Blough <devel@blough.us>
xerces-c (3.1.4+debian-2) unstable; urgency=medium
* Fix AC_LANG_SOURCE warnings.
* Override dh_auto_clean to also clean generated doc directory.
Closes: 847799
* Fix segfault in PSVIWriter. Closes: 715592
* Use -O1 on s390x to work around Bug: 833754
* Add hardening=+all build option
* Remove lintian override that was no longer needed
2016-11-07 - William Blough <devel@blough.us>
xerces-c (3.1.4+debian-1) unstable; urgency=medium
* New upstream release
* Removed patches that are no longer needed (applied upstream)
* Compile with curl support to allow accessing https urls.  Closes: #821380
* Added patch to fix some compiler warnings (forwarded upstream)
2016-07-01 - Salvatore Bonaccorso <carnil@debian.org>
xerces-c (3.1.3+debian-2.1) unstable; urgency=medium
* Non-maintainer upload.
* CVE-2016-4463: Apache Xerces-C XML Parser Crashes on Malformed DTD
(Closes: #828990)
* Enable the ability to disable DTD processing through the use of an env
variable
* Add NEWS.Debian entry to document the XERCES_DISABLE_DTD variable
2016-05-10 - William Blough <devel@blough.us>
xerces-c (3.1.3+debian-2) unstable; urgency=medium
* Fix CVE-2016-2099: Exception handling mistake in DTDScanner.
Closes: #823863
* Update standards version to 3.9.8 (no changes needed)
2016-02-27 - William Blough <devel@blough.us>
xerces-c (3.1.3+debian-1) unstable; urgency=medium
* New upstream version.
Fixes CVE-2016-0729: Apache Xerces-C XML Parser Crashes on Malformed
Input.  Closes: #815907
* Add build dependency on libatk-wrapper-java. Closes: #816021
* Updated standards version to 3.9.7 (no updates needed)
* Lintian fixes
d/copyright
fix typo in filename
fix duplicate license short name
add .svn to excluded files

See Also

Package Description
libxerces2-java-doc_2.12.0-1_all.deb Validating XML parser for Java -- Documentation and examples
libxerces2-java_2.12.0-1_all.deb Validating XML parser for Java with DOM level 3 support
libxext-dev_1.3.3-1+b2_i386.deb X11 miscellaneous extensions library (development headers)
libxext-doc_1.3.3-1_all.deb X11 miscellaneous extensions library (documentation)
libxext6_1.3.3-1+b2_i386.deb X11 miscellaneous extension library
libxfce4panel-2.0-4_4.12.2-1_i386.deb Xfce4 panel libraries (GTK3 variant)
libxfce4panel-2.0-dev_4.12.2-1_i386.deb Xfce4 panel libraries (GTK3 variant)
libxfce4ui-1-0_4.12.1-3_i386.deb widget library for Xfce - Gtk+2 variant
libxfce4ui-1-dev_4.12.1-3_i386.deb Development files for libxfce4ui - Gtk+2 variant
libxfce4ui-2-0_4.12.1-3_i386.deb widget library for Xfce - Gtk+3 variant
libxfce4ui-2-dev_4.12.1-3_i386.deb Development files for libxfce4ui - Gtk+3 variant
libxfce4ui-common_4.12.1-3_all.deb common files for libxfce4ui
libxfce4ui-utils_4.12.1-3_i386.deb Utility files for libxfce4ui
libxfce4util-bin_4.12.1-3_i386.deb tools for libxfce4util
libxfce4util-common_4.12.1-3_all.deb common files for libxfce4util
Advertisement
Advertisement