libxaw7_1.0.13-1+b2_i386.deb


Advertisement

Description

libxaw7 - X11 Athena Widget library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libxaw7_1.0.13-1+b2_i386.deb
Package name libxaw7
Package version 1.0.13
Package release 1+b2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage -
License -
Maintainer Debian X Strike Force <debian-x@lists.debian.org>
Download size 204.48 KB
Installed size 504.00 KB
libXaw7 provides the second version of Xaw, the Athena Widgets toolkit,
which is largely used by legacy X applications.  This version is the
most common version, as version 6 is considered deprecated, and version
8, which adds Xprint support, is unsupported and not widely used.
In general, use of a more modern toolkit such as GTK+ is recommended.
More information about X.Org can be found at:
<URL:http://www.X.org>
This module can be found at
git://anongit.freedesktop.org/git/xorg/lib/libXaw

Alternatives

Package Version Architecture Repository
libxaw7_1.0.13-1+b2_amd64.deb 1.0.13 amd64 Debian Main
libxaw7 - - -

Requires

Name Value
libc6 >= 2.15
libx11-6 -
libxext6 -
libxmu6 -
libxpm4 -
libxt6 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libxaw7_1.0.13-1+b2_i386.deb
Source Package libxaw

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxaw7 deb package:
    # sudo apt-get install libxaw7

Files

Path
/usr/lib/i386-linux-gnu/libXaw.so.7
/usr/lib/i386-linux-gnu/libXaw7.so.7
/usr/lib/i386-linux-gnu/libXaw7.so.7.0.0
/usr/share/doc/libxaw7/changelog.Debian.gz
/usr/share/doc/libxaw7/changelog.Debian.i386.gz
/usr/share/doc/libxaw7/changelog.gz
/usr/share/doc/libxaw7/copyright

Changelog

2015-08-01 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.13-1) unstable; urgency=medium
* Let uscan verify tarball signatures.
* New upstream release.
* Drop override_dh_auto_install, I don't think it's necessary with just one
Xaw variant.
2014-07-12 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.12-2) unstable; urgency=medium
* Fix typo in package description (closes: #736829).  Thanks, darkestkhan!
* Rewrite debian/rules to use dh.  Bump debhelper compat and build-dep to 9.
Use dh-autoreconf.
2014-01-20 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.12-1) unstable; urgency=medium
* New upstream release.
* Fix build with -Werror=format-security, and enable it.
* Remove Drew Parsons and Cyril Brulebois from Uploaders.
2013-06-16 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.11-1) unstable; urgency=low
* New upstream release.
* Bump debhelper compat level to 7.
* Use dpkg-buildflags, disable -Werror=format-security since that causes
FTBFS.
* Disable silent rules.
* Remove ed from Build-Depends, no longer needed.
* Get rid of debian/xsfbs, use /usr/share/quilt/quilt.make for patch/unpatch
rules.
2012-04-11 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.10-2) unstable; urgency=low
* *sigh* add missing Replaces/Breaks on libxaw7-dev for the new -doc
package.  Some day I'll remember to add those the first time.
2012-04-11 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.10-1) unstable; urgency=low
* New upstream release.
- Build fix for -Werror=pointer-to-int-cast (closes: #664934)
* Split documentation to a new libxaw-doc package.
* Fix up 01_Xaw_StripChart_fix.diff for new version.
* Don't require (fake)root for debian/rules clean.
* libxaw7-dev is now m-a: same, libxaw-doc m-a: foreign.
2011-10-21 - Steve Langasek <vorlon@debian.org>
libxaw (2:1.0.9-3) unstable; urgency=low
* Build for multiarch.
2011-02-06 - Julien Cristau <jcristau@debian.org>
libxaw (2:1.0.9-2) unstable; urgency=low
* Bump Standards-Version to 3.9.1.
* Drop Pre-Depends on x11-common, only needed for upgrades from sarge.
* Drop Conflicts/Replaces on libxaw6-dev, libxaw8-dev, libxaw-headers, last
shipped in etch.
* Remove David Nusinow and Brice Goglin from Uploaders.  Thanks for your
work!
* Wrap debian/control Depends fields.
2011-01-12 - Cyril Brulebois <kibi@debian.org>
libxaw (2:1.0.9-1) experimental; urgency=low
* New upstream release.
* Noticeable change: xaw6.pc now only has xmu in Requires.private, no
longer in Requires. Since it might trigger some FTBFS, target
experimental. Better be safe than sorry.
2010-11-06 - Cyril Brulebois <kibi@debian.org>
libxaw (2:1.0.8-2) unstable; urgency=low
[ Julien Cristau ]
* Revert addition of libXaw.so to libxaw7.install, done by mistake in the
previous revision.  That file belongs in the -dev package and is already
in libxaw7-dev.links (closes: #602620).  Delete the link in debian/rules
install instead, to avoid dh_install complaints.
[ Cyril Brulebois ]
* Lose the git push race, thank Alex Goebel for the report, and upload.

See Also

Package Description
libxbae-dev_4.60.4-7+b11_i386.deb Xbae Matrix Widget development package
libxbae4m_4.60.4-7+b11_i386.deb Xbae Matrix Widget libraries
libxbase64-1_3.1.2-13_i386.deb xbase compatible C++ class library (shared libraries)
libxbase64-bin_3.1.2-13_i386.deb xbase compatible C++ class library (utilities)
libxbase64-dev_3.1.2-13_i386.deb xbase compatible C++ class library (development files)
libxbase64-doc_3.1.2-13_all.deb xbase compatible C++ class library (documentation)
libxbean-java-doc_4.5-8_all.deb API documentation for XBean
libxbean-java_4.5-8_all.deb plugin based Java application server
libxbean-reflect-java_4.5-8_all.deb plugin based Java application server (xbean-reflect)
libxc-dev_4.2.3-3_i386.deb Library of Exchange-Correlation Functionals (development files)
libxc5_4.2.3-3_i386.deb Library of Exchange-Correlation Functionals
libxcb-composite0-dev_1.13.1-2_i386.deb X C Binding, composite extension, development files
libxcb-composite0_1.13.1-2_i386.deb X C Binding, composite extension
libxcb-cursor-dev_0.1.1-4_i386.deb utility libraries for X C Binding -- cursor, development files
libxcb-cursor0_0.1.1-4_i386.deb utility libraries for X C Binding -- cursor
Advertisement
Advertisement