libwebinject-perl_1.94-1_all.deb


Advertisement

Description

libwebinject-perl - Perl Module for testing web services

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libwebinject-perl_1.94-1_all.deb
Package name libwebinject-perl
Package version 1.94
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Webinject
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 28.15 KB
Installed size 110.00 KB
WebInject is a free tool for automated testing of web applications and web
services. It can be used to test individual system components that have HTTP
interfaces (JSP, ASP, CGI, PHP, AJAX, Servlets, HTML Forms, XML/SOAP Web
Services, REST, etc), and can be used as a test harness to create a suite of
[HTTP level] automated functional, acceptance, and regression tests. A test
harness allows you to run many test cases and collect/report your results.
WebInject offers real-time results display and may also be used for
monitoring system response times.

Alternatives

Package Version Architecture Repository
libwebinject-perl_1.94-1_all.deb 1.94 all Debian Main
libwebinject-perl - - -

Requires

Name Value
libcrypt-ssleay-perl -
liberror-perl -
libhttp-cookies-perl -
libhttp-message-perl -
liburi-perl -
libwww-perl -
libxml-parser-perl -
libxml-simple-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libwebinject-perl_1.94-1_all.deb
Source Package libwebinject-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwebinject-perl deb package:
    # sudo apt-get install libwebinject-perl

Files

Path
/usr/share/doc/libwebinject-perl/changelog.Debian.gz
/usr/share/doc/libwebinject-perl/changelog.gz
/usr/share/doc/libwebinject-perl/copyright
/usr/share/doc/libwebinject-perl/examples/config.xml
/usr/share/doc/libwebinject-perl/examples/testcases.xml
/usr/share/doc/libwebinject-perl/examples/webinject.pl
/usr/share/lintian/overrides/libwebinject-perl
/usr/share/man/man3/Webinject.3pm.gz
/usr/share/perl5/Webinject.pm

Changelog

2017-11-01 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.94-1) unstable; urgency=medium
* Import upstream version 1.94.
* Update years of packaging copyright.
* Refresh lintian override: changed line number.
* Declare compliance with Debian Policy 4.1.1.
2016-12-25 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.92-1) unstable; urgency=medium
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
* Remove Nathan handler from Uploaders. Thanks for your work!
* Import upstream version 1.92.
* Declare compliance with Debian Policy 3.9.8.
* Refresh lintian override (line number change).
2016-02-07 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.90-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Import upstream version 1.90.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.7.
* Add lintian override for manpage-has-errors-from-man "can't break
line".
2015-11-01 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.88-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata.
* Import upstream version 1.88
* Update years of packaging copyright.
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.
2013-12-11 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.86-1) unstable; urgency=medium
* New upstream release.
2013-11-08 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.84-1) unstable; urgency=low
* New upstream release.
* Add (build) dependency on liburi-perl.
* Declare compliance with Debian Policy 3.9.5.
2013-10-11 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.80-1) unstable; urgency=low
[ Nathan Handler ]
* New upstream release 1.76
* debian/control:
- Add myself to list of Uploaders
- Bump Standards-Version to 3.9.4 (no changes)
- Use metacpan instead of search.cpan.org for Homepage
- Use debhelper (>= 9)
* debian/compat: Bump to 9
* debian/copyright:
- Add myself to debian/* copyright
- Use metacpan instead of search.cpan.org
- Use <> to surround email addresses instead of ()
* debian/watch:
- Use metacpan instead of search.cpan.org
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ gregor herrmann ]
* New upstream release 1.80.
* Update years of packaging copyright.
2012-06-02 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.74-1) unstable; urgency=low
* New upstream release.
* Update copyright years for inc/Module/*.
2012-03-02 - gregor herrmann <gregoa@debian.org>
libwebinject-perl (1.72-1) unstable; urgency=low
* Initial release (closes: #661692).

See Also

Package Description
libwebjars-locator-core-java_0.30-1_all.deb WebJars Locator Core
libwebjars-locator-java_0.32-1_all.deb WebJars Locator
libwebkdc-perl_4.7.0-7_all.deb Perl libraries for WebAuth central login server
libwebkit2-sharp-4.0-cil-dev_2.10.9+git20160917-1.1_i386.deb CLI bindings for WebKitGTK+ 4.0 using GObject Introspection - development
libwebkit2-sharp-4.0-cil_2.10.9+git20160917-1.1_i386.deb CLI bindings for WebKitGTK+ 4.0 using GObject Introspection
libwebkit2gtk-4.0-37-gtk2_2.24.3-1~deb10u1_i386.deb Web content engine library for GTK - GTK 2 plugin process
libwebkit2gtk-4.0-37_2.24.3-1~deb10u1_i386.deb Web content engine library for GTK
libwebkit2gtk-4.0-dev_2.24.3-1~deb10u1_i386.deb Web content engine library for GTK - development files
libwebkit2gtk-4.0-doc_2.24.3-1~deb10u1_all.deb Web content engine library for GTK - documentation
libwebp-dev_0.6.1-2_i386.deb Lossy compression of digital photographic images
libwebp6_0.6.1-2_i386.deb Lossy compression of digital photographic images
libwebpdemux2_0.6.1-2_i386.deb Lossy compression of digital photographic images
libwebpmux3_0.6.1-2_i386.deb Lossy compression of digital photographic images
libwebrtc-audio-processing-dev_0.3-1_i386.deb development files for the webrtc-audio-processing library
libwebrtc-audio-processing1_0.3-1_i386.deb AudioProcessing module from the WebRTC project
Advertisement
Advertisement