libwagon-java_3.3.1-2_all.deb


Advertisement

Description

libwagon-java - Artifact transport abstraction used in Maven (transitional package)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libwagon-java_3.3.1-2_all.deb
Package name libwagon-java
Package version 3.3.1
Package release 2
Package architecture all
Package type deb
Category java
Homepage http://maven.apache.org/wagon/
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 4.55 KB
Installed size 11.00 KB
The Wagon project defines a simple API for transferring resources
(artifacts) to and from repositories. The word repository is used in this
context as it is commonly used in Maven and means a storage of artifacts.
It is also used to deploy the Maven generated site to a server.
Wagon defines a unified API, and it currently has the following providers:
* File
* HTTP
* HTTP lightweight
* FTP
* SSH/SCP
* WebDAV

Alternatives

Package Version Architecture Repository
libwagon-java_3.3.1-2_all.deb 3.3.1 all Debian Main
libwagon-java - - -

Requires

Name Value
libwagon-file-java >= 3.3.1-2
libwagon-ftp-java >= 3.3.1-2
libwagon-http-java >= 3.3.1-2
libwagon-http-shaded-java >= 3.3.1-2
libwagon-provider-api-java >= 3.3.1-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libwagon-java_3.3.1-2_all.deb
Source Package wagon

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwagon-java deb package:
    # sudo apt-get install libwagon-java

Files

Path
/usr/share/doc/libwagon-java/changelog.Debian.gz
/usr/share/doc/libwagon-java/copyright

Changelog

2019-02-15 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.3.1-2) unstable; urgency=medium
* Team upload.
* Rebuild with libhttpcore-java (>= 4.4.11-1~) to restore the compatibility
with Java 7 (Closes: #922347)
2019-01-11 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.3.1-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Rebuild with libhttpclient-java (>= 4.5.6-2~) to restore the compatibility
with Java 8 (Closes: #918772)
* Standards-Version updated to 4.3.0
2018-12-10 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.2.0-2) unstable; urgency=medium
* Team upload.
* Fixed the build failure with Jetty 9.4
2018-11-19 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.2.0-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Refreshed the patches
* Generate Java 7 compatible bytecode
* Standards-Version updated to 4.2.1
2018-07-30 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.1.0-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Refreshed the patches
* Ensure the Java 8 compatibility when built with Java 9 or later
* Removed Damien Raude-Morvan from the uploaders (Closes: #889397)
* Standards-Version updated to 4.1.5
* Switch to debhelper level 11
* Use salsa.debian.org Vcs-* URLs
* Track and download the new releases from GitHub
2017-11-09 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.0.0-2) unstable; urgency=medium
* Team upload.
* Split libwagon-java into smaller packages
* Build again the wagon-ssh-* modules
* Removed the unused build dependencies: libjaxen-java,
libcommons-logging-java, libplexus-maven-plugin-java
and libmaven-install-plugin-java
* Added an explicit dependency on libplexus-classworlds-java
(used by wagon-tck-http)
2017-11-08 - Emmanuel Bourg <ebourg@apache.org>
wagon (3.0.0-1) unstable; urgency=medium
* Team upload.
* Renamed the package to wagon
* New upstream release
- Refreshed the patches
* Standards-Version updated to 4.1.1
2017-08-03 - Emmanuel Bourg <ebourg@apache.org>
wagon2 (2.12-3) unstable; urgency=medium
* Team upload.
* Fixed the build failure caused by the maven-parent update
* Depend on libplexus-classworlds2-java instead of libplexus-classworlds-java
* Depend on libplexus-utils2-java instead of libplexus-utils-java
* Depend on libplexus-container-default1.5-java instead of
libplexus-containers-java and libplexus-container-default-java
(Closes: #855959)
* Removed the unused dependencies on libbcprov-java and libnekohtml-java
* Build depend on junit4 instead of junit (Closes: #869004)
* Removed the unused doc dependencies
* Standards-Version updated to 4.0.0
* Simplified the Maven rules
2017-06-19 - Emmanuel Bourg <ebourg@apache.org>
wagon2 (2.12-2) unstable; urgency=medium
* Team upload.
* Upload to unstable
2017-05-07 - tony mancill <tmancill@debian.org>
wagon2 (2.12-1) experimental; urgency=medium
* Team upload.
* New upstream version. (Closes: #861545)
* Update debian/watch and use Files-Excluded in debian/copyright.
Drop debian/orig-tar.sh and debian/orig-tar.exclude.
* Refresh patches for 2.12 release.
- Drop add_explicit_log4j patch
- Add updated-jetty-compatibility.patch (reworked jetty-compatibility)
- Refresh for change in source line-endings.
* Add build-dep on libservlet3.1-java
* Drop unneeded build-dep on subversion
* Rewrite aggregate:jetty-all -> jetty:jetty-webapp in maven.rules
* Drop geronimo servlet-spec api from maven.rules
* Drop log4j from maven.rules
* Map javax.servlet-api to version 3.1 in maven.rules.

See Also

Package Description
libwagon-provider-api-java_3.3.1-2_all.deb Artifact transport abstraction used in Maven (Provider API)
libwagon-ssh-java_3.3.1-2_all.deb Artifact transport abstraction used in Maven (SSH providers)
libwaili-dev_19990723-22.1+b2_i386.deb WAILI is a wavelet transform library (develop. files)
libwaili1c2_19990723-22.1+b2_i386.deb WAILI is a wavelet transform library
libwala-java-doc_1.5.1-1_all.deb Static analysis on Java bytecode and related languages - Docs
libwala-java_1.5.1-1_all.deb Static analysis on Java bytecode and related languages
libwandio1-dev_3.0.21-1+b2_i386.deb development headers for the libwandio library
libwandio1_3.0.21-1+b2_i386.deb multi-threaded file compression and decompression library
libwant-perl_0.29-1+b4_i386.deb generalisation of wantarray
libwarnings-illegalproto-perl_0.001003-1_all.deb pragma to disable illegal prototype warnings on old Perls
libwavpack-dev_5.1.0-6_i386.deb audio codec (lossy and lossless) - development files
libwavpack1_5.1.0-6_i386.deb audio codec (lossy and lossless) - library
libwayland-bin_1.16.0-1_i386.deb wayland compositor infrastructure - binary utilities
libwayland-client0_1.16.0-1_i386.deb wayland compositor infrastructure - client library
libwayland-cursor0_1.16.0-1_i386.deb wayland compositor infrastructure - cursor library
Advertisement
Advertisement