libvterm-bin_0~bzr718-1_i386.deb


Advertisement

Description

libvterm-bin - abstract terminal library (utility programs)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libvterm-bin_0~bzr718-1_i386.deb
Package name libvterm-bin
Package version 0~bzr718
Package release 1
Package architecture i386
Package type deb
Category misc
Homepage http://www.leonerd.org.uk/code/libvterm/
License -
Maintainer James McCoy <jamessan@debian.org>
Download size 12.95 KB
Installed size 44.00 KB
An abstract C99 library which implements a VT220 or xterm-like terminal
emulator. It doesn't use any particular graphics toolkit or output
system, instead it invokes callback function pointers that its embedding
program should provide it to draw on its behalf. It avoids calling
malloc() during normal running state, allowing it to be used in embedded
kernel situations.
This package contains utility programs that demonstrate libvterm.

Alternatives

Package Version Architecture Repository
libvterm-bin_0~bzr718-1_amd64.deb 0~bzr718 amd64 Debian Main
libvterm-bin - - -

Requires

Name Value
libc6 >= 2.10
libvterm0 >= 0~bzr626

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libvterm-bin_0~bzr718-1_i386.deb
Source Package libvterm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvterm-bin deb package:
    # sudo apt-get install libvterm-bin

Files

Path
/usr/bin/unterm
/usr/bin/vterm-ctrl
/usr/bin/vterm-dump
/usr/share/doc/libvterm-bin/changelog.Debian.gz
/usr/share/doc/libvterm-bin/copyright

Changelog

2018-03-17 - James McCoy <jamessan@debian.org>
libvterm (0~bzr718-1) unstable; urgency=medium
* Merge latest snapshot
+ Fix implementation of query on bracketed paste mode
* control: Change Vcs-* to salsa.debian.org
* Bump debhelper compat to 11
* rules: Disable tests if DEB_BUILD_OPTIONS has nocheck
* control: Declare compliance with Policy 4.1.3
* control: Mark libvterm-dev Multi-Arch: same
2017-11-09 - James McCoy <jamessan@debian.org>
libvterm (0~bzr715-1) unstable; urgency=medium
* Merge latest snapshot
+ Support reporting FocusIn/FocusOut events
* Add new vterm_state_focus_{in,out} symbols
* Change Priority to optional
* Declare compliance with Policy 4.1.1
* Bump debhelper compat to 10
* Set R³ to no
2017-08-01 - James McCoy <jamessan@debian.org>
libvterm (0~bzr710-1) unstable; urgency=medium
* Merge latest snapshot
+ Make build reproducible (Closes: #842622)
* Declare compliance with Policy 4.0.0, no changes needed
2016-08-30 - James McCoy <jamessan@debian.org>
libvterm (0~bzr684-1) unstable; urgency=medium
* New upstream release
* Upload to unstable
* Declare compliance with policy 3.9.8, no changes required
* Migrate to automatic dbgsym package
2015-11-17 - James McCoy <jamessan@debian.org>
libvterm (0~bzr679-1) experimental; urgency=medium
* New upstream release
+ Support for bracketed paste mode
2015-02-24 - James McCoy <jamessan@debian.org>
libvterm (0~bzr638-1) experimental; urgency=medium
* Fix Vcs-* URLs.
* Merge latest upstream snapshot.
+ Add Breaks: pangoterm (<< 0~bzr572) due to upstream API changes
+ Update symbols file
* Build from upstream's distdir to use their vterm.pc creation
* Declare compatibility with Policy 3.9.6
2014-11-30 - James McCoy <jamessan@debian.org>
libvterm (0~bzr618-1) experimental; urgency=low
* Initial release (Closes: #740400)
* Fix crash in specific scroll scenarios
* Bounds-check number of rows in screen->state before calling
vterm_state_get_lineinfo
* Set Version in vterm.pc to DEB_VERSION_UPSTREAM

See Also

Package Description
libvterm-dev_0~bzr718-1_i386.deb abstract terminal library (development files)
libvterm0_0~bzr718-1_i386.deb abstract terminal library
libvtk-dicom-dev_0.8.9-1_i386.deb DICOM for VTK - dev
libvtk6-dev_6.3.0+dfsg2-2+b5_i386.deb VTK header files
libvtk6-java_6.3.0+dfsg2-2+b5_i386.deb Visualization Toolkit - A high level 3D visualization library - java
libvtk6-jni_6.3.0+dfsg2-2+b5_i386.deb Visualization Toolkit - A high level 3D visualization library - java
libvtk6-qt-dev_6.3.0+dfsg2-2+b5_i386.deb VTK header files, containing Qt files
libvtk6.3-qt_6.3.0+dfsg2-2+b5_i386.deb VTK libraries, Qt files
libvtk6.3_6.3.0+dfsg2-2+b5_i386.deb VTK libraries
libvtk7-dev_7.1.1+dfsg1-12+b1_i386.deb VTK header files
libvtk7-java_7.1.1+dfsg1-12+b1_i386.deb Visualization Toolkit - A high level 3D visualization library - java
libvtk7-jni_7.1.1+dfsg1-12+b1_i386.deb Visualization Toolkit - A high level 3D visualization library - java
libvtk7-qt-dev_7.1.1+dfsg1-12+b1_i386.deb VTK header files, containing Qt files
libvtk7.1-qt_7.1.1+dfsg1-12+b1_i386.deb VTK libraries, Qt files
libvtk7.1_7.1.1+dfsg1-12+b1_i386.deb VTK libraries
Advertisement
Advertisement