libvorbis0a_1.3.6-2_i386.deb


Advertisement

Description

libvorbis0a - decoder library for Vorbis General Audio Compression Codec

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libvorbis0a_1.3.6-2_i386.deb
Package name libvorbis0a
Package version 1.3.6
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.xiph.org/vorbis/
License -
Maintainer Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Download size 91.15 KB
Installed size 201.00 KB
Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
general-purpose compressed audio format for audio and music at fixed
and variable bitrates from 16 to 128 kbps/channel.
The Vorbis library is the primary Ogg Vorbis library.

Alternatives

Package Version Architecture Repository
libvorbis0a_1.3.6-2_amd64.deb 1.3.6 amd64 Debian Main
libvorbis0a - - -

Requires

Name Value
libc6 >= 2.15
libogg0 >= 1.1.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libvorbis0a_1.3.6-2_i386.deb
Source Package libvorbis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvorbis0a deb package:
    # sudo apt-get install libvorbis0a

Files

Path
/usr/lib/i386-linux-gnu/libvorbis.so.0
/usr/lib/i386-linux-gnu/libvorbis.so.0.4.8
/usr/share/doc/libvorbis0a/changelog.Debian.gz
/usr/share/doc/libvorbis0a/changelog.gz
/usr/share/doc/libvorbis0a/copyright
/usr/share/lintian/overrides/libvorbis0a

Changelog

2019-02-25 - Florian Schlichting <fsfs@debian.org>
libvorbis (1.3.6-2) unstable; urgency=medium
* Team upload
[ Ondřej Nový ]
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
* d/changelog: Remove trailing whitespaces
* d/control: Remove trailing whitespaces
* d/control: Set Vcs-* to salsa.debian.org
[ Florian Schlichting ]
* Set Maintainer address to Debian Multimedia Maintainers (closes: #899590)
* Cherry-pick two patches from upstream git (closes: #876780):
+ 0003-CVE-2017-14160-fix-bounds-check-on-very-low-sample-r.patch
(this is also CVE-2018-10393)
+ 0004-Sanity-check-number-of-channels-in-setup.patch (CVE-2018-10392)
* Use secure URIs for xiph.org
* Update d/copyright to copyright-format 1.0
* Bump dh compat to level 12
* Enable all hardening build flags
* Add Build-Depends-Package field to symbols files
* Declare compliance with Debian Policy 4.3.0
* Drop debian/source.lintian-overrides, it is apparently unused
* Make lintian happy: "I" is a number here
* Update debian/tests/test-examples, the examples are no longer gzipped at
this compat level
* Add 0005-vorbisenc-detect-if-new-template-is-null.patch from upstream git
to fix the autopkgtest (closes: #772877)
2018-03-22 - Petter Reinholdtsen <pere@debian.org>
libvorbis (1.3.6-1) unstable; urgency=medium
* Add more used CPE strings to d/upstream/metadata.
* Fix typo in patch description.  Thanks lintian.
* Updated Standards-Version from 3.9.8 to 4.1.3.
* Changed debhelper compat level from 9 to  10.
* Remove no longer needed Testsuite header from d/control.
* Drop binary package libvorbis-dbg.  Use automatically generated dbgsym
package instead.
* New upstream version 1.3.6.
- Fixes CVE-2018-5146 - out-of-bounds write on codebook decoding.
- Fixes CVE-2017-14632 - free() on uninitialized data
- Fixes CVE-2017-14633/CVE-2017-14633 - out-of-bounds read (Closes: 870341)
- Removed obsolete patches
CVE-2017-14633-Don-t-allow-for-more-than-256-channels.patch,
CVE-2017-14632-vorbis_analysis_header_out-Don-t-clear-opb.patch and
CVE-2018-5146-Prevent-out-of-bounds-write-in-codeboo.patch.
2018-03-16 - Salvatore Bonaccorso <carnil@debian.org>
libvorbis (1.3.5-4.2) unstable; urgency=medium
* Non-maintainer upload.
* Prevent out-of-bounds write in codebook decoding (CVE-2018-5146)
(Closes: #893130)
2017-12-20 - Guido Günther <agx@sigxcpu.org>
libvorbis (1.3.5-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Cherry-pick upstream patches for CVE-2017-14632 and CVE-2017-14633
(Closes: #876778, 876779)
2016-12-22 - Petter Reinholdtsen <pere@debian.org>
libvorbis (1.3.5-4) unstable; urgency=low
* Changed Standards-Version from 3.9.6 to 3.9.8.
* Added CPE id in d/upstream/metadata for future reference.
* Adjusted d/tests/test-coupling-segfault to print bug number and
upstream URL.
2016-02-11 - Petter Reinholdtsen <pere@debian.org>
libvorbis (1.3.5-3) unstable; urgency=medium
* Replace Peter Samuelson with Ralph Giles as uploader.  Thank you
Peter for all past work.
* Fix autopkgtest script by redirecting stderr to log file.
* Add new autopkgtest script test-coupling-segfault to detect if
bug #772877 is present.
2016-02-07 - Petter Reinholdtsen <pere@debian.org>
libvorbis (1.3.5-2) unstable; urgency=medium
* Add build-essential to the list of autopkgtest dependencies to get gcc.
2016-02-06 - Petter Reinholdtsen <pere@debian.org>
libvorbis (1.3.5-1) unstable; urgency=low
[ Martin Steghöfer ]
* New upstream version 1.3.5. (Closes: #798960)
[ Petter Reinholdtsen ]
* Added simple autopkgtest script running the examples.

See Also

Package Description
libvorbisenc2_1.3.6-2_i386.deb encoder library for Vorbis General Audio Compression Codec
libvorbisfile3_1.3.6-2_i386.deb high-level API for Vorbis General Audio Compression Codec
libvorbisidec-dev_1.2.1+git20180316-3_i386.deb Integer-only Ogg Vorbis decoder, AKA "tremor" (Development Files)
libvorbisidec1_1.2.1+git20180316-3_i386.deb Integer-only Ogg Vorbis decoder, AKA "tremor"
libvorbisspi-java_1.0.3-3_all.deb Java Service Provider Interface for the OGG Vorbis audio format
libvoro++1_0.4.6+dfsg1-3_i386.deb library for the computation of the Voronoi diagram (shared library)
libvotca-csg-dev_1.5-3_i386.deb VOTCA's coarse-graining library, development kit
libvotca-csg5_1.5-3_i386.deb VOTCA's coarse-graining library
libvotca-tools-dev_1.5-2_i386.deb VOTCA's tools library, development kit
libvotca-tools5_1.5-2_i386.deb VOTCA's tools library
libvotequorum-dev_3.0.1-2_i386.deb cluster engine Votequorum library development
libvotequorum8_3.0.1-2_i386.deb cluster engine Votequorum library
libvpb-dev_4.2.61-1_i386.deb Voicetronix telephony hardware userspace library development files
libvpb-doc_4.2.61-1_all.deb Voicetronix telephony interface library documentation
libvpb1_4.2.61-1_i386.deb Voicetronix telephony hardware userspace interface library
Advertisement
Advertisement