libversion-perl_0.9924-1+b1_i386.deb


Advertisement

Description

libversion-perl - Perl extension for Version Objects

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libversion-perl_0.9924-1+b1_i386.deb
Package name libversion-perl
Package version 0.9924
Package release 1+b1
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/version
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 54.78 KB
Installed size 142.00 KB
The version module implements version objects for older version of Perl and
provides the version object API for all versions of Perl.
There are two different types of version objects supported by this modules,
corresponding to the two different styles of versions in use:
* Decimal Versions - The classic floating-point number $VERSION.
* Dotted Decimal Versions - The more modern form of version assignment, with
3 (or potentially more) integers separated by decimal points (e.g. v1.2.3).

Alternatives

Package Version Architecture Repository
libversion-perl_0.9924-1+b1_amd64.deb 0.9924 amd64 Debian Main
libversion-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libversion-perl_0.9924-1+b1_i386.deb
Source Package libversion-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libversion-perl deb package:
    # sudo apt-get install libversion-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/version.pm
/usr/lib/i386-linux-gnu/perl5/5.28/version.pod
/usr/lib/i386-linux-gnu/perl5/5.28/auto/version/vxs/vxs.so
/usr/lib/i386-linux-gnu/perl5/5.28/version/Internals.pod
/usr/lib/i386-linux-gnu/perl5/5.28/version/regex.pm
/usr/lib/i386-linux-gnu/perl5/5.28/version/vpp.pm
/usr/lib/i386-linux-gnu/perl5/5.28/version/vxs.pm
/usr/share/doc/libversion-perl/README
/usr/share/doc/libversion-perl/changelog.Debian.gz
/usr/share/doc/libversion-perl/changelog.Debian.i386.gz
/usr/share/doc/libversion-perl/changelog.gz
/usr/share/doc/libversion-perl/copyright
/usr/share/man/man3/version.3pm.gz
/usr/share/man/man3/version::Internals.3pm.gz

Changelog

2018-05-17 - gregor herrmann <gregoa@debian.org>
libversion-perl (1:0.9924-1) unstable; urgency=medium
[ Alex Muntada ]
* Remove inactive pkg-perl members from Uploaders.
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* New upstream release.
* Update debian/upstream/metadata (new upstream repo).
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 4.1.4.
2017-06-23 - Lucas Kanashiro <kanashiro@debian.org>
libversion-perl (1:0.9918-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Remove Jonathan Yu from Uploaders. Thanks for your work!
[ Lucas Kanashiro ]
* Import upstream version 0.9918
* Update years of upstream copyright
* Update Debian packaging copyright
* Bump debhelper compatibility level to 10
* Declare compliance with Debian Policy 4.0.0
2016-06-03 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libversion-perl (1:0.9917-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Lucas Kanashiro ]
* Import upstream version 0.9917
* Declare compliance with Debian policy 3.9.8
2016-03-21 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libversion-perl (1:0.9916-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.9916
* debian/rules: export DEB_BUILD_MAINT_OPTIONS = hardening=+all
2016-03-09 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libversion-perl (1:0.9915-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.9915
* Update years of upstream copyright
* Update Debian packaging copyright
* debian/control: wrap and sort
2016-02-28 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libversion-perl (1:0.9914-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.9914
2016-02-17 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libversion-perl (1:0.9913-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Lucas Kanashiro ]
* Add debian/upstream/metadata
* Import upstream version 0.9913
* Declare compliance with Debian policy 3.9.7
2015-07-12 - Salvatore Bonaccorso <carnil@debian.org>
libversion-perl (1:0.9912-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 0.9912
* Declare package as autopkgtestable
2014-09-26 - Salvatore Bonaccorso <carnil@debian.org>
libversion-perl (1:0.9909-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
* Imported Upstream version 0.9909
- Make package installable again in sid by updating to same version as
provided already in perl 5.20.1 (Closes: #762964)
* Declare compliance with Debian Policy 3.9.6
2014-02-15 - Salvatore Bonaccorso <carnil@debian.org>
libversion-perl (1:0.9908-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.9908

See Also

Package Description
libversion-util-perl_0.731-1_all.deb Perl module that provides version-number utilities
libversioneer-clojure_0.1.1-3_all.deb version introspection for Leiningen-generated projects
libverto-dev_0.3.0-2_i386.deb Event loop abstraction for Libraries - Development
libverto-glib1_0.3.0-2_i386.deb Event loop abstraction for Libraries - glib
libverto-libev1_0.3.0-2_i386.deb Event loop abstraction for Libraries - libev
libverto1_0.3.0-2_i386.deb Event loop abstraction for Libraries - Runtime
libveyon-core_4.1.7+repack1-1_i386.deb Computer Monitoring and Classroom Management Software - libraries
libvformat-dev_1.13-10+b2_i386.deb library to read and write vcard files (development files)
libvformat0_1.13-10+b2_i386.deb library to read and write vcard files
libvhdi-dev_20181227-1_i386.deb Virtual Hard Disk image format access library -- development files
libvhdi-utils_20181227-1_i386.deb Virtual Hard Disk image format access library -- Utilities
libvhdi1_20181227-1_i386.deb Virtual Hard Disk image format access library
libvi-quickfix-perl_1.135-1_all.deb Perl support for vim's QuickFix mode
libvibe-core-dev_0.8.4-2_i386.deb High-performance web application toolkit - Core (development)
libvibe-core0_0.8.4-2_i386.deb High-performance web application toolkit - Core
Advertisement
Advertisement