libvc-dev_005-4_i386.deb


Advertisement

Description

libvc-dev - vCard library - development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libvc-dev_005-4_i386.deb
Package name libvc-dev
Package version 005
Package release 4
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://rolo.sourceforge.net/
License -
Maintainer Rafael Laboissiere <rafael@debian.org>
Download size 19.52 KB
Installed size 64.00 KB
vCard is an Electronic Business Card format, as specified by the
versit Consortium, useful for storing personal data.  libvc handles
scanning a vCard file, parsing the vCard file into a data storage
structure, manipulating the data storage structure, and writing back
to file.  It was originally written for `rolo', but has been
split-off as a generic library for general use.
This package contains static library, headers, and the development
manpage for libvc.

Alternatives

Package Version Architecture Repository
libvc-dev_005-4_amd64.deb 005 amd64 Debian Main
libvc-dev - - -

Requires

Name Value
libvc0 = 005-4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libvc-dev_005-4_i386.deb
Source Package libvc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvc-dev deb package:
    # sudo apt-get install libvc-dev

Files

Path
/usr/include/vc.h
/usr/lib/i386-linux-gnu/libvc.a
/usr/lib/i386-linux-gnu/libvc.la
/usr/lib/i386-linux-gnu/libvc.so
/usr/share/doc/libvc-dev/NEWS.gz
/usr/share/doc/libvc-dev/README
/usr/share/doc/libvc-dev/README.Debian
/usr/share/doc/libvc-dev/THANKS
/usr/share/doc/libvc-dev/TODO
/usr/share/doc/libvc-dev/changelog.Debian.gz
/usr/share/doc/libvc-dev/changelog.gz
/usr/share/doc/libvc-dev/copyright
/usr/share/man/man3/vc.3.gz

Changelog

2019-01-05 - Rafael Laboissiere <rafael@debian.org>
libvc (005-4) unstable; urgency=medium
* d/control:
+ Add Rules-Requires-Root: no
+ Bump Standards-Version to 4.3.0
+ Bump to debhelper compat level 12
* Build against debhelper instead of CDBS
* d/libvc*.install: Use dh-exec for installing files
* d/s/options: Drop this useless file
* d/clean: Remove built files in src/
* d/libvc0.symbols: Add Build-Depends-Package header
2017-12-23 - Rafael Laboissiere <rafael@debian.org>
libvc (005-3) unstable; urgency=medium
* d/control:
+ Bump Standards-Version to 4.1.2 (no changes needed)
+ Use URLs from Debian's GitLab server
+ Drop useless build-dependency on autotools-dev
2017-06-18 - Rafael Laboissiere <rafael@debian.org>
libvc (005-2) unstable; urgency=medium
* Uploaded to unstable
* d/copyright: Use secure URL in Format
* d/watch: Use version 4
2017-02-19 - Rafael Laboissiere <rafael@debian.org>
libvc (005-1) experimental; urgency=medium
* New upstream version 005
* Make uscan check the upstream GPG signature
* d/control: Build-Depend on bison
2017-02-18 - Rafael Laboissiere <rafael@debian.org>
libvc (004-1) experimental; urgency=medium
* New upstream version 004
* d/copyright:
+ Reflect upstream changes
+ Convert to DEP-5 format
* Bump the debhelper compatility level to 10
* d/control:
+ Bump Standards-Version to 3.9.8 (no changes needed)
+ New maintainer (Closes: 834311)
+ Use secure Vcs-* URLs
* d/watch: Use new upstream location
* d/s/format: Use 3.0 (quilt) format
* d/s/options: Add extend-diff-ignore option
* d/p/*: Drop patches (applied upstream)
* d/rules:
+ Ensure that autoreconf is run
+ Set all hardening flags
2009-09-16 - Tony Palma <xbytemx@gmail.com>
libvc (003.dfsg.1-12) unstable; urgency=low
* New maintainer. Closes: #534359
* Bump Standards-Verstion to 3.8.3
2009-04-20 - Rafael Laboissiere <rafael@debian.org>
libvc (003.dfsg.1-11) unstable; urgency=low
* debian/control:
+ Bump Standards-Version to 3.8.1 (add needed file
debian/README.source explaining the patch system)
+ The package is now maintained with Git at alioth.debian.org.  Add
Vcs-Git field and change Vcs-Browser accordingly.
2009-02-13 - Rafael Laboissiere <rafael@debian.org>
libvc (003.dfsg.1-10) unstable; urgency=low
* debian/rules: Use debian/clean instead of manually cleaning files
* debian/compat, debian/control: Bump build-dependency on debhelper to
>= 7.0.0, otherwise debian/clean is moot
* debian/clean: New file
* debian/control:
+ Fix Lintian warning debhelper-but-no-misc-depends
+ Drop useless Section field for libvc0 package
* debian/libvc0.symbols: Add shared library symbols file
2008-07-01 - Rafael Laboissiere <rafael@debian.org>
libvc (003.dfsg.1-9) unstable; urgency=low
* debian/control:
+ Append trunk/ to the path in Vcs-Svn:, such that debcheckout works
+ Bump Standards-Version to 3.8.0 (no changes needed)
* debian/watch: Remove "dfsg" from the upstream version before number
comparison
* Use quilt instead of CDBS' simple-patchsys
2007-12-15 - Rafael Laboissiere <rafael@debian.org>
libvc (003.dfsg.1-8) unstable; urgency=low
* debian/control:
+ Use the now official Vcs-* fields instead of the obsolete XS-Vcs-*
+ Dropped the Homepage pseudo-header from the extended descriptions
+ Bumped Standards-Version to 3.7.3

See Also

Package Description
libvc0_005-4_i386.deb vCard (the Electronic Business Card) library
libvcdinfo-dev_2.0.1+dfsg-3_i386.deb library to extract information from VideoCD (development files)
libvcdinfo0_2.0.1+dfsg-3_i386.deb library to extract information from VideoCD
libvcs-lite-perl_0.12-1_all.deb Minimal version control system
libvdb-sqlite-dev_2.9.3+dfsg-2_i386.deb sqlite modul of ncbi-vdb library (devel)
libvdb-sqlite2_2.9.3+dfsg-2_i386.deb sqlite modul of ncbi-vdb library
libvde-dev_2.3.2+r586-2.2_i386.deb Virtual Distributed Ethernet - support libraries development files
libvde0_2.3.2+r586-2.2_i386.deb Virtual Distributed Ethernet - support libraries
libvdeplug-dev_2.3.2+r586-2.2_i386.deb Virtual Distributed Ethernet - Plug development files
libvdeplug2_2.3.2+r586-2.2_i386.deb Virtual Distributed Ethernet - Plug library
libvdk2-2c2_2.4.0-5.5_i386.deb Visual Development Kit C++ library version 2
libvdk2-dev_2.4.0-5.5_i386.deb header files and static libraries for VDK library version 2
libvdk2-doc_2.4.0-5.5_all.deb documentation for VDK library version 2
libvdpau-dev_1.1.1-10_i386.deb Video Decode and Presentation API for Unix (development files)
libvdpau-doc_1.1.1-10_all.deb Video Decode and Presentation API for Unix (documentation)
Advertisement
Advertisement