libunicode-string-perl_2.10-1+b4_i386.deb


Advertisement

Description

libunicode-string-perl - Older Perl modules for Unicode string manipulation

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libunicode-string-perl_2.10-1+b4_i386.deb
Package name libunicode-string-perl
Package version 2.10
Package release 1+b4
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib role::program works-with::text works-with::unicode
Homepage https://metacpan.org/release/Unicode-String
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 97.69 KB
Installed size 615.00 KB
This package provides Unicode::String, which manipulates strings of
characters in various Unicode representations, and Unicode::CharName,
which maps Unicode characters to official character names.
These modules predate native Unicode support inside Perl.  Normally, the
integrated Perl Unicode support and modules such as Encode should be used
instead of these modules.  They are provided primarily for their
additional utility functions and to support other Perl code with
dependencies on these modules.  Be aware that Unicode::CharName only
includes Unicode characters up to Unicode 4.1 and the character name
tables included with Perl are more complete.

Alternatives

Package Version Architecture Repository
libunicode-string-perl_2.10-1+b4_amd64.deb 2.10 amd64 Debian Main
libunicode-string-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libunicode-string-perl_2.10-1+b4_i386.deb
Source Package libunicode-string-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libunicode-string-perl deb package:
    # sudo apt-get install libunicode-string-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Unicode/CharName.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Unicode/String.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Unicode/String/String.so
/usr/share/doc/libunicode-string-perl/README
/usr/share/doc/libunicode-string-perl/changelog.Debian.gz
/usr/share/doc/libunicode-string-perl/changelog.Debian.i386.gz
/usr/share/doc/libunicode-string-perl/changelog.gz
/usr/share/doc/libunicode-string-perl/copyright
/usr/share/man/man3/Unicode::CharName.3pm.gz
/usr/share/man/man3/Unicode::String.3pm.gz

Changelog

2016-09-12 - Lucas Kanashiro <kanashiro@debian.org>
libunicode-string-perl (2.10-1) unstable; urgency=low
* Team upload.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Change bugtracker URL(s) to HTTPS.
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Remove Jaldhar H. Vyas from Uploaders. Thanks for your work!
[ Lucas Kanashiro ]
* Import upstream version 2.10
* Remove fix-defined-hash-deprecation-warning.patch, applied by upstream
* Rename debian/docs -> debian/libunicode-string-perl.docs
* Declare compliance with Debian policy 3.9.8
* debian/rules: enable hardening=+bindnow
* Create patch to fix pod2man error
2012-01-29 - Salvatore Bonaccorso <carnil@debian.org>
libunicode-string-perl (2.09-5) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Bump Debhelper compat level to 9.
Adjust versioned Build-Depends on debhelper to (>= 9).
* Update debian/copyright file.
Update to revision 174 of format specification of DEP5 proposal for
machine readable copyright file information.
* Add fix-defined-hash-deprecation-warning.patch patch.
Fix 'defined(%hash) is deprecated' warning.
Thanks to Justin B Rye <jbr@edlug.org.uk> for the patch (Closes: #657144)
* Bump Standards-Version to 3.9.2
* Drop Depends on libmime-base64-perl.
Dependency for MIME::Base64 is already satisfied by perl package.
2011-03-06 - Russ Allbery <rra@debian.org>
libunicode-string-perl (2.09-4) unstable; urgency=low
* Team upload.
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
* Change my email address.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Russ Allbery ]
* Remove myself from Uploaders.
* Update debhelper compatibility level to V8.
- Use debhelper rule minimization.
* Remove versioned build dependency on Perl satisfied by oldstable.
* Change Debian source package format to 3.0 (quilt).
* Rewrite debian/copyright in DEP-5 format.
* Add the Unicode Character Database license, since Unicode::CharMap is
derived from it.
* Expand the long description to note that these modules are older and
predate native Unicode support, and the character mapping table is
somewhat out of date.  Recommend using native facilities instead where
possible.
* Update standards version to 3.9.1 (no changes required).
2008-01-25 - Damyan Ivanov <dmn@debian.org>
libunicode-string-perl (2.09-3) unstable; urgency=low
[ gregor herrmann ]
* debian/rules: delete /usr/share/perl5 only if it exists.
[ Damyan Ivanov ]
* debian/rules: cleanup
+ allow overriding of perl being used (by $(PERL))
+ use dh_listpackages instead of hard-coded package name
+ use $(CURDIR) instead of $(shell pwd)
+ allow disabling build optimation by setting noopt in $DEB_BUILD_OPTIONS
+ do not ignore test suite errors
+ use "$@" when touching stamps
+ use dh_clean for removing stamp files
+ remove unused dh_installdirs and dh_installman
+ move dh_installdocs and dh_installchangelogs deom install-stamp to
binary-arch target
+ add dh_testroot to binary-arch target
+ .PHONY: remove checkroot, add install and build
* add README to dh_installdocs, remove debian/docs
* debhelper compatibility level 6
* add myself to Uploaders
* debian/copyright: update years of copyright

See Also

Package Description
libunicode-stringprep-perl_1.105+dfsg-1_all.deb Perl module for preparation of Internationalized Strings (RFC 3454)
libunicode-utf8-perl_0.62-1_i386.deb encoding and decoding of UTF-8 encoding form
libuniconf4.6_4.6.1-14_i386.deb C++ network libraries for rapid application development
libuninameslist-dev_20180701-1_i386.deb library of Unicode annotation data (development files)
libuninameslist1_20180701-1_i386.deb library of Unicode annotation data
libuninum-dev_2.7-1.1+b2_i386.deb development files for Libuninum library
libuninum5_2.7-1.1+b2_i386.deb library for handling numbers as Unicode strings
libunique-1.0-0_1.1.6-6_i386.deb Library for writing single instance applications - shared libraries
libunique-dev_1.1.6-6_i386.deb Library for writing single instance applications - development files
libunique-doc_1.1.6-6_all.deb Library for writing single instance applications - documentation
libunirest-java-java_1.4.8-2_all.deb Simplified, lightweight HTTP client library
libunistring-dev_0.9.10-1_i386.deb Unicode string library for C - development files
libunistring2_0.9.10-1_i386.deb Unicode string library for C
libunittest++-dev_2.0.0-3_i386.deb unit testing framework for c++, static library and headers
libunittest++2_2.0.0-3_i386.deb unit testing framework for c++, runtime library
Advertisement
Advertisement