libtwin-dev_13.05.03.15.06-g287d16c-2.2+b1_i386.deb


Advertisement

Description

libtwin-dev - tiny window system (development files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libtwin-dev_13.05.03.15.06-g287d16c-2.2+b1_i386.deb
Package name libtwin-dev
Package version 13.05.03.15.06
Package release g287d16c-2.2+b1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://git.kernel.org/cgit/linux/kernel/git/geoff/libtwin.git
License -
Maintainer Geoff Levand <geoff@infradead.org>
Download size 73.35 KB
Installed size 253.00 KB
With embedded systems gaining high resolution displays and powerful CPUs, the
desire for sophisticated graphical user interfaces can be realized in even the
smallest of systems. While the CPU power available for a given power budget
has increased dramatically, these tiny systems remain severely memory
constrained. This unique environment presents interesting challenges in
graphical system design and implementation. Using ideas from modern window
systems in larger environments, TWIN offers overlapping translucent windows,
anti-aliased graphics and scalable fonts in a total memory budget of 100KB.
This package contains the header files for development.

Alternatives

Package Version Architecture Repository
libtwin-dev_13.05.03.15.06-g287d16c-2.2+b1_amd64.deb 13.05.03.15.06 amd64 Debian Main
libtwin-dev - - -

Requires

Name Value
libjpeg-dev -
libpng-dev -
libtwin0 = 13.05.03.15.06-g287d16c-2.2+b1
libx11-dev -
libz-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtwin-dev_13.05.03.15.06-g287d16c-2.2+b1_i386.deb
Source Package libtwin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtwin-dev deb package:
    # sudo apt-get install libtwin-dev

Files

Path
/usr/include/libtwin/twin.h
/usr/include/libtwin/twin_fbdev.h
/usr/include/libtwin/twin_jpeg.h
/usr/include/libtwin/twin_linux_js.h
/usr/include/libtwin/twin_linux_mouse.h
/usr/include/libtwin/twin_linux_touch.h
/usr/include/libtwin/twin_png.h
/usr/include/libtwin/twin_x11.h
/usr/lib/i386-linux-gnu/libtwin.a
/usr/lib/i386-linux-gnu/libtwin.so
/usr/lib/i386-linux-gnu/pkgconfig/libtwin.pc
/usr/share/doc/libtwin-dev/changelog.Debian.gz
/usr/share/doc/libtwin-dev/changelog.Debian.i386.gz
/usr/share/doc/libtwin-dev/changelog.gz
/usr/share/doc/libtwin-dev/copyright

Changelog

2016-01-22 - Gianfranco Costamagna <locutusofborg@debian.org>
libtwin (13.05.03.15.06-g287d16c-2.2) unstable; urgency=medium
* Non-maintainer upload.
[ Nobuhiro Iwamatsu ]
* Fix FTBFS with libpng16 (Closes: #742655)
2015-12-23 - Steve Langasek <vorlon@debian.org>
libtwin (13.05.03.15.06-g287d16c-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop wrong direct pre-dependency on multiarch-support, as reported by
lintian.
[ Fernando Seiti Furusato ]
* debian/rules: added conditional for --disable-altivec on ppc64el to fix
ftbfs. Added --with-autoreconf to build with dh-autoreconf.
Closes: #804273, #744623.
2013-05-24 - Geoff Levand <geoff@infradead.org>
libtwin (13.05.03.15.06-g287d16c-2)  unstable; urgency=low
* debian/rules: Add conditional for --disable-linux-touchscreen. Fixes
non-linux build errors.
Use $(filter) for cpu types.
* debian/libtwin-dev.install: Install libtwin.a.
2013-05-19 - Geoff Levand <geoff@infradead.org>
libtwin (13.05.03.15.06-g287d16c-1) unstable; urgency=low
* debian/compat: Update 8 -> 9.
* debian/control: Set debhelper (>= 9).
Update standards version to 3.9.4.
Update Homepage, Vcs-Git, Vcs-Browser.
Add Multi-Arch, Pre-Depends.
* debian/copyright: Update Source.
Add Copyright for new libtwin files.
* debian/*.install: Update for multiarch.
* debian/rules: Change from DEB_HOST_ARCH to DEB_HOST_ARCH_CPU.
* libtwin: Update to latest release (13.05.03.15.06-g287d16c).
Adds touch screen support.
2012-05-10 - Geoff Levand <geoff@infradead.org>
libtwin (12.04.13.17.57-g130ee5f-2) unstable; urgency=low
* debian/rules: Fix error in powerpc DEB_HOST_ARCH conditional
2012-04-13 - Geoff Levand <geoff@infradead.org>
libtwin (12.04.13.17.57-g130ee5f-1) unstable; urgency=low
* debian/rules: Add conditionals for DEB_HOST_ARCH, DEB_HOST_ARCH_OS.
Fixes non-linux and powerpc altivec build errors.
* libtwin: Update to latest release (libtwin-12.04.13.17.57-g130ee5f).
Reverts powerpc altivec changes.
2012-04-08 - Geoff Levand <geoff@infradead.org>
libtwin (12.04.08.20.33-gf15c3de-1) unstable; urgency=low
* debian/control: Update 'Homepage:'.
* debian/rules: Remove now unneeded '--with autoreconf'.
* libtwin: Update to latest release (libtwin-12.04.08.20.33-gf15c3de).
Fixes powerpc altivec build errors.
2012-03-17 - Geoff Levand <geoff@infradead.org>
libtwin (11.12.11-gcc20d5f-2) unstable; urgency=low
* debian/control: Add missing package dependencies. (Closes: #664173)
* debian/control: Update standards version to 3.9.3
* debian/control: Minor cleanup of package descriptions
* debian/rules: Add libs to LDFLAGS.
2012-02-15 - Geoff Levand <geoff@infradead.org>
libtwin (11.12.11-gcc20d5f-1) unstable; urgency=low
* Initial release (Closes: 660025)

See Also

Package Description
libtwin0_13.05.03.15.06-g287d16c-2.2+b1_i386.deb tiny window system (library)
libtwitter-api-perl_1.0005-1_all.deb Twitter REST API library for Perl
libtwofish-dev_0.3-5_i386.deb Niels Ferguson's Twofish cryptographic algorithm library
libtwofish0_0.3-5_i386.deb Niels Ferguson's Twofish cryptographic library -- runtime package
libtwolame-dev_0.3.13-4_i386.deb MPEG Audio Layer 2 encoder (development files)
libtwolame0_0.3.13-4_i386.deb MPEG Audio Layer 2 encoding library
libtxw2-java_2.3.0.1-8_all.deb Typed XML Writer for Java
libtycho-java_1.0.0-2_all.deb build Eclipse plugins with Maven
libtype-conv-camlp4-dev_113.00.02-2+b1_i386.deb support library for OCaml preprocessor type conversions
libtype-tie-perl_0.014-1_all.deb tie a variable to a type constraint
libtype-tiny-perl_1.004004-1_all.deb tiny, yet Moo(se)-compatible type constraint
libtype-tiny-xs-perl_0.014-1+b1_i386.deb boost for some of Type::Tiny's built-in type constraints
libtypes-datetime-perl_0.002-1_all.deb type constraints and coercions for datetime objects
libtypes-path-tiny-perl_0.006-1_all.deb Path::Tiny types and coercions for Moose and Moo
libtypes-serialiser-perl_1.0-1_all.deb module providing simple data types for common serialisation formats
Advertisement
Advertisement