libtreil-dev_1.8-2.2+b3_i386.deb


Advertisement

Description

libtreil-dev - Development library for treil (tree structure into tiles)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libtreil-dev_1.8-2.2+b3_i386.deb
Package name libtreil-dev
Package version 1.8
Package release 2.2+b3
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://www.unixuser.org/~ueno/software/treil/index.html
License -
Maintainer NIIBE Yutaka <gniibe@fsij.org>
Download size 7.03 KB
Installed size 26.00 KB
Treil is a utility which produces an image of tiles from tree structure.
This is a development library and a header file for treil.

Alternatives

Package Version Architecture Repository
libtreil-dev_1.8-2.2+b3_amd64.deb 1.8 amd64 Debian Main
libtreil-dev - - -

Requires

Name Value
libtreil0 = 1.8-2.2+b3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtreil-dev_1.8-2.2+b3_i386.deb
Source Package treil

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtreil-dev deb package:
    # sudo apt-get install libtreil-dev

Files

Path
/usr/include/treil.h
/usr/lib/i386-linux-gnu/libtreil.a
/usr/lib/i386-linux-gnu/libtreil.la
/usr/lib/i386-linux-gnu/libtreil.so
/usr/share/doc/libtreil-dev/changelog.Debian.gz
/usr/share/doc/libtreil-dev/changelog.Debian.i386.gz
/usr/share/doc/libtreil-dev/copyright

Changelog

2015-11-03 - Christian Hofstaedtler <zeha@debian.org>
treil (1.8-2.2) unstable; urgency=medium
* Non-maintainer upload.
* Use RbConfig instead of now removed Config to fix build with ruby 2.2.
(Closes: #791846)
2014-04-16 - Antonio Terceiro <terceiro@debian.org>
treil (1.8-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Make the package build against whatever Ruby version is the default
(Closes: #739123)
2013-07-10 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.8-2) unstable; urgency=low
* debian/source/format: New.
* debian/compat: Require 9.
* debian/control (Build-Depends): Require debhelper >= 9.  Use ruby 1.9.1.
(Standards-Version): Conforms to 3.9.4.
(Homepage): New.
(Depends): Add ${misc:Depends} for debhelper.
[libtreil0] (Multi-Arch, Pre-Depends): New.
* debian/patches/01-makefiles.diff: New.
* debian/patches/02-rbconfig.diff: New.
* debian/rules: Re-write using newer debhelper.
* debian/treil.manpages: New.
* debian/*.install: Update.
* Incorporate NMUs.
2013-07-06 - Colin Watson <cjwatson@debian.org>
treil (1.8-1.2) unstable; urgency=low
* Non-maintainer upload.
* Build-depend/depend on ruby-cairo rather than libcairo-ruby1.8 (closes:
#713112).
2012-07-10 - Scott Kitterman <scott@kitterman.com>
treil (1.8-1.1) unstable; urgency=low
* Non-maintainer upload.
* Specify use of ruby1.8 in debian/rules and add --with-ruby=ruby1.8 since
ruby is now 1.9 (Closes: #676120)
* Make treil specifically depend on ruby1.8
2008-02-29 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.8-1) unstable; urgency=low
* New upstream release.
2008-01-23 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.7-1) unstable; urgency=low
* New upstream release.  Now, struct treil_tree has "long long" for size,
should fixes problems for large files.  (Closes: #415218, #459855).
Thanks to Daniel Roschka and A. Costa for their reports.
* debian/control (Build-Depends): Removed libexpat1-dev, no longer
required.
2008-01-15 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.6-1) unstable; urgency=low
* New upstream release.
* debian/control (Standards-Version): It comforms 3.7.3.
(Build-Depends): Added libexpat1-dev.
(Section): Moved to 'utils' (was: 'games').  Because lintian complains.
* configure.ac: Substitute lib_treil_la_LIBS, when libexpat will be found.
* Makefile.am: Use lib_treil_la_LIBADD for -lexpat (not generic LIBS).
* ruby/extconf.rb.in ($libs): Removed @LIBS@, and don't use +=.
* ruby/Makefile.am: Avoid linking non-needed libraries (Ruby's mkmf 
is not that precise), by supplying LIBS.
2007-08-01 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.3-1) unstable; urgency=low
* New upstream release (Closes: #433988).
* debian/treil.1: Updated.
2007-07-18 - NIIBE Yutaka <gniibe@fsij.org>
treil (1.1-2) unstable; urgency=low
* debian/rules: Fix FTBFS.

See Also

Package Description
libtreil0_1.8-2.2+b3_i386.deb Shared library for treil (tree structure into tiles)
libtrident-java-doc_7.3+dfsg3-4_all.deb Animation library for Java applications (documentation)
libtrident-java_7.3+dfsg3-4_all.deb Animation library for Java applications
libtrilead-putty-extension-java-doc_1.2-1_all.deb Documentation for libtrilead-putty-extension-java
libtrilead-putty-extension-java_1.2-1_all.deb PuTTY key support for Trilead SSH2 library
libtrilead-ssh2-java_6401+svn158-1_all.deb Java SSH library
libtrio-dev_1.16+dfsg1-3+b2_i386.deb portable and extendable printf and string functions development files
libtrio2_1.16+dfsg1-3+b2_i386.deb portable and extendable printf and string functions
libtritonus-java_20070428-14_all.deb implementation of the Java Sound API
libtritonus-jni_20070428-14_i386.deb implementation of the Java Sound API (jni shared libraries)
libtrove-java-doc_2.1.0-3_all.deb high performance collections for java
libtrove-java_2.1.0-3_all.deb high performance collections for java
libtrove3-java-doc_3.0.3-5_all.deb high performance collections for java
libtrove3-java_3.0.3-5_all.deb high performance collections for java
libtrue-perl_0.18-2+b5_i386.deb automatically return a true value when a file is required
Advertisement
Advertisement