libtest-version-perl_2.09-1_all.deb


Advertisement

Description

libtest-version-perl - module for checking the sanity of versions in modules

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libtest-version-perl_2.09-1_all.deb
Package name libtest-version-perl
Package version 2.09
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Test-Version
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 19.00 KB
Installed size 45.00 KB
Test::Versions's goal is to be a one stop shop for checking to see that
the versions in the modules across a CPAN distribution are sane.
It has checks to ensure that all modules have a VERSION defined, and that the
VERSION is valid.

Alternatives

Package Version Architecture Repository
libtest-version-perl_2.09-1_all.deb 2.09 all Debian Main
libtest-version-perl - - -

Requires

Name Value
libfile-find-rule-perl-perl -
libmodule-metadata-perl >= 1.000020
perl >= 5.21.1
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtest-version-perl_2.09-1_all.deb
Source Package libtest-version-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-version-perl deb package:
    # sudo apt-get install libtest-version-perl

Files

Path
/usr/share/doc/libtest-version-perl/CONTRIBUTING.gz
/usr/share/doc/libtest-version-perl/changelog.Debian.gz
/usr/share/doc/libtest-version-perl/changelog.gz
/usr/share/doc/libtest-version-perl/copyright
/usr/share/man/man3/Test::Version.3pm.gz
/usr/share/perl5/Test/Version.pm

Changelog

2018-06-25 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (2.09-1) unstable; urgency=medium
* Import upstream version 2.09.
* Declare compliance with Debian Policy 4.1.4.
2018-03-17 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (2.07-1) unstable; urgency=medium
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 2.07.
* Drop untaint-find.patch, merged upstream.
* Update years of upstream and packaging copyright.
* Bump debhelper compatibility level to 10.
2017-11-12 - Damyan Ivanov <dmn@debian.org>
libtest-version-perl (2.05-2) unstable; urgency=medium
* Team upload
* patch File::Find::Rule invocation adding untaint=>1 (Closes: #881451)
* declare conformance with Policy 4.1.1 (no changes needed)
2016-09-22 - Nick Morrott <knowledgejunkie@gmail.com>
libtest-version-perl (2.05-1) unstable; urgency=medium
* Team upload.
* Import upstream version 2.05
* Refresh (build-) dependencies
2016-07-03 - Lucas Kanashiro <kanashiro@debian.org>
libtest-version-perl (2.04-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ Lucas Kanashiro ]
* Import upstream version 2.04
* Update years of upstream copyright
* Update Debian packaging copyright
* Declare compliance with Debian policy 3.9.8
* debian/contro: update build and runtime dependencies, thanks cme
2016-02-21 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (2.03-2) unstable; urgency=medium
[ gregor herrmann ]
* Rename autopkgtest configuration file(s) as per new pkg-perl-
autopkgtest schema.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Change order of alternative (build) dependencies.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.7.
2015-07-30 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libtest-version-perl (2.03-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Update Test::Tester build dependency.
[ Lucas Kanashiro ]
* Import upstream version 2.03
* Set debhelper >= 9
2015-05-21 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (2.01-1) unstable; urgency=medium
* Import upstream version 2.01
* Update github URLs and Contact in debian/upstream/metadata.
* Update debian/copyright.
Years of packaging copyright, years of upstream copyright, new
Upstream-Contact.
* Build-depend on Test::Simple 0.94.
2014-10-22 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (1.004001-1) unstable; urgency=medium
* Import upstream version 1.004001
2014-10-20 - gregor herrmann <gregoa@debian.org>
libtest-version-perl (1.004000-1) unstable; urgency=medium
* Rename debian/tests/test-files to debian/tests/pkg-perl/test-files.
* Drop debian/tests/control, add Testsuite field to debian/control
instead.
* Import upstream version 1.004000
* Declare compliance with Debian Policy 3.9.6.

See Also

Package Description
libtest-warn-perl_0.36-1_all.deb test module for checking which warnings are generated
libtest-warnings-perl_0.026-1_all.deb Perl module to test for warnings and the lack of them
libtest-weaken-perl_3.022000-1_all.deb Perl module to test that freed memory objects were actually freed
libtest-without-module-perl_0.20-1_all.deb test fallback behaviour in absence of modules
libtest-www-declare-perl_0.02-4_all.deb declarative testing module for web apps
libtest-www-mechanize-catalyst-perl_0.62-1_all.deb module for automated testing for Catalyst applications
libtest-www-mechanize-cgiapp-perl_0.05-4_all.deb Test CGI::Application apps using WWW::Mechanize
libtest-www-mechanize-mojo-perl_0.0.19-1_all.deb module for testing web applications built using Mojolicious
libtest-www-mechanize-perl_1.52-1_all.deb module for testing web applications
libtest-www-mechanize-psgi-perl_0.38-1_all.deb test PSGI programs using WWW::Mechanize
libtest-www-selenium-perl_1.36-2_all.deb Perl test framework using Selenium Remote Control
libtest-xml-perl_0.08-3_all.deb compare XML in perl tests
libtest-xml-simple-perl_1.05-1_all.deb Perl testing framework for XML data
libtest-xpath-perl_0.19-1_all.deb test XML and HTML content and structure with XPath expressions
libtest-yaml-perl_1.07-1_all.deb test module for YAML implementations
Advertisement
Advertisement