libtest-needsdisplay-perl_1.07-3_all.deb


Advertisement

Description

libtest-needsdisplay-perl - module to ensure that tests needing a display have one

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libtest-needsdisplay-perl_1.07-3_all.deb
Package name libtest-needsdisplay-perl
Package version 1.07
Package release 3
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Test-NeedsDisplay
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 7.52 KB
Installed size 21.00 KB
When testing GUI applications, sometimes applications or modules absolutely
insist on a display, even just to load a module without actually showing any
objects.
Regardless, this makes GUI applications pretty much impossible to build and
test on headless or automated systems. And it fails to the point of not even
running the Makefile.PL script because a dependency needs a display so it can
be loaded to find a version.
In these situations, what is needed is a fake display.
The Test::NeedsDisplay module will search around and try to find a way to load
some sort of display that can be used for the testing.

Alternatives

Package Version Architecture Repository
libtest-needsdisplay-perl_1.07-3_all.deb 1.07 all Debian Main
libtest-needsdisplay-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtest-needsdisplay-perl_1.07-3_all.deb
Source Package libtest-needsdisplay-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtest-needsdisplay-perl deb package:
    # sudo apt-get install libtest-needsdisplay-perl

Files

Path
/usr/share/doc/libtest-needsdisplay-perl/changelog.Debian.gz
/usr/share/doc/libtest-needsdisplay-perl/changelog.gz
/usr/share/doc/libtest-needsdisplay-perl/copyright
/usr/share/man/man3/Test::NeedsDisplay.3pm.gz
/usr/share/perl5/Test/NeedsDisplay.pm

Changelog

2015-12-29 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libtest-needsdisplay-perl (1.07-3) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Lucas Kanashiro ]
* Add debian/upstream/metadata
* Bump debhelper compatibility level to 9
* Declare compliance with Debian policy 3.9.6
* Add recommends and build dependencies on xauth and xvfb
* Mark package as autopkgtestable
2013-06-07 - gregor herrmann <gregoa@debian.org>
libtest-needsdisplay-perl (1.07-2) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
Closes: #711266
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Switch to "3.0 (quilt)" source format.
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Bump debhelper compatibility level to 8, use dh(1) in d/rules.
* Make short description a noun phrase.
* Set Standards-Version to 3.9.4 (no further changes).
2009-01-05 - gregor herrmann <gregoa@debian.org>
libtest-needsdisplay-perl (1.07-1) unstable; urgency=low
* New upstream release.
* Add /me to Uploaders.
* debian/copyright: update years of copyright.
2008-12-02 - Damyan Ivanov <dmn@debian.org>
libtest-needsdisplay-perl (1.05-1) unstable; urgency=low
* Initial Release. (Closes: #507548)

See Also

Package Description
libtest-net-ldap-perl_0.07-1_all.deb Net::LDAP subclass for testing
libtest-nobreakpoints-perl_0.15-2_all.deb module to test that files do not contain soft breakpoints
libtest-notabs-perl_2.02-1_all.deb module for scanning for hard tabs in files
libtest-nowarnings-perl_1.04-2_all.deb module to make sure you didn't emit any warnings while testing
libtest-number-delta-perl_1.06-1_all.deb module to compare the difference between numbers against a given tolerance
libtest-object-perl_0.08-1_all.deb module for thoroughly testing objects via registered handlers
libtest-output-perl_1.031-1_all.deb perl module to test stdout and stderr messages
libtest-perl-critic-perl_1.04-1_all.deb module to use Perl::Critic in test scripts
libtest-perl-critic-progressive-perl_0.03-1_all.deb module that allows gradual enforcement of coding standards
libtest-pod-content-perl_0.0.6-2_all.deb Perl module for testing POD content
libtest-pod-coverage-perl_1.10-2_all.deb module to check for pod coverage in a distribution
libtest-pod-no404s-perl_0.02-1_all.deb test utility checking POD for HTTP 404 links
libtest-pod-perl_1.52-1_all.deb module to test for POD errors
libtest-poe-client-tcp-perl_1.26-1_all.deb POE Component providing TCP client services for test cases
libtest-poe-server-tcp-perl_1.20-1_all.deb test framework for TCP client libraries using POE
Advertisement
Advertisement