libterm-prompt-perl_1.04-2_all.deb


Advertisement

Description

libterm-prompt-perl - Perl module for prompting a user for information

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libterm-prompt-perl_1.04-2_all.deb
Package name libterm-prompt-perl
Package version 1.04
Package release 2
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Term-Prompt
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 18.22 KB
Installed size 74.00 KB
Term::Prompt is used to check accept interactive input. You
specify the type of inputs allowed, a prompt, help text and
defaults and it will deal with the user interface, (and the
user!), by displaying the prompt, showing the default, and checking
to be sure that the response is one of the legal choices.

Alternatives

Package Version Architecture Repository
libterm-prompt-perl_1.04-2_all.deb 1.04 all Debian Main
libterm-prompt-perl - - -

Requires

Name Value
libterm-readkey-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libterm-prompt-perl_1.04-2_all.deb
Source Package libterm-prompt-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libterm-prompt-perl deb package:
    # sudo apt-get install libterm-prompt-perl

Files

Path
/usr/share/doc/libterm-prompt-perl/changelog.Debian.gz
/usr/share/doc/libterm-prompt-perl/changelog.gz
/usr/share/doc/libterm-prompt-perl/copyright
/usr/share/man/man3/Term::Prompt.3pm.gz
/usr/share/perl5/Term/Prompt.pm

Changelog

2015-05-01 - gregor herrmann <gregoa@debian.org>
libterm-prompt-perl (1.04-2) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add patch to correctly wrap prompts. Thanks to William Schaub for the
bug report. (LP: #1427464)
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Declare compliance with Debian Policy 3.9.6.
* Bump debhelper compatibility level to 8.
* Mark package as autopkgtest-able.
2010-04-01 - Ansgar Burchardt <ansgar@43-1.org>
libterm-prompt-perl (1.04-1) unstable; urgency=low
* New upstream release.
* Now maintained by the Debian Perl Group. (Closes: #576163)
+ debian/control: Add Vcs-* fields.
+ debian/control: Add myself to Uploaders.
* debian/control: Add Homepage field.
* debian/control: Make build-dep on perl unversioned.
* debian/control: Depend on ${perl:Depends} instead of perl.
* Refresh rules for debhelper 7.
* Use source format 3.0 (quilt).
* Convert debian/copyright to proposed machine-readable format.
* debian/watch: Use dist-based URL.
* Bump Standards-Version to 3.8.4.
2008-04-05 - Marc 'HE' Brockschmidt <he@debian.org>
libterm-prompt-perl (1.03-3.1) unstable; urgency=low
* Non-maintainer upload.
* debian/rules:
+ Don't fail when perl is smart enough not to create empty dirs. (Closes:
#467765)
+ Don't ignore make distclean errors.
* debian/copyright: Recode to UTF8
2006-06-05 - Víctor Pérez Pereira <vperez@debianvenezuela.org>
libterm-prompt-perl (1.03-3) unstable; urgency=low
* New maintainer (closes: #333194).
* Update of Debian Policy.
2005-10-27 - Andrew Pollock <apollock@debian.org>
libterm-prompt-perl (1.03-2) unstable; urgency=low
* QA Group upload orphaning this package
2005-01-05 - Marc 'HE' Brockschmidt <he@debian.org>
libterm-prompt-perl (1.03-1) unstable; urgency=low
* New upstream release.
* debian/control: Fix long description. (Closes: #275943)
* debian/watch: Added.
2004-09-12 - Marc 'HE' Brockschmidt <he@debian.org>
libterm-prompt-perl (1.01-1) unstable; urgency=low
* Initial Release. (Closes: #267798)

See Also

Package Description
libterm-query-perl_2.0-10_all.deb Perl module for subroutines that handle simple tty-based UI
libterm-readkey-perl_2.38-1_i386.deb perl module for simple terminal control
libterm-readline-gnu-perl_1.36-1_i386.deb Perl extension for the GNU ReadLine/History Library
libterm-readline-perl-perl_1.0303-2_all.deb Perl implementation of Readline libraries
libterm-readline-ttytter-perl_1.4-3_all.deb Term::ReadLine driver with special features for microblogging
libterm-readline-zoid-perl_0.07-3_all.deb Pure Perl implementation of Readline libraries
libterm-readpassword-perl_0.11-3_all.deb prompt user for a password
libterm-shell-perl_0.10-1_all.deb Perl module for writing shell-like interfaces
libterm-shellui-perl_0.92-2_all.deb Perl module for fully-featured shell-like command line environment
libterm-size-any-perl_0.002-1_all.deb unified interface to retrieve the terminal size from Perl
libterm-size-perl-perl_0.031-1+b1_i386.deb pure Perl extension for retrieving the terminal size
libterm-size-perl_0.209-1+b1_i386.deb Perl extension for retrieving terminal size
libterm-sk-perl_0.18-1_all.deb Perl extension for displaying a progress indicator on a terminal
libterm-slang-perl_0.07-13+b1_i386.deb Perl interface to the S-Lang terminal library
libterm-table-perl_0.013-1_all.deb module to format a header and rows into a table
Advertisement
Advertisement