libsystem-sub-perl_0.162800-2_all.deb


Advertisement

Description

libsystem-sub-perl - wrap external command with a DWIM sub

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsystem-sub-perl_0.162800-2_all.deb
Package name libsystem-sub-perl
Package version 0.162800
Package release 2
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/System-Sub
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 13.99 KB
Installed size 38.00 KB
System::Sub provides a Perl sub
that wraps the call to an external program.
The return value is line(s) dependending on context ("wantarray").
This may be what you need if you want to run external commands
as easily as from a Unix shell script
but with a perl-ish feel (contextual output).
So this is not a universal module
for running external programs (like IPC::Run)
but instead a simpler interface
for a common style of external programs.

Alternatives

Package Version Architecture Repository
libsystem-sub-perl_0.162800-2_all.deb 0.162800 all Debian Main
libsystem-sub-perl - - -

Requires

Name Value
libfile-which-perl -
libipc-run-perl -
libsub-name-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsystem-sub-perl_0.162800-2_all.deb
Source Package libsystem-sub-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsystem-sub-perl deb package:
    # sudo apt-get install libsystem-sub-perl

Files

Path
/usr/share/doc/libsystem-sub-perl/changelog.Debian.gz
/usr/share/doc/libsystem-sub-perl/changelog.gz
/usr/share/doc/libsystem-sub-perl/copyright
/usr/share/man/man3/System::Sub.3pm.gz
/usr/share/man/man3/System::Sub::AutoLoad.3pm.gz
/usr/share/perl5/System/Sub.pm
/usr/share/perl5/System/Sub/AutoLoad.pm

Changelog

2019-02-01 - Jonas Smedegaard <dr@jones.dk>
libsystem-sub-perl (0.162800-2) unstable; urgency=medium
* Mark test-only build-dependencies as such.
2019-02-01 - Jonas Smedegaard <dr@jones.dk>
libsystem-sub-perl (0.162800-1) unstable; urgency=low
* Initial packaging release.
Closes: Bug#921078.

See Also

Package Description
libsystemc-dev_2.3.3-2_i386.deb Development files for SystemC library
libsystemc-doc_2.3.3-2_all.deb Documentation for SystemC library
libsystemc_2.3.3-2_i386.deb SystemC library
libsystemd-dev_241-5_i386.deb systemd utility library - development files
libsystemd0_241-5_i386.deb systemd utility library
libsz2_1.0.2-1_i386.deb Adaptive Entropy Coding library - SZIP
libt3config-dev_0.2.11-1_i386.deb Development files for libt3config
libt3config0_0.2.11-1_i386.deb Library for reading and writing configuration files
libt3highlight-dev_0.4.6-1_i386.deb Development files for libt3highlight
libt3highlight2_0.4.6-1_i386.deb Syntax highlighting library
libt3key-bin_0.2.9-1+b1_i386.deb Utilities for working with libt3key terminal descriptions
libt3key-dev_0.2.9-1+b1_i386.deb Development files for libt3key
libt3key1_0.2.9-1+b1_i386.deb Terminal key sequence database library
libt3widget-dev_1.0.3-1_i386.deb Development files for libt3widget
libt3widget2_1.0.3-1_i386.deb C++ terminal dialog toolkit
Advertisement
Advertisement