libsysadm-install-perl_0.48-1_all.deb


Advertisement

Description

libsysadm-install-perl - module for typical installation tasks of system administrators

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsysadm-install-perl_0.48-1_all.deb
Package name libsysadm-install-perl
Package version 0.48
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::devel-lib role::shared-lib
Homepage https://metacpan.org/release/Sysadm-Install
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 29.74 KB
Installed size 80.00 KB
Sysadm::Install executes shell-like commands performing typical
installation tasks: Copying files, extracting tarballs, calling make.
It has a fail once and die policy, meticulously checking the result
of every operation and calling die() immeditatly if anything fails.
Sysadm::Install also supports a dry_run mode, in which it
logs everything, but suppresses any write actions.

Alternatives

Package Version Architecture Repository
libsysadm-install-perl_0.48-1_all.deb 0.48 all Debian Main
libsysadm-install-perl - - -

Requires

Name Value
libfile-which-perl -
liblog-log4perl-perl -
libterm-readkey-perl -
libwww-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsysadm-install-perl_0.48-1_all.deb
Source Package libsysadm-install-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsysadm-install-perl deb package:
    # sudo apt-get install libsysadm-install-perl

Files

Path
/usr/share/doc/libsysadm-install-perl/changelog.Debian.gz
/usr/share/doc/libsysadm-install-perl/changelog.gz
/usr/share/doc/libsysadm-install-perl/copyright
/usr/share/doc/libsysadm-install-perl/examples/ask
/usr/share/doc/libsysadm-install-perl/examples/mkperl
/usr/share/doc/libsysadm-install-perl/examples/one-liner
/usr/share/doc/libsysadm-install-perl/examples/perm_cp
/usr/share/doc/libsysadm-install-perl/examples/tap
/usr/share/doc/libsysadm-install-perl/examples/untar_in
/usr/share/man/man3/Sysadm::Install.3pm.gz
/usr/share/perl5/Sysadm/Install.pm

Changelog

2016-11-16 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.48-1) unstable; urgency=medium
[ gregor herrmann ]
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Nathan Handler from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
[ Salvatore Bonaccorso ]
* Import upstream version 0.48
* Drop fix-spelling-error-in-manpage.patch (applied upstream)
2016-05-30 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.47-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
[ Salvatore Bonaccorso ]
* Import upstream version 0.47
* Relax versioned (Build-)Depends(-Indep) on libfile-which-perl.
The version required is already satisfied in stable, thus relax the
versioned dependency to an unversioned dependency on libfile-which-perl.
* Drop spelling_errors.patch patch
* Update copyright years for debian/* packaging files
* Bump Debhelper compat level to 9
* Declare compliance with Debian policy 3.9.8
* Add patch for some spelling errors in manpage
2015-06-24 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.46-1) unstable; urgency=medium
* Import upstream version 0.46
* Refresh spelling_errors.patch patch
2015-05-27 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.45-1) unstable; urgency=medium
* Update Vcs-Browser URL to cgit web frontend
* Add debian/upstream/metadata
* Import upstream version 0.45
* Declare compliance with Debian policy 3.9.6
* Update copyright years for debian/* packaging files
* Add Testsuite: autopkgtest-pkg-perl field in debian/control
2014-05-21 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.44-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.44
* Add (build-)dependency for File::Which.
Add versioned Build-Depends-Indep and Depends on libfile-which-perl (>=
1.09) for File::Which use.
* Wrap and sort fields in debian/control file
* Declare compliance with Debian Policy 3.9.5
* Referesh spelling_errors.patch
2013-05-20 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.43-1) unstable; urgency=low
* Imported Upstream version 0.43
* Change search.cpan.org based URIs to metacpan.org based URIs
* Refresh spelling_errors.patch patch (offset)
2013-01-22 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.42-1) unstable; urgency=low
* Imported Upstream version 0.42
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Refresh spelling_errors.patch (offset)
* Update copyright years for debian/* packaging
2012-12-18 - Salvatore Bonaccorso <carnil@debian.org>
libsysadm-install-perl (0.41-1) unstable; urgency=low
[ Nathan Handler ]
* Email change: Nathan Handler -> nhandler@debian.org
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.41
* Refresh spelling_errors.patch patch (offset)
2012-09-21 - Angel Abad <angel@debian.org>
libsysadm-install-perl (0.40-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Angel Abad ]
* Imported Upstream version 0.40
* debian/patches/spelling_errors.patch: Refresh patch
* Bump Standards-Version to 3.9.4 (no changes)
* debian/copyright: Update Debian years

See Also

Package Description
libsysfs-dev_2.1.0+repack-5_i386.deb interface library to sysfs - development files
libsysfs2_2.1.0+repack-5_i386.deb interface library to sysfs
libsyslog-ocaml-dev_1.4-6+b5_i386.deb syslog routines for OCaml (development files)
libsyslog-ocaml_1.4-6+b5_i386.deb syslog routines for OCaml (runtime)
libsysstat-qt5-0-dev_0.4.2-1_i386.deb Qt-based interface to system statistics (dev)
libsysstat-qt5-0_0.4.2-1_i386.deb Qt-based interface to system statistics
libsystem-command-perl_1.119-1_all.deb Perl class for running system commands
libsystem-info-perl_0.058-1_all.deb package to obtain basic system information
libsystem-sub-perl_0.162800-2_all.deb wrap external command with a DWIM sub
libsystemc-dev_2.3.3-2_i386.deb Development files for SystemC library
libsystemc-doc_2.3.3-2_all.deb Documentation for SystemC library
libsystemc_2.3.3-2_i386.deb SystemC library
libsystemd-dev_241-7~deb10u1_i386.deb systemd utility library - development files
libsystemd0_241-7~deb10u1_i386.deb systemd utility library
libsz2_1.0.2-1_i386.deb Adaptive Entropy Coding library - SZIP
Advertisement
Advertisement