libsvn-notify-perl_2.87-1_all.deb


Advertisement

Description

libsvn-notify-perl - Subversion activity notification

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsvn-notify-perl_2.87-1_all.deb
Package name libsvn-notify-perl
Package version 2.87
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::source
Homepage https://metacpan.org/release/SVN-Notify
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 94.28 KB
Installed size 226.00 KB
SVN::Notify provides a class and an interface to notify by email Subversion
repository changes.
It is able to inform about the files changed in a commit and send the
appropriate diff files.
An additional class (SVN::Notify::HTML) is provided to manage HTML formatted
emails.
Please, consider installing a MTA if you are planning to use sendmail instead
of --smtp-* options.

Alternatives

Package Version Architecture Repository
libsvn-notify-perl_2.87-1_all.deb 2.87 all Debian Main
libsvn-notify-perl - - -

Requires

Name Value
libemail-address-xs-perl -
perl -
subversion -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsvn-notify-perl_2.87-1_all.deb
Source Package libsvn-notify-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsvn-notify-perl deb package:
    # sudo apt-get install libsvn-notify-perl

Files

Path
/usr/bin/svnnotify
/usr/share/doc/libsvn-notify-perl/changelog.Debian.gz
/usr/share/doc/libsvn-notify-perl/changelog.gz
/usr/share/doc/libsvn-notify-perl/copyright
/usr/share/man/man1/svnnotify.1p.gz
/usr/share/man/man3/SVN::Notify.3pm.gz
/usr/share/man/man3/SVN::Notify::Alternative.3pm.gz
/usr/share/man/man3/SVN::Notify::Filter.3pm.gz
/usr/share/man/man3/SVN::Notify::Filter::Trac.3pm.gz
/usr/share/man/man3/SVN::Notify::HTML.3pm.gz
/usr/share/man/man3/SVN::Notify::HTML::ColorDiff.3pm.gz
/usr/share/perl5/SVN/Notify.pm
/usr/share/perl5/SVN/Notify/Alternative.pm
/usr/share/perl5/SVN/Notify/Filter.pod
/usr/share/perl5/SVN/Notify/HTML.pm
/usr/share/perl5/SVN/Notify/Filter/Trac.pm
/usr/share/perl5/SVN/Notify/HTML/ColorDiff.pm

Changelog

2018-07-04 - gregor herrmann <gregoa@debian.org>
libsvn-notify-perl (2.87-1) unstable; urgency=medium
* Import upstream version 2.87.
* Drop patches which were taken from upstream Git.
* Update years of upstream copyright.
2018-06-30 - gregor herrmann <gregoa@debian.org>
libsvn-notify-perl (2.86-2) unstable; urgency=medium
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Add 2 patches from upstream Git to change from Email::Address to
Email::Address::XS.
Thanks to Pali Rohár for the bug report and the pointer to the
pull request. (Closes: #887549)
* debian/control: libemail-address-perl → libemail-address-xs-perl.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.1.4.
* Bump debhelper compatibility level to 10.
* Add default-mta to the mail-transport-agent Suggests, as suggested
by lintian.
* Enable autopkgtest's syntax.t.
2016-04-29 - Salvatore Bonaccorso <carnil@debian.org>
libsvn-notify-perl (2.86-1) unstable; urgency=medium
* Team upload.
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
* Import upstream version 2.86
* Add libemail-address-perl to (Build-)Depends(-Indep)
* Drop spelling.patch patch
* Bump Debhelper compat level to 9
* Update copyright years for debian/* packaging files
* Declare compliance with Debian policy 3.9.8
* t/script.t: When running autopkgtests test the installed
svnnotify script
* Declare package as autopkgtestable
2015-06-08 - gregor herrmann <gregoa@debian.org>
libsvn-notify-perl (2.84-2) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Declare compliance with Debian Policy 3.9.6.
* Add explicit build dependency on libmodule-build-perl.
* Update years of packaging copyright.
2014-01-12 - gregor herrmann <gregoa@debian.org>
libsvn-notify-perl (2.84-1) unstable; urgency=medium
* Take over for the Debian Perl Group; Closes: #733558 -- RFA/ITA
* debian/control: Added: Vcs-Git field (source stanza); Vcs-Browser
field (source stanza). Changed: Homepage field changed to
metacpan.org URL; Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Debian QA Group
<packages@qa.debian.org>).
* debian/watch: use metacpan-based URL.
* New upstream release. Closes: #655034
* Use dh(1) in debian/rules.
* Update (build) dependencies.
* Add /me to Uploaders.
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Add a patch to fix a spelling mistake.
* Declare compliance with Debian Policy 3.9.5.
2013-12-29 - Nacho Barrientos Arias <nacho@debian.org>
libsvn-notify-perl (2.81-2) unstable; urgency=low
* Orphaned. Set maintainer to Debian QA Group.
2013-11-25 - gregor herrmann <gregoa@debian.org>
libsvn-notify-perl (2.81-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS: POD coverage":
- debian/rules:
don't run pod* tests, they are already removed upstream in 2.84
(Closes: #720358)
2011-03-15 - Nacho Barrientos Arias <nacho@debian.org>
libsvn-notify-perl (2.81-1) unstable; urgency=low
* New upstream release.
* Switch to dpkg-source 3.0 (quilt) format.
* debian/control
- Bump debhelper compatibility level to 8.
- Set Standards-Version to 3.9.1 (no changes).
- B-Ds: Remove libmodule-build-perl as it is provided by perl-modules.
2009-09-24 - Nacho Barrientos Arias <nacho@debian.org>
libsvn-notify-perl (2.79-1) unstable; urgency=low
* New upstream release. 
* debian/control
+ Update standards-version to 3.8.3 (no changes).

See Also

Package Description
libsvn-perl_1.10.4-1+deb10u1_i386.deb Perl bindings for Apache Subversion
libsvn-svnlook-perl_0.04-3_all.deb module to aid using svnlook in Subversion hooks
libsvn-web-perl_0.63-3_all.deb Subversion repository web frontend
libsvn1_1.10.4-1+deb10u1_i386.deb Shared libraries used by Apache Subversion
libsvnclientadapter-java-doc_1.10.12-1_all.deb High-level Java API for Subversion (documentation)
libsvnclientadapter-java_1.10.12-1_all.deb High-level Java API for Subversion (library)
libsvncpp-dev_0.12.1dfsg-3.1+b1_i386.deb Subversion C++ library (development files)
libsvncpp3_0.12.1dfsg-3.1+b1_i386.deb Subversion C++ shared library
libsvnkit-java-doc_1.8.14-3_all.deb documentation for libsvnkit-java
libsvnkit-java_1.8.14-3_all.deb pure Java Subversion client library
libswami-dev_2.0.0+svn389-5+b11_i386.deb MIDI instrument editor - development files
libswami0_2.0.0+svn389-5+b11_i386.deb MIDI instrument editor - shared libraries
libswarmcache-java_1.0RC2+cvs20071027-7_all.deb SwarmCache - Distributed caching mechanism for Java
libswe-dev_1.80.00.0002-1+b1_i386.deb C library for The Swiss Ephemeris
libswe0_1.80.00.0002-1+b1_i386.deb C library for the Swiss Ephemeris
Advertisement
Advertisement