libstrophe-dev_0.9.2-2_i386.deb


Advertisement

Description

libstrophe-dev - Library for writing XMPP clients - development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libstrophe-dev_0.9.2-2_i386.deb
Package name libstrophe-dev
Package version 0.9.2
Package release 2
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://strophe.im/
License -
Maintainer Debian XMPP Maintainers <pkg-xmpp-devel@lists.alioth.debian.org>
Download size 58.38 KB
Installed size 203.00 KB
libstrophe is a lightweight XMPP client library written in C.
It has minimal dependencies and is configurable for various environments.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libstrophe-dev_0.9.2-2_amd64.deb 0.9.2 amd64 Debian Main
libstrophe-dev - - -

Requires

Name Value
libstrophe0 = 0.9.2-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libstrophe-dev_0.9.2-2_i386.deb
Source Package libstrophe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libstrophe-dev deb package:
    # sudo apt-get install libstrophe-dev

Files

Path
/usr/include/strophe.h
/usr/lib/i386-linux-gnu/libstrophe.a
/usr/lib/i386-linux-gnu/libstrophe.so
/usr/lib/i386-linux-gnu/pkgconfig/libstrophe.pc
/usr/share/doc/libstrophe-dev/README.markdown
/usr/share/doc/libstrophe-dev/changelog.Debian.gz
/usr/share/doc/libstrophe-dev/changelog.gz
/usr/share/doc/libstrophe-dev/copyright

Changelog

2019-01-10 - Tomasz Buchert <tomasz@debian.org>
libstrophe (0.9.2-2) unstable; urgency=medium
* refresh packaging (debhelper 12, std-ver 4.3.0)
2018-02-24 - Tomasz Buchert <tomasz@debian.org>
libstrophe (0.9.2-1) unstable; urgency=medium
* New upstream version 0.9.2
2018-02-18 - Tomasz Buchert <tomasz@debian.org>
libstrophe (0.9.1+git20170912.6e6093e-2) unstable; urgency=medium
* Update links to salsa
2018-02-18 - Tomasz Buchert <tomasz@debian.org>
libstrophe (0.9.1+git20170912.6e6093e-1) unstable; urgency=medium
* Changed maintainer to the XMPP team (thanks Darek!)
* Bump std-ver to 4.1.3
* Use "Rules-Requires-Root: no"
* Refresh packaging and patches
* Bump debhelper compat to 11
* Fix useless-autoreconf-build-depends
* Fix insecure-copyright-format-uri
* New upstream git version 0.9.1+git20170912.6e6093e
2016-09-22 - Dariusz Dwornikowski <darek@debian.org>
libstrophe (0.9.1-1) unstable; urgency=medium
* New upstream version 0.9.1
* Bump standards to 3.9.8, no changes needed
* Year 2016 added to d/copyright
* Changed maintainer's email to d.o
* s/libstrophe0.symbols updated with new symbols
* Enable bindnow hardening flags
* Fixed spelling in patch d/patches/fix_spelling.patch
2015-09-10 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
libstrophe (0.8.8-2) unstable; urgency=medium
* Added installation of pkg-config file
2015-08-28 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
libstrophe (0.8.8-1) unstable; urgency=medium
* Imported Upstream version 0.8.8
* Cleaned-up licenses in d/copyright
* d/libstrophe0.symbols:
- added xmpp_connect_component@Base 0.8.8-1
2014-11-08 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
libstrophe (0.8.7-1) unstable; urgency=medium
* Imported Upstream version 0.8.7
* Bump standards to 3.9.6
- no changes needed
* Regenerated d/libstrophe0.symbols
- no ABI changes needed, hidden private symbols
not used anyway
2014-08-28 - Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>
libstrophe (0.8.6-1) unstable; urgency=medium
* Initial release (Closes: #511341)

See Also

Package Description
libstrophe0_0.9.2-2_i386.deb Library for writing XMPP clients - shared library
libstruct-compare-perl_1.0.1-4_all.deb Perl module providing recursive diff for perl structures
libstruct-dumb-perl_0.09-1_all.deb module to create simple lightweight record-like structures
libstxxl-dev_1.4.1-3_i386.deb Development libraries for STXXL
libstxxl-doc_1.4.1-3_all.deb Documentation for STXXL
libstxxl1-bin_1.4.1-3_i386.deb STXXL File creation and benchmark tool
libstxxl1v5_1.4.1-3_i386.deb C++ Standard Template Library for extra large datasets
libstylebook-java_1.0~b3~svn20061109-7_all.deb XML application for authoring web site content
libstyx2_2.0.1-1+b1_i386.deb runtime libraries for styx
libsub-delete-perl_1.00002-2_all.deb Perl module to delete subroutines
libsub-exporter-formethods-perl_0.100052-1_all.deb Sub::Exporter extension for handling methods
libsub-exporter-globexporter-perl_0.005-1_all.deb module for exporting shared globs
libsub-exporter-perl_0.987-1_all.deb sophisticated exporter for custom-built routines
libsub-exporter-progressive-perl_0.001013-1_all.deb module for using Sub::Exporter only if needed
libsub-identify-perl_0.14-1+b1_i386.deb module to retrieve names of code references
Advertisement
Advertisement