libsolv-perl_0.6.35-2+b2_i386.deb


Advertisement

Description

libsolv-perl - dependency solver using a satisfiability algorithm (Perl bindings)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsolv-perl_0.6.35-2+b2_i386.deb
Package name libsolv-perl
Package version 0.6.35
Package release 2+b2
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://github.com/openSUSE/libsolv
License -
Maintainer Mike Gabriel <sunweaver@debian.org>
Download size 125.56 KB
Installed size 714.00 KB
This dependency solver code in this package is based on two major, but
independent, blocks:
1. Using a dictionary approach to store and retrieve package
and dependency information.
2. Using satisfiability, a well known and researched topic, for
resolving package dependencies.
This package contains the Perl bindings for the libsolv0 library.

Alternatives

Package Version Architecture Repository
libsolv-perl_0.6.35-2+b2_amd64.deb 0.6.35 amd64 Debian Main
libsolv-perl - - -

Requires

Name Value
libc6 >= 2.4
libsolv0 = 0.6.35-2+b2
libsolvext0 >= 0.6.35-2+b2
perl >= 5.28.0-4
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsolv-perl_0.6.35-2+b2_i386.deb
Source Package libsolv

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsolv-perl deb package:
    # sudo apt-get install libsolv-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/solv.pm
/usr/lib/i386-linux-gnu/perl5/5.28/solv.so
/usr/share/doc/libsolv-perl/BUGS
/usr/share/doc/libsolv-perl/CREDITS
/usr/share/doc/libsolv-perl/README
/usr/share/doc/libsolv-perl/changelog.Debian.gz
/usr/share/doc/libsolv-perl/changelog.Debian.i386.gz
/usr/share/doc/libsolv-perl/changelog.gz
/usr/share/doc/libsolv-perl/copyright

Changelog

2018-09-03 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.35-2) unstable; urgency=medium
* debian/changelog: White-space cleanup in previous stanza.
* debian/rules:
+ Add build time option ENABLE_COMPLEX_DEPS=1.
* debian/control:
+ Bump Standards-Version: to 4.2.1. No changes needed.
2018-08-20 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.35-1) unstable; urgency=medium
* New upstream release.
* debian/control:
+ Bump Standards-Version: to 4.2.0. No changes needed.
+ Update Vcs-*: fields. Packaging Git has been migrated to
salsa.debian.org.
+ Drop ancient X-Python{,3}-Version: fields.
+ Add to B-D: dh-python.
* debian/patches:
+ Rebase 1004_cmake-module-path-fix.patch and 1006_various-types.patch.
* debian/copyright:
+ Update auto-generated copyright.in template file.
+ Update copyright attributions.
* debian/libsolv0.symbols:
+ Update symbols.
* debian/libsolv-tools.lintian-overrides:
+ Drop file. Issues solved with this upstream release.
2018-04-24 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.34-1) unstable; urgency=medium
* New upstream release.
* debian/control:
+ Bump Standards-Version: to 4.1.4. No changes needed.
+ White-space cleanup.
* debian/patches:
+ Drop 2001_build-for-SUSE-and-find-rpmdb.patch. Not required anymore.
+ Update/rebase patches.
* debian/{control,compat}:
+ Bump to DH compat level 10. (CDBS not yet supports level 11,
unfortunately).
* debian/copyright:
+ Use secure URI to obtain copyright format reference.
+ Update copyright attributions.
* debian/libsolv0.symbols:
+ Update symbols. Remove flawed part of the file that contained
libsolvext.so.0 symbol names.
2017-11-03 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.30-1) unstable; urgency=medium
[ Héctor Orón Martínez ]
* New upstream release.
* debian/control: bump standards version
+ switch priority extra to optional
* debian/control: move libsolv0 and libsolvext0 to section libs
* debian/libsolv0.symbols: update
[ Mike Gabriel ]
* debian/patches:
+ Drop 0001_get-rid-of-path-max.patch as a file. The series file already had
this patched removed by Héctor Orón Martínez.
2017-09-18 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.29-1) unstable; urgency=medium
* New upstream release.
* debian/patches:
+ Drop 1008_cmake-python-version.patch. Applied upstream.
+ Rebase patches against recent upstream release.
+ Add 0001_get-rid-of-path-max.patch. Fix FTBFS on Debian GNU/Hurd where
PATH_MAX is not defined.
* debian/rules:
+ Use tarball from upstream URL as is. Don't repack it anymore.
* debian/copyright:
+ Update auto-generated copyright.in.
+ Update copyright attributions.
2017-07-24 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.28-2) unstable; urgency=medium
[ gregor herrmann ]
* Fix "python2.7/cmake: find_package called with invalid argument
"2.7.13+"":
Add 1008_cmake-python-version.patch to sanitize PYTHONLIBS_VERSION_STRING
before passing it to 'FIND_PACKAGE (PythonInterp)'.
(Closes: #867514)
2017-07-06 - Mike Gabriel <sunweaver@debian.org>
libsolv (0.6.28-1) unstable; urgency=medium
* New upstream release. (Closes: #865033).
* debian/libsolv0.symbols:
+ Update symbols file.
* debian/control:
+ Fix typo in D (python3-pampy): Change ${python:Depends} to
${python3:Depends}. Spotted by Adrian Bunk. (Closes: #867407).
+ Bump Standards-Version: to 4.0.0. No changes needed.
* debian/copyright:
+ Update copyright attributions.
* debian/libsolvext0-dev.install:
+ Add usr/lib/*/pkgconfig/libsolvext.pc to list of files to install
into libsolvext0-dev.

See Also

Package Description
libsolv-tools_0.6.35-2+b2_i386.deb dependency solver using a satisfiability algorithm (command-line tools)
libsolv0-dev_0.6.35-2+b2_i386.deb dependency solver using a satisfiability algorithm (development files)
libsolv0_0.6.35-2+b2_i386.deb dependency solver using a satisfiability algorithm (shared library)
libsolvext0-dev_0.6.35-2+b2_i386.deb dependency solver using a satisfiability algorithm (ext development files)
libsolvext0_0.6.35-2+b2_i386.deb dependency solver using a satisfiability algorithm (extensions)
libsombok-dev_2.4.0-2_i386.deb Unicode Text Segmentation library (development files)
libsombok3_2.4.0-2_i386.deb Unicode Text Segmentation library
libsonic-dev_0.2.0-7_i386.deb Header file for linking to libsonic
libsonic-java_0.2.0-7_all.deb Simple library to speed up or slow down speech - Java bindings
libsonic0_0.2.0-7_i386.deb Simple library to speed up or slow down speech
libsope-dev_4.0.7-1_i386.deb SKYRiX Object Publishing Environment (development files)
libsope1_4.0.7-1_i386.deb SKYRiX Object Publishing Environment (shared libraries)
libsopt-dev_2.0.0-5_i386.deb Development package for Sparse OPTimisation library
libsopt2.0_2.0.0-5_i386.deb Sparse OPTimisation shared library
libsoqt520-dev_1.6.0~ea5cd76+ds1-1_i386.deb Qt5 GUI component toolkit for Inventor - development
Advertisement
Advertisement