libsndfile1_1.0.28-6_i386.deb


Advertisement

Description

libsndfile1 - Library for reading/writing audio files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsndfile1_1.0.28-6_i386.deb
Package name libsndfile1
Package version 1.0.28
Package release 6
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.mega-nerd.com/libsndfile/
License -
Maintainer Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Download size 267.65 KB
Installed size 666.00 KB
libsndfile is a library of C routines for reading and writing files containing
sampled audio data.
Various versions of WAV (integer, floating point, GSM, and compressed formats);
Microsoft PCM, A-law and u-law formats; AIFF, AIFC and RIFX; various AU/SND
formats (Sun/NeXT, Dec AU, G721 and G723 ADPCM); RAW header-less PCM files;
Amiga IFF/8SVX/16SV PCM files; Ensoniq PARIS  (.PAF); Apple's Core Audio Format
(CAF) and others.

Alternatives

Package Version Architecture Repository
libsndfile1_1.0.28-6_amd64.deb 1.0.28 amd64 Debian Main
libsndfile1 - - -

Requires

Name Value
libc6 >= 2.4
libflac8 >= 1.3.0
libogg0 >= 1.0rc3
libvorbis0a >= 1.2.3
libvorbisenc2 >= 1.2.3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsndfile1_1.0.28-6_i386.deb
Source Package libsndfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsndfile1 deb package:
    # sudo apt-get install libsndfile1

Files

Path
/usr/lib/i386-linux-gnu/libsndfile.so.1
/usr/lib/i386-linux-gnu/libsndfile.so.1.0.28
/usr/share/doc/libsndfile1/changelog.Debian.gz
/usr/share/doc/libsndfile1/changelog.gz
/usr/share/doc/libsndfile1/copyright

Changelog

2019-03-08 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-6) unstable; urgency=medium
* Backported fix for out-of-bound reading (CVE-2019-3832) (Closes: #922372)
2019-02-12 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-5) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/changelog: Remove trailing whitespaces
[ Felipe Sateler ]
* Change maintainer address to debian-multimedia@lists.debian.org
[ IOhannes m zmölnig (Debian/GNU) ]
* Normalize patches with 'gbp pq'
* Add patch to fix buffer overflows in alaw/ulaw code
(CVE-2018-19661, CVE-2018-19662, CVE-2017-17456 and CVE-2017-17457).
Thanks to Hugo Lefeuvre <hle@owl.eu.com> (Closes: #884735)
* Patch to fix division by zero (CVE-2017-14634)
Thanks to Fabian Greffrath <fabian@greffrath.com> (Closes: #876783)
* Patch to fix heap read overflow (CVE-2018-19758)
Thanks to Erik de Castro Lopo <erikd@mega-nerd.com> (Closes: #917416)
* Patch to ensure that maxnum channels is not exceeded.
Thanks to Brett T. Warden <brett.t.warden@intel.com>
* Declare that "root" is not required to build this package
* Removed whitespace at end of d/changelog
* Bumped dh compat to 12
* Bump standards version to 4.3.0
2017-08-17 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-4) unstable; urgency=medium
* Moved maintainance to pkg-multimedia team
* Made examples buildable (and build reproducible)
* Dropped doubly installed docs
* Dropped B-D on autotools-dev
* Bumped standards version to 4.0.1
2017-07-12 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-3) unstable; urgency=medium
* Backported heap-overflow fix from upstream.
2017-06-20 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-2) unstable; urgency=medium
* Backported fixes for RF64 support on armel/armhf (Closes: #865344)
2017-06-20 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.28-1) unstable; urgency=medium
* New upstream version 1.0.28
* d/patches/
* Removed patches applied upstream
* Refreshed patches
* Backported patch for fixing CVE-2017-6892
(Closes: #864704)
* Fixed more typos
* d/control: single line per Depends
* Switched packaging to shorthand dh
* Build automatic debug packages
* Dropped setting of DEB_*_GNU_TYPE and friends
* Raised debhelper compat to 10
* Dropped B-D on dh-autoreconf
* B-D on autotools-dev
* Use DEP5 for d/copyright
* Bumped standards version to 4.0.0
*
2017-05-28 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.27-3) unstable; urgency=medium
* Mentioned CVEs fixed by fix_bufferoverflows.patch
(CVE-2017-7741, CVE-2017-7586, CVE-2017-7585)
* Backported patch for error handling of malicious/broken FLAC files
(CVE-2017-7742, CVE-2017-7741, CVE-2017-7585)
(Closes: #860255)
* Backported patch to fix buffer read overflow in FLAC code
(CVE-2017-8362)
(Closes: #862204)
* Backported patches to fix memory leaks in FLAC code
(CVE-2017-8363)
(Closes: #862203)
* Backported patch to fix buffer overruns in FLAC-code
(CVE-2017-8365, CVE-2017-8363, CVE-2017-8361)
(Closes: #862205, #862203, #862202)
* Added Vcs-* stanzas to d/control
2017-04-04 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
libsndfile (1.0.27-2) unstable; urgency=medium
* Backported fixes for buffer-write overflows from 1.0.28.
Thanks to Erik de Castro Lopo
* Added myself to uploaders

See Also

Package Description
libsndifsdl2-dev_0.8.3-2_i386.deb SDL2-based sound support for the fizmo interpreter
libsndio-dev_1.5.0-3_i386.deb Small audio and MIDI framework from OpenBSD, development files
libsndio7.0_1.5.0-3_i386.deb Small audio and MIDI framework from OpenBSD, runtime libraries
libsndobj-dev_2.6.7+ds1-1_i386.deb Sound Object library (development files)
libsndobj2v5_2.6.7+ds1-1_i386.deb Sound Object library
libsnl-dev_0.2.1.svn.18-1.1_i386.deb Simple Nurbs Library (development files)
libsnl0_0.2.1.svn.18-1.1_i386.deb Simple Nurbs Library
libsnmp-base_5.7.3+dfsg-5_all.deb SNMP configuration script, MIBs and documentation
libsnmp-dev_5.7.3+dfsg-5_i386.deb SNMP (Simple Network Management Protocol) development files
libsnmp-extension-passpersist-perl_0.07-2_all.deb Generic pass/pass_persist extension framework for Net-SNMP
libsnmp-info-perl_3.65-1_all.deb Object Oriented Perl5 Interface to Network devices and MIBs through SNMP
libsnmp-mib-compiler-perl_0.06-2.2_all.deb a MIB Compiler supporting SMIv1 and SMIv2
libsnmp-multi-perl_2.1-4_all.deb Perform SNMP operations on multiple hosts simultaneously
libsnmp-perl_5.7.3+dfsg-5_i386.deb SNMP (Simple Network Management Protocol) Perl5 support
libsnmp-session-perl_1.14~git20130523.186a005-4_all.deb Perl support for accessing SNMP-aware devices
Advertisement
Advertisement