libsilly-dev_0.1.0-8_i386.deb


Advertisement

Description

libsilly-dev - simple image loading library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsilly-dev_0.1.0-8_i386.deb
Package name libsilly-dev
Package version 0.1.0
Package release 8
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://www.cegui.org.uk
License -
Maintainer Muammar El Khatib <muammar@debian.org>
Download size 25.65 KB
Installed size 163.00 KB
The aim of Simple Image Loading LibrarY is to provide a simple library for
loading image in the context of CEGUI.
The library supports only the most common image format. The project was
initialy launch in order to provide an MIT based replacement of DevIL with
less image format supported and focused on loading image only.

Alternatives

Package Version Architecture Repository
libsilly-dev_0.1.0-8_amd64.deb 0.1.0 amd64 Debian Main
libsilly-dev - - -

Requires

Name Value
libsilly = 0.1.0-8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsilly-dev_0.1.0-8_i386.deb
Source Package silly

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsilly-dev deb package:
    # sudo apt-get install libsilly-dev

Files

Path
/usr/include/SILLY/SILLY.h
/usr/include/SILLY/SILLYBase.h
/usr/include/SILLY/SILLYDataSource.h
/usr/include/SILLY/SILLYDataSource.icpp
/usr/include/SILLY/SILLYFileDataSource.h
/usr/include/SILLY/SILLYFileDataSource.icpp
/usr/include/SILLY/SILLYImage.h
/usr/include/SILLY/SILLYImage.icpp
/usr/include/SILLY/SILLYImageContext.h
/usr/include/SILLY/SILLYImageContext.icpp
/usr/include/SILLY/SILLYImageLoader.h
/usr/include/SILLY/SILLYImageLoader.icpp
/usr/include/SILLY/SILLYImageLoaderManager.h
/usr/include/SILLY/SILLYImageLoaderManager.icpp
/usr/include/SILLY/SILLYMemoryDataSource.h
/usr/include/SILLY/SILLYMemoryDataSource.icpp
/usr/include/SILLY/SILLYOptions.h
/usr/lib/libSILLY.a
/usr/lib/libSILLY.so
/usr/lib/pkgconfig/SILLY.pc
/usr/share/doc/libsilly-dev/AUTHORS
/usr/share/doc/libsilly-dev/ChangeLog
/usr/share/doc/libsilly-dev/changelog.Debian.gz
/usr/share/doc/libsilly-dev/changelog.gz
/usr/share/doc/libsilly-dev/copyright

Changelog

2016-08-07 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-8) unstable; urgency=medium
* Bump Standards-Version to 3.9.8.
* Updated libsilly.symbols. This will fix the FTBFS due to GCC-6 (Closes:
#831152).
2016-05-09 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-7) unstable; urgency=medium
* Package should not FTBFS when built with dpkg-buildpackage -A. Thanks to
Santiago Vila for providing a patch (Closes: #805960).
2016-04-13 - Tobias Frost <tobi@debian.org>
silly (0.1.0-6.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix symbols file: Some symbols are dpenent on the arch's bitsize.
(Closes: #820297), using arch-bits wildcards. This requires a
versioned B-D on dpkg-dev >= 1.18
2016-04-07 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-6) unstable; urgency=medium
* Bump Standards-Version to 3.9.7.
* debian/compat: bump to compat level 9.
* Updated libsilly.symbols.
* debian/rules: the option export DEB_BUILD_MAINT_OPTIONS = hardening=+all
is passed.
2016-04-06 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-5) unstable; urgency=medium
* debian/control:
+ Build-depends on libpng-dev instead of libpng16-dev (Closes: #812322).
2016-01-22 - Tobias Frost <tobi@debian.org>
silly (0.1.0-3.3) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS with libpng1.6 (Closes: #743391)
2016-01-08 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-4) experimental; urgency=medium
* Now the package is built using libpng6-dev. (Closes: #743391)
* Bump Standards-Version to 3.9.6.
* debian/control:
+ libjs-jquery added as dependency to link jquery.js.
* Now the package makes use of fortified libc functions.
2015-08-05 - Steve Langasek <vorlon@debian.org>
silly (0.1.0-3.2) unstable; urgency=medium
* Non-maintainer upload.
* Correct previous NMU patch which causes a broken .pc file and results
in reverse-dependencies failing to build.  (Closes: #773351).
2014-10-28 - Wookey <wookey@debian.org>
silly (0.1.0-3.1) unstable; urgency=low
* Non-maintainer upload.
* Use dh-autoreconf on build for new architectures (Closes: #758747)
2012-04-10 - Muammar El Khatib <muammar@debian.org>
silly (0.1.0-3) unstable; urgency=low
* debian/control:
+ Build-Depends on libpng12-dev was dropped in favour of libpng-dev.
(Closes: #638811, #662500). Besides, pkg-config was added to this field in
order of avoiding undefined symbol in libSILLY.so.1 and thus making it fail
to link to libpng. (Closes: #651608)
* Bump Standards-Version to 3.9.3. No changes were needed.

See Also

Package Description
libsilly-doc_0.1.0-8_all.deb simple image loading library (documentation)
libsilly_0.1.0-8_i386.deb development files for the simple image loading library
libsilo-bin_4.10.2.real-5+b1_i386.deb Utilities to manipulate libsilo files
libsilo-dev_4.10.2.real-5+b1_i386.deb Development files for SILO Scientific I/O library from LLNL
libsiloh5-0_4.10.2.real-5+b1_i386.deb SILO Science I/O library from LLNL
libsimage-dev_1.7.1~2c958a6.dfsg-5_i386.deb generic interface to various image file format libraries. Development files
libsimage20_1.7.1~2c958a6.dfsg-5_i386.deb generic interface to various image file format libraries
libsimavr-dev_1.6+dfsg-1_i386.deb AVR simulator development library
libsimavr-examples_1.6+dfsg-1_all.deb AVR simulator development examples
libsimavr2_1.6+dfsg-1_i386.deb AVR simulator shared library
libsimavrparts1_1.6+dfsg-1_i386.deb AVR simulator additional peripherals shared library
libsimbody-dev_3.6.1+dfsg-7_i386.deb SimTK multibody dynamics API - development files
libsimbody3.6_3.6.1+dfsg-7_i386.deb SimTK multibody dynamics API - shared library
libsimgear-dev_2018.3.2+dfsg-5_i386.deb Simulator Construction Gear -- development files
libsimgrid-dev_3.21+dfsg-4_i386.deb Development files for the SimGrid Toolkit
Advertisement
Advertisement