libsdl2-mixer-2.0-0_2.0.4+dfsg1-1_i386.deb


Advertisement

Description

libsdl2-mixer-2.0-0 - Mixer library for Simple DirectMedia Layer 2, libraries

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsdl2-mixer-2.0-0_2.0.4+dfsg1-1_i386.deb
Package name libsdl2-mixer-2.0-0
Package version 2.0.4+dfsg1
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.libsdl.org/projects/SDL_mixer/
License -
Maintainer Debian SDL packages maintainers <pkg-sdl-maintainers@lists.alioth.debian.org>
Download size 67.19 KB
Installed size 171.00 KB
SDL_mixer is a sample multi-channel audio mixer library.  It supports any
number of simultaneously playing channels of 16 bit stereo audio, plus a single
channel of music, mixed by the popular FLAC, modplug MOD, FluidSynth and
Timidity MIDI, Ogg Vorbis, and MAD or SMPEG MP3 libraries.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
libsdl2-mixer-2.0-0_2.0.4+dfsg1-1_amd64.deb 2.0.4+dfsg1 amd64 Debian Main
libsdl2-mixer-2.0-0 - - -

Requires

Name Value
libc6 >= 2.4
libflac8 >= 1.3.0
libfluidsynth1 >= 1.1.6-4~
libmodplug1 >= 1:0.8.8.5
libmpg123-0 >= 1.12.1
libopusfile0 >= 0.5
libsdl2-2.0-0 >= 2.0.9
libvorbis0a >= 1.1.2
libvorbisfile3 >= 1.1.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsdl2-mixer-2.0-0_2.0.4+dfsg1-1_i386.deb
Source Package libsdl2-mixer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsdl2-mixer-2.0-0 deb package:
    # sudo apt-get install libsdl2-mixer-2.0-0

Files

Path
/usr/lib/i386-linux-gnu/libSDL2_mixer-2.0.so.0
/usr/lib/i386-linux-gnu/libSDL2_mixer-2.0.so.0.2.2
/usr/share/doc/libsdl2-mixer-2.0-0/README.txt
/usr/share/doc/libsdl2-mixer-2.0-0/changelog.Debian.gz
/usr/share/doc/libsdl2-mixer-2.0-0/changelog.gz
/usr/share/doc/libsdl2-mixer-2.0-0/copyright

Changelog

2019-02-03 - Felix Geyer <fgeyer@debian.org>
libsdl2-mixer (2.0.4+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream version.
* Verify signature of upstream tarball.
* Switch from libmad to libmpg123 to avoid potential GPL licensing issues
of libsdl2-mixer users.
* Enable support for the Opus codec.
2018-10-19 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.2+dfsg1-3) unstable; urgency=medium
* Bump Policy Standards-Version to 4.2.1 (no changes needed)
* Switch to debhelper compat level v11
* d/watch:
- Set to version=4
- Use https for URL
* d/control:
- Use https for Homepage URL
- Set "Rules-Requires-Root: no"
- Update Vcs-* URLs
2017-11-09 - Fabian Greffrath <fabian@debian.org>
libsdl2-mixer (2.0.2+dfsg1-2) unstable; urgency=medium
* Team upload.
* Fix the shlib symlink again, thanks again Andreas Beckmann
(Closes: #877270).
2017-11-09 - Fabian Greffrath <fabian@debian.org>
libsdl2-mixer (2.0.2+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.0.2+dfsg1.
* Bump Build-Depends to libsdl2-dev (>= 2.0.7) as per configure.in
requirements.
* Remove bug-715461-soundfont_paths.patch, applied upstream.
* Bump SHLIBVER to 2.0.2 as INTERFACE_AGE has been reset in configure.in.
* Call aclocal before dh_autoreconf to fix FTBFS.
* Move the dbgsym-migration parameter to the dh_strip call.
* Add support for the fluidr3mono-gm-soundfont package:
+ Add fluidr3mono-gm-soundfont to the list of alternative recommends.
+ Add Breaks: libfluidsynth1 (<< 1.1.7~) to make sure we have a
version of that library available that supports the SF3 soundfont
format.
+ Add the soundfont file to the MIX_INIT_SOUNDFONT_PATHS macro.
2017-08-05 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.1+dfsg1-3) unstable; urgency=medium
* Update Recommends musescore-soundfont-gm -> timgm6mb-soundfont, thanks
Thorsten Glaser (Closes: #870793)
2017-07-29 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.1+dfsg1-2) unstable; urgency=medium
* Bump Policy Standards-Version to 4.0.0 (no changes needed)
* Switch to debhelper compat level v10
- dh flags --parallel are not needed
- autoreconf is invoked by default
* disable autoheader (invoked automatically by autoreconf),
necessary in order to use debhelper compat level v10 without
overriding dh-autoreconf calls
* Use automatic dbgsym packages, drop -dbg
* Update Vcs-* URLs
2016-01-26 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.1+dfsg1-1) unstable; urgency=medium
* New upstream release
* d/examples/Makefile: link against SDL2_mixer.  Thanks Riku Saikkonen.
(Closes: #774717)
* d/patches:
- Remove fix-750706-upstream-8ef083375857.patch, backported from upstream
2014-10-25 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.0+dfsg1-5) unstable; urgency=medium
* Add patch fix-750706-upstream-8ef083375857.patch backported from
upstream to fix playing speed with timidity backend.  Thanks Sylvain
Beucler (Closes: #750706)
2014-10-25 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.0+dfsg1-4) unstable; urgency=medium
* Bump Policy Standards-Version to 3.9.6 (no changes needed)
* Copy patch bug-715461-soundfont_paths.patch from sdl-mixer1.2 to use
better quality sounds than those of freepats.  Thanks Fabian Greffrath
(Closes: #766019)
2014-03-09 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl2-mixer (2.0.0+dfsg1-3) unstable; urgency=low
* Bump Policy Standards-Version to 3.9.5 (no changes needed)
* Do not call dh_autoreconf with autogen.sh as parameter, and use
instead other methods to force the update of ltmain.sh and
config.{sub,guess} files, needed when having new architectures such as
arm64 (Closes: #727435)

See Also

Package Description
libsdl2-mixer-dev_2.0.4+dfsg1-1_i386.deb Mixer library for Simple DirectMedia Layer 2, development files
libsdl2-net-2.0-0_2.0.1+dfsg1-4_i386.deb Network library for Simple DirectMedia Layer 2, libraries
libsdl2-net-dev_2.0.1+dfsg1-4_i386.deb Network library for Simple DirectMedia Layer 2, development files
libsdl2-ttf-2.0-0_2.0.15+dfsg1-1_i386.deb TrueType Font library for Simple DirectMedia Layer 2, libraries
libsdl2-ttf-dev_2.0.15+dfsg1-1_i386.deb TrueType Font library for Simple DirectMedia Layer 2, development files
libsdo-api-java-doc_1.1.1-1_all.deb Documentation for libsdo-api-java
libsdo-api-java_1.1.1-1_all.deb Service Data Objects 2.1 Java API spec
libsdp-api-java_1.0-1_all.deb SDP API for Java
libseafile-dev_6.2.11-1_i386.deb Development files for the Seafile Client
libseafile0_6.2.11-1_i386.deb Shared library for the Seafile Client
libsearch-elasticsearch-client-1-0-perl_5.02-1_all.deb Module to add client support for Elasticsearch 1.x
libsearch-elasticsearch-client-2-0-perl_5.02-1_all.deb Thin client with full support for Elasticsearch 2.x APIs
libsearch-elasticsearch-perl_6.00-1_all.deb Perl client for Elasticsearch
libsearch-gin-perl_0.11-2_all.deb Perl module for Generalized Inverted Indexing
libsearch-queryparser-perl_0.94-1_all.deb Perl module to parse URI query strings into a data structure
Advertisement
Advertisement