libsdl-console_2.1-6_i386.deb


Advertisement

Description

libsdl-console - Console that can be added to any SDL application, libraries

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libsdl-console_2.1-6_i386.deb
Package name libsdl-console
Package version 2.1
Package release 6
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://sourceforge.net/projects/sdlconsole/
License -
Maintainer Debian SDL packages maintainers <pkg-sdl-maintainers@lists.alioth.debian.org>
Download size 15.61 KB
Installed size 53.00 KB
This library provides a console similar to the consoles in Quake and other
games but with lots of added features.
A console is meant to be a very simple way of interacting with a program
and executing commands. Commands are linked to the console with callback
functions so that when a command is typed in, a specific function is
executed automatically.
This package contains the runtime library.

Alternatives

Package Version Architecture Repository
libsdl-console_2.1-6_amd64.deb 2.1 amd64 Debian Main
libsdl-console - - -

Requires

Name Value
libc6 >= 2.4
libsdl-image1.2 >= 1.2.12~
libsdl1.2debian >= 1.2.11

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsdl-console_2.1-6_i386.deb
Source Package libsdl-console

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsdl-console deb package:
    # sudo apt-get install libsdl-console

Files

Path
/usr/lib/i386-linux-gnu/libSDL_console-2.1.so.0
/usr/lib/i386-linux-gnu/libSDL_console-2.1.so.0.0.0
/usr/share/doc/libsdl-console/changelog.Debian.gz
/usr/share/doc/libsdl-console/copyright
/usr/share/lintian/overrides/libsdl-console

Changelog

2018-10-19 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl-console (2.1-6) unstable; urgency=medium
* Bump Policy Standards-Version to 4.2.1 (no changes needed)
* Switch to debhelper compat level 11
- Drop 'docs/*.jpg' line from libsdl-console-dev.docs, the files do
not exist and dh_installdocs exits with error in this compat level
* Set "Rules-Requires-Root: no" in d/control
* Drop explicit build-dependency on "dpkg-dev (>= 1.16.1~)", this
version is now satisfied everywhere
* d/watch:
- Switch to version=4
- Use https in URL
* d/control, d/copyright: Use updated URLs of Homepage and use https in
copyright Format
* d/control: Update Vcs-* URLs
2017-06-21 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl-console (2.1-5) unstable; urgency=medium
* Bump Policy Standards-Version to 4.0.0 (no changes needed)
* Switch to debhelper compat level v10
- dh flags --parallel are not needed
- autoreconf is invoked by default
* Update Vcs-* URLs
* Minor updates to d/copyright
- quell lintian about GPL and LGPL names
- update maintainer address to @debian.org
2014-03-08 - Manuel A. Fernandez Montecelo <mafm@debian.org>
libsdl-console (2.1-4) unstable; urgency=medium
* Bump Policy Standards-Version to 3.9.5 (no changes needed)
* Remove field "DM-Upload-Allowed: yes", obsolete
* Change maintainer address to @debian.org
2012-05-31 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
libsdl-console (2.1-3) unstable; urgency=low
* Remove wrongly used "Multi-Arch: same" in -dev package.  One of the files
shipped is actually different across architectures (Closes: #674494); thanks
Jakub Wilk.
2012-05-08 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
libsdl-console (2.1-2) unstable; urgency=low
* New upstream version (Closes: #207994)
* Complete overhaul of the package:
- debian/source/format to '3.0 (quilt)'
- Extensive modifications for debhelper compat v9, including Multi-Arch,
build-hardening and all goodies
- Bump Policy Standars-Version to 3.9.3
- debian/copyright rewritten with appropriate standard format
- Revisit all patches
- Remove all previous maintainers, inactive/unresponsive for years
- updated lintian override
2008-04-22 - Aurelien Jarno <aurel32@debian.org>
libsdl-console (1.3-5) unstable; urgency=low
[ Aurelien Jarno ]
* debian/control:
+ Make the package binNMU safe. 
+ Set policy to 3.7.3.
* debian/rules:
+ Call "make clean" instead of "make distclean", as the later target
does not exists. (Closes: bug#424535).
+ Switch to dh_install from dh_movefiles
* debian/copyright:
+ Add copyright entry.
2006-03-02 - Sam Hocevar (Debian packages) <sam+deb@zoy.org>
libsdl-console (1.3-4) unstable; urgency=low
* Moved development to the pkg-sdl Alioth project.
* debian/rules:
+ Use quilt for patch management.
+ Do not compress the examples.
* debian/control:
+ Added missing "Section: libs" for the source package.
+ Build-depend on quilt.
+ Set the SDL team as the maintainer and added its members to the
uploaders field.
+ Build-depend on debhelper (>= 4.0).
+ Set policy to 3.6.2.
* debian/compat:
+ Set compatibility level to 4.
* debian/patches/000_autoconf.diff:
+ Put the autoconf stuff in this separate patch.
+ Build with -Wall.
* debian/patches/010_examples.diff:
+ Fix the example and its makefile.

See Also

Package Description
libsdl-gfx1.2-5_2.0.25-11_i386.deb drawing and graphical effects extension for SDL
libsdl-gfx1.2-dev_2.0.25-11_i386.deb development files for SDL_gfx
libsdl-gfx1.2-doc_2.0.25-11_all.deb documentation files for SDL_gfx
libsdl-image1.2-dev_1.2.12-10+deb10u1_i386.deb Image loading library for Simple DirectMedia Layer 1.2, development files
libsdl-image1.2_1.2.12-10+deb10u1_i386.deb Image loading library for Simple DirectMedia Layer 1.2, libraries
libsdl-kitchensink-dev_1.0.7-1_i386.deb FFmpeg and SDL2 based library for audio and video playback - Development files
libsdl-kitchensink1_1.0.7-1_i386.deb FFmpeg and SDL2 based library for audio and video playback
libsdl-mixer1.2-dev_1.2.12-15_i386.deb Mixer library for Simple DirectMedia Layer 1.2, development files
libsdl-mixer1.2_1.2.12-15_i386.deb Mixer library for Simple DirectMedia Layer 1.2, libraries
libsdl-net1.2-dev_1.2.8-6_i386.deb Network library for Simple DirectMedia Layer 1.2, development files
libsdl-net1.2_1.2.8-6_i386.deb Network library for Simple DirectMedia Layer 1.2, libraries
libsdl-ocaml-dev_0.9.1-2+b4_i386.deb OCaml bindings for SDL - development files
libsdl-ocaml_0.9.1-2+b4_i386.deb OCaml bindings for SDL - runtime files
libsdl-pango-dev_0.1.2-8_i386.deb text rendering with Pango in SDL applications (development)
libsdl-pango1_0.1.2-8_i386.deb text rendering with Pango in SDL applications (shared library)
Advertisement
Advertisement